summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2013-09-13 06:56:08 +0000
committerMark Wright <gienah@gentoo.org>2013-09-13 06:56:08 +0000
commit4ba277bb250de5e04f59e0213a3583f88c96e06b (patch)
tree1da08632ac98e0a8f9778be92911c8fa86f77ee0 /sci-mathematics/agda-executable/agda-executable-2.3.0.1-r2.ebuild
parentAdd yesod-platform (diff)
downloadgentoo-2-4ba277bb250de5e04f59e0213a3583f88c96e06b.tar.gz
gentoo-2-4ba277bb250de5e04f59e0213a3583f88c96e06b.tar.bz2
gentoo-2-4ba277bb250de5e04f59e0213a3583f88c96e06b.zip
agda-executable must be rebuilt when agda is upgraded
(Portage version: 2.2.3/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'sci-mathematics/agda-executable/agda-executable-2.3.0.1-r2.ebuild')
-rw-r--r--sci-mathematics/agda-executable/agda-executable-2.3.0.1-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sci-mathematics/agda-executable/agda-executable-2.3.0.1-r2.ebuild b/sci-mathematics/agda-executable/agda-executable-2.3.0.1-r2.ebuild
new file mode 100644
index 000000000000..6c0254403074
--- /dev/null
+++ b/sci-mathematics/agda-executable/agda-executable-2.3.0.1-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda-executable/agda-executable-2.3.0.1-r2.ebuild,v 1.1 2013/09/13 06:56:08 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="bin"
+inherit haskell-cabal eutils
+
+MY_PN="Agda-executable"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Command-line program for type-checking and compiling Agda programs"
+HOMEPAGE="http://wiki.portal.chalmers.se/agda/"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=sci-mathematics/agda-2.3.0.1:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ >=dev-lang/ghc-6.10.4"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ cabal-mksetup
+ sed -e 's@Agda == 2.3.0.1@Agda >= 2.3.0.1@' \
+ -i "${S}/${MY_PN}.cabal" || die "Could not loosen dependencies"
+}