summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-12-28 05:47:39 +0000
committerMark Wright <gienah@gentoo.org>2012-12-28 05:47:39 +0000
commit472b265bd83b1483405cabe0891fce3e20f72f85 (patch)
treec7a61e1227da5039c969f2c7a4ebb00ac56452bd /sci-mathematics/agda
parentupdated license and fixed bug 448730 (diff)
downloadgentoo-2-472b265bd83b1483405cabe0891fce3e20f72f85.tar.gz
gentoo-2-472b265bd83b1483405cabe0891fce3e20f72f85.tar.bz2
gentoo-2-472b265bd83b1483405cabe0891fce3e20f72f85.zip
Loosen binary dep, patch for hashable 1.2
(Portage version: 2.1.11.38/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'sci-mathematics/agda')
-rw-r--r--sci-mathematics/agda/ChangeLog8
-rw-r--r--sci-mathematics/agda/agda-2.3.2-r2.ebuild98
-rw-r--r--sci-mathematics/agda/files/agda-2.3.2-hashable-1.2.patch66
3 files changed, 171 insertions, 1 deletions
diff --git a/sci-mathematics/agda/ChangeLog b/sci-mathematics/agda/ChangeLog
index 98d87c94e978..d4a3439b3b1d 100644
--- a/sci-mathematics/agda/ChangeLog
+++ b/sci-mathematics/agda/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/agda
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/ChangeLog,v 1.19 2012/11/18 07:48:34 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/ChangeLog,v 1.20 2012/12/28 05:47:39 gienah Exp $
+
+*agda-2.3.2-r2 (28 Dec 2012)
+
+ 28 Dec 2012; Mark Wright <gienah@gentoo.org> +agda-2.3.2-r2.ebuild,
+ +files/agda-2.3.2-hashable-1.2.patch:
+ Loosen binary dep, patch for hashable 1.2
*agda-2.3.2 (18 Nov 2012)
diff --git a/sci-mathematics/agda/agda-2.3.2-r2.ebuild b/sci-mathematics/agda/agda-2.3.2-r2.ebuild
new file mode 100644
index 000000000000..97e8c26664d5
--- /dev/null
+++ b/sci-mathematics/agda/agda-2.3.2-r2.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/agda-2.3.2-r2.ebuild,v 1.1 2012/12/28 05:47:39 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="lib profile"
+inherit haskell-cabal eutils elisp-common
+
+MY_PN="Agda"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A dependently typed functional programming language and proof assistant"
+HOMEPAGE="http://wiki.portal.chalmers.se/agda/"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="epic +stdlib"
+
+RDEPEND=">=dev-haskell/binary-0.4.4:=[profile?]
+ <dev-haskell/binary-0.7:=[profile?]
+ =dev-haskell/deepseq-1.3*:=[profile?]
+ epic? ( dev-lang/epic:=[profile?] )
+ >=dev-haskell/geniplate-0.6.0.3:=[profile?]
+ <dev-haskell/geniplate-0.7:=[profile?]
+ >=dev-haskell/hashable-1.1.2.3:=[profile?]
+ <dev-haskell/hashable-1.3:=[profile?]
+ =dev-haskell/hashtables-1.0*:=[profile?]
+ >=dev-haskell/haskeline-0.6.3.2:=[profile?]
+ <dev-haskell/haskeline-0.8:=[profile?]
+ >=dev-haskell/haskell-src-exts-1.9.6:=[profile?]
+ <dev-haskell/haskell-src-exts-1.14:=[profile?]
+ >=dev-haskell/mtl-2.0:=[profile?]
+ <dev-haskell/mtl-2.2:=[profile?]
+ <dev-haskell/parallel-3.3:=[profile?]
+ >=dev-haskell/quickcheck-2.3:=[profile?]
+ <dev-haskell/quickcheck-2.6:=[profile?]
+ =dev-haskell/text-0.11*:=[profile?]
+ =dev-haskell/unordered-containers-0.2*:=[profile?]
+ =dev-haskell/xhtml-3000.2*:=[profile?]
+ >=dev-haskell/zlib-0.4.0.1:=[profile?]
+ <dev-haskell/zlib-0.6:=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+ virtual/emacs
+ app-emacs/haskell-mode"
+PDEPEND="stdlib? ( sci-mathematics/agda-stdlib )"
+DEPEND="${RDEPEND}
+ dev-haskell/alex
+ >=dev-haskell/cabal-1.8
+ dev-haskell/happy"
+
+SITEFILE="50${PN}2-gentoo.el"
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ CABAL_FILE=${MY_PN}.cabal cabal_chdeps \
+ 'binary >= 0.4.4 && < 0.6' 'binary >= 0.4.4 && < 0.7' \
+ 'hashable >= 1.1.2.3 && < 1.2' 'hashable >= 1.1.2.3 && < 1.3'
+ epatch "${FILESDIR}/${PN}-2.3.2-hashable-1.2.patch"
+ sed -e '/.*emacs-mode.*$/d' \
+ -e '/^executable agda/,$d' \
+ -i "${S}/${MY_PN}.cabal" \
+ || die "Could not remove agda and agda-mode from ${MY_PN}.cabal"
+ cabal-mksetup
+ if use epic && use stdlib; then
+ ewarn "Note that the agda-stdlib README:"
+ ewarn "http://www.cse.chalmers.se/~nad/listings/lib/README.html"
+ ewarn 'says: "Currently the library does not support the Epic or JavaScript compiler'
+ ewarn 'backends." Hence you may wish to remove the epic use flag if you wish to use'
+ ewarn "the Agda standard library."
+ fi
+}
+
+src_configure() {
+ cabal_src_configure $(cabal_flag epic)
+}
+
+src_install() {
+ haskell-cabal_src_install
+ elisp-install ${PN} src/data/emacs-mode/*.el \
+ || die "Failed to install emacs mode"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" \
+ || die "Failed to install elisp site file"
+}
+
+pkg_postinst() {
+ ghc-package_pkg_postinst
+ elisp-site-regen
+}
+
+pkg_postrm() {
+ ghc-package_pkg_prerm
+ elisp-site-regen
+}
diff --git a/sci-mathematics/agda/files/agda-2.3.2-hashable-1.2.patch b/sci-mathematics/agda/files/agda-2.3.2-hashable-1.2.patch
new file mode 100644
index 000000000000..407b3616fa20
--- /dev/null
+++ b/sci-mathematics/agda/files/agda-2.3.2-hashable-1.2.patch
@@ -0,0 +1,66 @@
+--- Agda-2.3.2-orig/src/full/Agda/Syntax/Abstract/Name.hs 2012-11-12 11:25:21.000000000 +1100
++++ Agda-2.3.2/src/full/Agda/Syntax/Abstract/Name.hs 2012-12-18 22:10:22.241674353 +1100
+@@ -239,8 +239,13 @@
+ show x = show (nameConcrete x) -- ++ "|" ++ show (nameId x)
+
+ instance Hashable Name where
++#if MIN_VERSION_hashable(1,2,0)
++ {-# INLINE hashWithSalt #-}
++ hashWithSalt salt = (hashWithSalt salt) . nameId
++#else
+ {-# INLINE hash #-}
+ hash = hash . nameId
++#endif
+
+ instance Show QName where
+ show q = concat $ intersperse "." $ map show $ qnameToList q
+@@ -255,8 +260,13 @@
+ compare = compare `on` qnameName
+
+ instance Hashable QName where
++#if MIN_VERSION_hashable(1,2,0)
++ {-# INLINE hashWithSalt #-}
++ hashWithSalt salt = (hashWithSalt salt) . qnameName
++#else
+ {-# INLINE hash #-}
+ hash = hash . qnameName
++#endif
+
+ instance HasRange Name where
+ getRange = getRange . nameConcrete
+--- Agda-2.3.2-orig/src/full/Agda/Syntax/Common.hs 2012-11-12 11:25:21.000000000 +1100
++++ Agda-2.3.2/src/full/Agda/Syntax/Common.hs 2012-12-18 22:11:29.730050687 +1100
+@@ -272,8 +272,13 @@
+ fromEnum (NameId n _) = fromIntegral n
+
+ instance Hashable NameId where
++#if MIN_VERSION_hashable(1,2,0)
++ {-# INLINE hashWithSalt #-}
++ hashWithSalt salt (NameId n m) = hashWithSalt salt (n, m)
++#else
+ {-# INLINE hash #-}
+ hash (NameId n m) = hash (n, m)
++#endif
+
+ newtype Constr a = Constr a
+
+--- Agda-2.3.2-orig/src/full/Agda/Utils/Pointer.hs 2012-11-12 11:25:22.000000000 +1100
++++ Agda-2.3.2/src/full/Agda/Utils/Pointer.hs 2012-12-18 22:12:18.834049775 +1100
+@@ -1,4 +1,4 @@
+-{-# LANGUAGE DeriveDataTypeable #-}
++{-# LANGUAGE DeriveDataTypeable, CPP #-}
+ module Agda.Utils.Pointer
+ ( Ptr, newPtr, derefPtr, setPtr
+ , updatePtr, updatePtrM
+@@ -71,7 +71,11 @@
+ compare = compare `on` ptrTag
+
+ instance Hashable (Ptr a) where
++#if MIN_VERSION_hashable(1,2,0)
++ hashWithSalt salt = (hashWithSalt salt) . ptrTag
++#else
+ hash = hash . ptrTag
++#endif
+
+ instance NFData (Ptr a) where
+