summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-07-26 11:37:35 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-07-26 11:37:35 +0000
commit9a9cef0d20af58ae62ec7c1c6bb651c35a57c143 (patch)
treee95db99763c288af6aa95cd5b9c21de4a0b655b2 /sci-mathematics/agda
parentMake lirc compile against linux-2.6.26, thanks to enkil <enkil@cvmx.org> for ... (diff)
downloadgentoo-2-9a9cef0d20af58ae62ec7c1c6bb651c35a57c143.tar.gz
gentoo-2-9a9cef0d20af58ae62ec7c1c6bb651c35a57c143.tar.bz2
gentoo-2-9a9cef0d20af58ae62ec7c1c6bb651c35a57c143.zip
Fixed several compile and QA issues (fixes bug #232349). Disabled doc useflag for now since installation of html docs is broken.
(Portage version: 2.2_rc3/cvs/Linux 2.6.25-SENTINEL-5 i686)
Diffstat (limited to 'sci-mathematics/agda')
-rw-r--r--sci-mathematics/agda/ChangeLog10
-rw-r--r--sci-mathematics/agda/agda-1.0.2-r1.ebuild40
-rw-r--r--sci-mathematics/agda/agda-1.0.2.ebuild15
-rw-r--r--sci-mathematics/agda/files/agda-1.0.2-upstream-fixes.patch55
4 files changed, 91 insertions, 29 deletions
diff --git a/sci-mathematics/agda/ChangeLog b/sci-mathematics/agda/ChangeLog
index 2e50555d3b51..5cdc96c32bd7 100644
--- a/sci-mathematics/agda/ChangeLog
+++ b/sci-mathematics/agda/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/agda
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/ChangeLog,v 1.6 2007/10/31 13:28:20 dcoutts Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/ChangeLog,v 1.7 2008/07/26 11:37:35 markusle Exp $
+
+ 26 Jul 2008; Markus Dittrich <markusle@gentoo.org>
+ +files/agda-1.0.2-upstream-fixes.patch, agda-1.0.2.ebuild,
+ agda-1.0.2-r1.ebuild:
+ Fixed several compile and QA issues (fixes bug #232349). Disabled doc
+ useflag for now since installation of html docs is broken.
31 Oct 2007; Duncan Coutts <dcoutts@gentoo.org> agda-1.0.2.ebuild,
agda-1.0.2-r1.ebuild:
diff --git a/sci-mathematics/agda/agda-1.0.2-r1.ebuild b/sci-mathematics/agda/agda-1.0.2-r1.ebuild
index 74043aae9bd4..5e14612076b2 100644
--- a/sci-mathematics/agda/agda-1.0.2-r1.ebuild
+++ b/sci-mathematics/agda/agda-1.0.2-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/agda-1.0.2-r1.ebuild,v 1.2 2007/10/31 13:28:20 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/agda-1.0.2-r1.ebuild,v 1.3 2008/07/26 11:37:35 markusle Exp $
-inherit autotools elisp-common
+inherit elisp-common eutils
MY_PN="Agda"
S="${WORKDIR}/${MY_PN}-${PV}"
@@ -13,12 +13,12 @@ SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-${PV}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~x86"
-IUSE="doc emacs"
+KEYWORDS="~x86 ~amd64"
+IUSE="emacs"
DEPEND="dev-lang/ghc
- emacs? ( virtual/emacs )
- doc? ( dev-haskell/haddock )"
+ dev-haskell/mtl
+ emacs? ( virtual/emacs )"
RDEPEND=""
SITEFILE="50${PN}-gentoo.el"
@@ -26,29 +26,31 @@ SITEFILE="50${PN}-gentoo.el"
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}/agda-make_install.patch"
+ epatch "${FILESDIR}"/${PN}-make_install.patch
+ epatch "${FILESDIR}"/${P}-upstream-fixes.patch
+
+ sed -e "s:-package lang::" -i src/Makefile.in \
+ || die "Failed to fix Makfile.in"
}
src_compile() {
- cd "${S}"
econf --enable-newsyntax || die "./configure failed"
- emake || die "make failed"
- if use doc ; then
- emake html
- fi
+ emake -j1 || die "make failed"
+ #if use doc ; then
+ # emake html
+ #fi
}
src_install() {
+ emake ROOT="${D}" install || die "make install failed"
+ dosym /usr/lib/EmacsAgda/bin/emacsagda /usr/bin/emacsagda
+ dosym /usr/bin/emacsagda /usr/bin/agda
+
if use emacs; then
cd "${S}/elisp"
elisp-install ${PN} *.el
- elisp-site-file-install ${FILESDIR}/${SITEFILE}
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
fi
- cd "${S}/src"
- make prefix="${D}/usr" install || die "make install failed"
- dosym /usr/lib/EmacsAgda/bin/emacsagda /usr/bin/emacsagda
- dosym /usr/bin/emacsagda /usr/bin/agda
-
}
pkg_postinst() {
diff --git a/sci-mathematics/agda/agda-1.0.2.ebuild b/sci-mathematics/agda/agda-1.0.2.ebuild
index f031c3aa13c5..2dab0473253e 100644
--- a/sci-mathematics/agda/agda-1.0.2.ebuild
+++ b/sci-mathematics/agda/agda-1.0.2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/agda-1.0.2.ebuild,v 1.3 2007/10/31 13:28:20 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/agda-1.0.2.ebuild,v 1.4 2008/07/26 11:37:35 markusle Exp $
-inherit autotools elisp-common
+inherit elisp-common eutils
MY_PN="Agda"
S="${WORKDIR}/${MY_PN}-${PV}"
@@ -30,7 +30,6 @@ src_unpack() {
}
src_compile() {
- cd "${S}"
econf --enable-newsyntax || die "./configure failed"
emake || die "make failed"
if use doc ; then
@@ -40,12 +39,12 @@ src_compile() {
src_install() {
if use emacs; then
- cd "${S}/elisp"
+ cd "${S}"/elisp
elisp-install ${PN} *.el
- elisp-site-file-install ${FILESDIR}/${SITEFILE}
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
fi
- cd "${S}/src"
- make prefix="${D}/usr" install || die "make install failed"
+ cd "${S}"/src
+ make prefix="${D}"/usr install || die "make install failed"
dosym /usr/lib/EmacsAgda/bin/emacsagda /usr/bin/emacsagda
dosym /usr/bin/emacsagda /usr/bin/agda
diff --git a/sci-mathematics/agda/files/agda-1.0.2-upstream-fixes.patch b/sci-mathematics/agda/files/agda-1.0.2-upstream-fixes.patch
new file mode 100644
index 000000000000..40eea5bec836
--- /dev/null
+++ b/sci-mathematics/agda/files/agda-1.0.2-upstream-fixes.patch
@@ -0,0 +1,55 @@
+diff -Naur Agda-1.0.2/src/BasicEngineOps.hs-boot Agda-1.0.2.new/src/BasicEngineOps.hs-boot
+--- Agda-1.0.2/src/BasicEngineOps.hs-boot 2006-12-25 18:47:26.000000000 -0500
++++ Agda-1.0.2.new/src/BasicEngineOps.hs-boot 2008-07-26 06:29:02.000000000 -0400
+@@ -1,4 +1,4 @@
+-module BasicEngineOps where
++module BasicEngineOps (checkAndUpdate, solveCs) where
+ import MetaVars(MetaVar)
+ import ISynType(Exp)
+ import ProofMonad(PCM)
+diff -Naur Agda-1.0.2/src/Id.hs Agda-1.0.2.new/src/Id.hs
+--- Agda-1.0.2/src/Id.hs 2006-12-25 18:47:26.000000000 -0500
++++ Agda-1.0.2.new/src/Id.hs 2008-07-26 06:28:22.000000000 -0400
+@@ -157,7 +157,7 @@
+ "$" -> FInfixr 0
+ ">>" -> FInfixl 1
+ ">>=" -> FInfixl 1
+- "×" -> FInfixr 1
++ "\xD7"-> FInfixr 1 -- times
+ "||" -> FInfixr 2
+ "&&" -> FInfixr 3
+ "==" -> FInfix 4
+@@ -172,8 +172,8 @@
+ "-" -> FInfixl 6
+ "*" -> FInfixl 7
+ "/" -> FInfixl 7
+- "·" -> FInfixr 8
+- "°" -> FInfixr 8
++ "\xB7"-> FInfixr 8 -- cdot
++ "\xB0"-> FInfixr 8 -- circ
+ _ -> FInfixl 9
+
+
+diff -Naur Agda-1.0.2/src/Lex.hs Agda-1.0.2.new/src/Lex.hs
+--- Agda-1.0.2/src/Lex.hs 2006-12-25 18:47:26.000000000 -0500
++++ Agda-1.0.2.new/src/Lex.hs 2008-07-26 06:35:10.000000000 -0400
+@@ -307,7 +307,7 @@
+ isSym '>' = True; isSym '\\' = True; isSym '^' = True
+ isSym '|' = True; isSym ':' = True; isSym '-' = True; isSym '~' = True
+ isSym ',' = True
+-isSym c | c >= '\x80' = c `elem` "¡¢£¤¥¦§¨©ª«¬­®¯°±²³´µ¶·¸¹º»¼½¾¿×÷"
++isSym c | c >= '\x80' = ord c `elem` ([161..191] ++ [215,247])
+ --isSym c | c >= '\x80' = isSymbol c
+ isSym _ = False
+
+diff -Naur Agda-1.0.2/src/PreStrings.hs Agda-1.0.2.new/src/PreStrings.hs
+--- Agda-1.0.2/src/PreStrings.hs 2006-12-25 18:47:26.000000000 -0500
++++ Agda-1.0.2.new/src/PreStrings.hs 2008-07-26 06:28:36.000000000 -0400
+@@ -46,6 +46,6 @@
+ "Setoid","Elem","Equal","ref","sym",
+ "tran","El","Eq", "_V", "A",
+ "B", "x", "xs", "m","JMeq",
+- "same", "a", "b", "×"
++ "same", "a", "b", "\xD7" -- times
+ ]
+