summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-11-18 07:01:39 +0000
committerMark Wright <gienah@gentoo.org>2012-11-18 07:01:39 +0000
commitd94ae35c4e3ad9764a94291f5e3ec9390338dfb6 (patch)
tree04aa6c5ea0b6ded667b45896c3953bd632dc58f5 /sci-mathematics/agda
parenthaskeline 0.6.4.7 requires extensible-exceptions (diff)
downloadgentoo-2-d94ae35c4e3ad9764a94291f5e3ec9390338dfb6.tar.gz
gentoo-2-d94ae35c4e3ad9764a94291f5e3ec9390338dfb6.tar.bz2
gentoo-2-d94ae35c4e3ad9764a94291f5e3ec9390338dfb6.zip
Thanks to Naohiro Aota for adding patch for agda 2.3.0.1 to build with quickcheck 2.5
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'sci-mathematics/agda')
-rw-r--r--sci-mathematics/agda/ChangeLog9
-rw-r--r--sci-mathematics/agda/agda-2.3.0.1-r1.ebuild89
-rw-r--r--sci-mathematics/agda/files/agda-2.3.0.1-quickcheck-2.5.patch30
3 files changed, 127 insertions, 1 deletions
diff --git a/sci-mathematics/agda/ChangeLog b/sci-mathematics/agda/ChangeLog
index 08670771cef6..8c06a05c9fd4 100644
--- a/sci-mathematics/agda/ChangeLog
+++ b/sci-mathematics/agda/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-mathematics/agda
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/ChangeLog,v 1.17 2012/09/12 16:10:28 qnikst Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/ChangeLog,v 1.18 2012/11/18 07:01:39 gienah Exp $
+
+*agda-2.3.0.1-r1 (18 Nov 2012)
+
+ 18 Nov 2012; Mark Wright <gienah@gentoo.org> +agda-2.3.0.1-r1.ebuild,
+ +files/agda-2.3.0.1-quickcheck-2.5.patch:
+ Thanks to Naohiro Aota for adding patch for agda 2.3.0.1 to build with
+ quickcheck 2.5
12 Sep 2012; Alexander Vershilov <qnikst@gentoo.org> agda-2.3.0.1.ebuild,
agda-2.3.0.ebuild:
diff --git a/sci-mathematics/agda/agda-2.3.0.1-r1.ebuild b/sci-mathematics/agda/agda-2.3.0.1-r1.ebuild
new file mode 100644
index 000000000000..557ef6fa3242
--- /dev/null
+++ b/sci-mathematics/agda/agda-2.3.0.1-r1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/agda-2.3.0.1-r1.ebuild,v 1.1 2012/11/18 07:01:39 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="lib profile"
+inherit haskell-cabal eutils elisp-common
+
+MY_PN="Agda"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A dependently typed functional programming language and proof assistant"
+HOMEPAGE="http://wiki.portal.chalmers.se/agda/"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="epic +stdlib"
+
+RDEPEND=">=dev-haskell/binary-0.4.4:=[profile?]
+ <dev-haskell/binary-0.6:=[profile?]
+ epic? ( dev-lang/epic:=[profile?] )
+ =dev-haskell/hashable-1.1*:=[profile?]
+ =dev-haskell/hashtables-1.0*:=[profile?]
+ >=dev-haskell/haskeline-0.6.3.2:=[profile?]
+ <dev-haskell/haskeline-0.7:=[profile?]
+ >=dev-haskell/haskell-src-exts-1.9.6:=[profile?]
+ <dev-haskell/haskell-src-exts-1.14:=[profile?]
+ >=dev-haskell/mtl-2.0:=[profile?]
+ <dev-haskell/mtl-2.2:=[profile?]
+ >=dev-haskell/quickcheck-2.3:=[profile?]
+ <dev-haskell/quickcheck-2.6:=[profile?]
+ >=dev-haskell/syb-0.1:=[profile?]
+ <dev-haskell/syb-0.4:=[profile?]
+ =dev-haskell/xhtml-3000.2*:=[profile?]
+ >=dev-haskell/zlib-0.4.0.1:=[profile?]
+ <dev-haskell/zlib-0.6:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+ virtual/emacs
+ app-emacs/haskell-mode"
+PDEPEND="stdlib? ( sci-mathematics/agda-stdlib )"
+DEPEND="${RDEPEND}
+ dev-haskell/alex
+ >=dev-haskell/cabal-1.8
+ dev-haskell/happy"
+
+SITEFILE="50${PN}2-gentoo.el"
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-emacs.patch
+ epatch "${FILESDIR}"/${PN}-2.3.0.1-haskell-src-exts-1.13.patch
+ epatch "${FILESDIR}"/${PN}-2.3.0.1-mtl-2.1.patch
+ epatch "${FILESDIR}"/${PN}-2.3.0.1-quickcheck-2.5.patch
+ cabal-mksetup
+ if use epic && use stdlib; then
+ ewarn "Note that the agda-stdlib README:"
+ ewarn "http://www.cse.chalmers.se/~nad/listings/lib/README.html"
+ ewarn 'says: "Currently the library does not support the Epic or JavaScript compiler'
+ ewarn 'backends." Hence you may wish to remove the epic use flag if you wish to use'
+ ewarn "the Agda standard library."
+ fi
+}
+
+src_configure() {
+ cabal_src_configure $(cabal_flag epic)
+}
+
+src_install() {
+ haskell-cabal_src_install
+ elisp-install ${PN} src/data/emacs-mode/*.el \
+ || die "Failed to install emacs mode"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" \
+ || die "Failed to install elisp site file"
+}
+
+pkg_postinst() {
+ ghc-package_pkg_postinst
+ elisp-site-regen
+}
+
+pkg_postrm() {
+ ghc-package_pkg_prerm
+ elisp-site-regen
+}
diff --git a/sci-mathematics/agda/files/agda-2.3.0.1-quickcheck-2.5.patch b/sci-mathematics/agda/files/agda-2.3.0.1-quickcheck-2.5.patch
new file mode 100644
index 000000000000..51d5f8b0038f
--- /dev/null
+++ b/sci-mathematics/agda/files/agda-2.3.0.1-quickcheck-2.5.patch
@@ -0,0 +1,30 @@
+--- Agda-2.3.0.1-orig/Agda.cabal 2012-04-12 01:24:54.004394444 +1000
++++ Agda-2.3.0.1/Agda.cabal 2012-07-08 12:59:51.280014442 +1000
+@@ -76,7 +76,7 @@
+ if flag(epic)
+ build-depends: epic >= 0.1.13 && < 0.10
+ build-depends: mtl >= 2.0 && < 2.2,
+- QuickCheck >= 2.3 && < 2.5,
++ QuickCheck >= 2.3 && < 2.6,
+ haskell-src-exts >= 1.9.6 && < 1.14,
+ containers >= 0.1 && < 0.5,
+ pretty >= 1.0 && < 1.2,
+--- Agda-2.3.0.1-orig/src/full/Agda/Termination/Lexicographic.hs 2012-11-09 03:23:20.938830800 +0900
++++ Agda-2.3.0.1/src/full/Agda/Termination/Lexicographic.hs 2012-11-09 03:22:25.918728273 +0900
+@@ -1,3 +1,4 @@
++{-# LANGUAGE CPP #-}
+ -- | Lexicographic order search, more or less as defined in
+ -- \"A Predicative Analysis of Structural Recursion\" by
+ -- Andreas Abel and Thorsten Altenkirch.
+@@ -230,7 +231,11 @@
+ , quickCheck' prop_fromDiagonals
+ , quickCheck' prop_newBehaviour
+ , quickCheckWith' stdArgs{ maxSuccess = 50
++#if MIN_VERSION_QuickCheck(2,5,0)
++ , maxDiscardRatio = 4
++#else
+ , maxDiscard = 200
++#endif
+ , maxSize = 20
+ }
+ prop_lexOrder