summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2005-12-04 21:41:10 +0000
committerTim Yamin <plasmaroo@gentoo.org>2005-12-04 21:41:10 +0000
commit5c27db397e9580eb1f5f4a7e206322eec549f3aa (patch)
treeb140e69081a6ad48d9232499655827ac31f7b86f /sci-mathematics/axiom/files
parentstable on ppc64 (diff)
downloadgentoo-2-5c27db397e9580eb1f5f4a7e206322eec549f3aa.tar.gz
gentoo-2-5c27db397e9580eb1f5f4a7e206322eec549f3aa.tar.bz2
gentoo-2-5c27db397e9580eb1f5f4a7e206322eec549f3aa.zip
Add compile fixes (#75372, #111923) as well as a gcl fix so compilation works once we're out of the sandbox.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sci-mathematics/axiom/files')
-rw-r--r--sci-mathematics/axiom/files/gcl-2.6.7.fix-out-of-build-root-compile.Makefile.patch33
-rw-r--r--sci-mathematics/axiom/files/gcl-2.6.7.fix-out-of-build-root-compile.patch.input24
2 files changed, 57 insertions, 0 deletions
diff --git a/sci-mathematics/axiom/files/gcl-2.6.7.fix-out-of-build-root-compile.Makefile.patch b/sci-mathematics/axiom/files/gcl-2.6.7.fix-out-of-build-root-compile.Makefile.patch
new file mode 100644
index 000000000000..bc4e3fa8b5ec
--- /dev/null
+++ b/sci-mathematics/axiom/files/gcl-2.6.7.fix-out-of-build-root-compile.Makefile.patch
@@ -0,0 +1,33 @@
+Index: Makefile.pamphlet
+===================================================================
+RCS file: /cvsroot/axiom/axiom/lsp/Makefile.pamphlet,v
+retrieving revision 1.16
+diff -u -r1.16 Makefile.pamphlet
+--- lsp/Makefile.pamphlet 5 Sep 2005 23:44:08 -0000 1.16
++++ lsp/Makefile.pamphlet 4 Dec 2005 21:25:58 -0000
+@@ -15,6 +15,17 @@
+ over the gcl Makefiles.
+
+ Patches are applied to the distribution before we do the configure.
++\section{Gnu Common Lisp 2.6.7}
++\subsubsection{fix-out-of-build-root-compile.patch}
++GCL's compiler system includes a -I<gclbuildroot> flag in the gcc args;
++which causes issues if <gclbuildroot> does not exist at a later date and
++the Axiom user invokes a command that requires compilation - the gcc call
++will fail and this patch rectifies the issue. Dec 4 2005, Tim Yamin.
++<<gcl-2.6.7.fix-out-of-build-root-compile.patch>>=
++ @(cd ${GCLVERSION}/cmpnew ; \
++ echo 29 applying fix-out-of-build-root-compile patch ; \
++ ${PATCH} <${SPD}/zips/${GCLVERSION}.fix-out-of-build-root-compile.patch )
++@
+ \section{Gnu Common Lisp 2.6.7pre}
+ \subsection{run-process patch}
+ The gcl-2.6.6.h.linux.h.patch has been accepted into the mainline lisp
+@@ -1019,6 +1030,7 @@
+ <<gcl-2.6.7.toploop.patch>>
+ <<gcl-2.6.7.tail-recursive.patch>>
+ <<gcl-2.6.7.collectfn.fix>>
++<<gcl-2.6.7.fix-out-of-build-root-compile.patch>>
+ <<gclConfigureMake>>
+ @echo 13 finished system build on `date` | tee >gcldir
+
diff --git a/sci-mathematics/axiom/files/gcl-2.6.7.fix-out-of-build-root-compile.patch.input b/sci-mathematics/axiom/files/gcl-2.6.7.fix-out-of-build-root-compile.patch.input
new file mode 100644
index 000000000000..9b73a20026ab
--- /dev/null
+++ b/sci-mathematics/axiom/files/gcl-2.6.7.fix-out-of-build-root-compile.patch.input
@@ -0,0 +1,24 @@
+--- gcl_cmpmain.lsp 2005-05-06 22:56:55.000000000 +0100
++++ gcl_cmpmain.lsp.new 2005-12-04 20:56:31.000000000 +0000
+@@ -545,9 +545,8 @@
+ (setq na (namestring
+ (make-pathname :name name :type (pathname-type(first args)))))
+ #+(or dos winnt)
+- (format nil "~a -I~a ~a ~a -c -w ~s -o ~s"
++ (format nil "~a ~a ~a -c -w ~s -o ~s"
+ *cc*
+- (concatenate 'string si::*system-directory* "../h")
+ (if (and (boundp '*c-debug*) *c-debug*) " -g " "")
+ (case *speed*
+ (3 *opt-three* )
+@@ -558,9 +557,8 @@
+ )
+
+ #-(or dos winnt)
+- (format nil "~a -I~a ~a ~a -c ~s -o ~s ~a"
++ (format nil "~a ~a ~a -c ~s -o ~s ~a"
+ *cc*
+- (concatenate 'string si::*system-directory* "../h")
+ (if (and (boundp '*c-debug*) *c-debug*) " -g " "")
+ (case *speed*
+ (3 *opt-three* )