summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-12-05 10:18:57 +0000
committerMark Wright <gienah@gentoo.org>2012-12-05 10:18:57 +0000
commitb3f7f5d9d435733596309ab2b8f6eec387e15123 (patch)
tree8be3085690bb52bfae70b4932c9693e4a1009373 /sci-mathematics/cvc3
parentEAPI=5 with subslot depends to automatically rebuild isabelle when polyml is ... (diff)
downloadgentoo-2-b3f7f5d9d435733596309ab2b8f6eec387e15123.tar.gz
gentoo-2-b3f7f5d9d435733596309ab2b8f6eec387e15123.tar.bz2
gentoo-2-b3f7f5d9d435733596309ab2b8f6eec387e15123.zip
Remove the static-libs use flag, as upstream do not support static in a way that is suitable for Gentoo (it disables building the shared libraries). EAPI=5 with subslot depends to automatically rebuild cvc3 when isabelle is updated if the isabelle use flag is enabled.
(Portage version: 2.1.11.33/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'sci-mathematics/cvc3')
-rw-r--r--sci-mathematics/cvc3/ChangeLog8
-rw-r--r--sci-mathematics/cvc3/cvc3-2.4.1.ebuild30
2 files changed, 22 insertions, 16 deletions
diff --git a/sci-mathematics/cvc3/ChangeLog b/sci-mathematics/cvc3/ChangeLog
index 9a783903c1fa..bd38b7602e29 100644
--- a/sci-mathematics/cvc3/ChangeLog
+++ b/sci-mathematics/cvc3/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/cvc3
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/cvc3/ChangeLog,v 1.4 2012/11/29 11:41:29 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/cvc3/ChangeLog,v 1.5 2012/12/05 10:18:57 gienah Exp $
+
+ 05 Dec 2012; Mark Wright <gienah@gentoo.org> cvc3-2.4.1.ebuild:
+ Remove the static-libs use flag, as upstream do not support static in a way
+ that is suitable for Gentoo (it disables building the shared libraries).
+ EAPI=5 with subslot depends to automatically rebuild cvc3 when isabelle is
+ updated if the isabelle use flag is enabled.
29 Nov 2012; Mark Wright <gienah@gentoo.org> cvc3-2.4.1.ebuild:
Try to fix: bug 442228 - sci-mathematics/cvc3-2.4.1 - QA Notice:
diff --git a/sci-mathematics/cvc3/cvc3-2.4.1.ebuild b/sci-mathematics/cvc3/cvc3-2.4.1.ebuild
index c4f7adb884c2..23c48feb38a5 100644
--- a/sci-mathematics/cvc3/cvc3-2.4.1.ebuild
+++ b/sci-mathematics/cvc3/cvc3-2.4.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/cvc3/cvc3-2.4.1.ebuild,v 1.3 2012/11/29 11:41:29 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/cvc3/cvc3-2.4.1.ebuild,v 1.4 2012/12/05 10:18:57 gienah Exp $
-EAPI="4"
+EAPI="5"
inherit elisp-common
@@ -12,22 +12,21 @@ SRC_URI="http://www.cs.nyu.edu/acsys/cvc3/releases/2.4.1/${P}.tar.gz"
LICENSE="BSD MIT as-is zchaff? ( zchaff )"
RESTRICT="mirror zchaff? ( bindist )"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="doc emacs isabelle static-libs zchaff"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc emacs isabelle test zchaff"
-RDEPEND=""
+RDEPEND="dev-libs/gmp
+ isabelle? (
+ >=sci-mathematics/isabelle-2011.1-r1:=
+ )"
DEPEND="${RDEPEND}
- >=dev-libs/gmp-5[static-libs?]
doc? (
app-doc/doxygen
media-gfx/graphviz
)
emacs? (
virtual/emacs
- )
- isabelle? (
- >=sci-mathematics/isabelle-2011.1-r1
)"
SITEFILE=50${PN}-gentoo.el
@@ -41,8 +40,11 @@ src_prepare() {
}
src_configure() {
+ # --enable-static disables building of shared libraries, statically
+ # links /usr/bin/cvc3 and installs static libraries.
+ # --enable-static --enable-sharedlibs behaves the same as just --enable-static
econf \
- $(use_enable static-libs static) \
+ --enable-dynamic \
$(use_enable zchaff)
if use test; then
@@ -100,9 +102,7 @@ src_install() {
if use isabelle; then
ISABELLE_HOME="$(isabelle getenv ISABELLE_HOME | cut -d'=' -f 2)" \
|| die "isabelle getenv ISABELLE_HOME failed"
- if [[ -z "${ISABELLE_HOME}" ]]; then
- die "ISABELLE_HOME empty"
- fi
+ [[ -n "${ISABELLE_HOME}" ]] || die "ISABELLE_HOME empty"
dodir "${ISABELLE_HOME}/contrib/${PN}-${PV}/etc"
cat <<- EOF >> "${S}/settings"
CVC3_COMPONENT="\$COMPONENT"
@@ -148,7 +148,7 @@ pkg_postrm() {
if [ -f "${ROOT}etc/isabelle/components" ]; then
# Note: this sed should only match the version of this ebuild
# Which is what we want as we do not want to remove the line
- # of a new E being installed during an upgrade.
+ # of a new CVC3 being installed during an upgrade.
sed -e "/contrib\/${PN}-${PV}/d" \
-i "${ROOT}etc/isabelle/components"
fi