summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-05-21 07:10:10 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-05-21 07:10:10 +0000
commit6369c8e8824eac2129bdf10b08f02000dd1e313f (patch)
tree960e15292ee47e98028549eac1fcbfb9037b7ad3 /sci-mathematics/flint
parentInitial commit, ebuild written by me. (diff)
downloadgentoo-2-6369c8e8824eac2129bdf10b08f02000dd1e313f.tar.gz
gentoo-2-6369c8e8824eac2129bdf10b08f02000dd1e313f.tar.bz2
gentoo-2-6369c8e8824eac2129bdf10b08f02000dd1e313f.zip
Fixing libdir for #470732
(Portage version: 2.2.0_alpha176/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sci-mathematics/flint')
-rw-r--r--sci-mathematics/flint/ChangeLog7
-rw-r--r--sci-mathematics/flint/flint-2.3.ebuild11
2 files changed, 13 insertions, 5 deletions
diff --git a/sci-mathematics/flint/ChangeLog b/sci-mathematics/flint/ChangeLog
index f42b1c46c7fc..a6f17743485d 100644
--- a/sci-mathematics/flint/ChangeLog
+++ b/sci-mathematics/flint/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-mathematics/flint
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/flint/ChangeLog,v 1.1 2012/11/26 08:06:33 patrick Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/flint/ChangeLog,v 1.2 2013/05/21 07:10:10 patrick Exp $
+
+ 21 May 2013; Patrick Lauer <patrick@gentoo.org> flint-2.3.ebuild:
+ Fixing libdir for #470732
*flint-2.3 (26 Nov 2012)
diff --git a/sci-mathematics/flint/flint-2.3.ebuild b/sci-mathematics/flint/flint-2.3.ebuild
index 1406ec4387bb..05e22e29205d 100644
--- a/sci-mathematics/flint/flint-2.3.ebuild
+++ b/sci-mathematics/flint/flint-2.3.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/flint/flint-2.3.ebuild,v 1.1 2012/11/26 08:06:33 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/flint/flint-2.3.ebuild,v 1.2 2013/05/21 07:10:10 patrick Exp $
EAPI="5"
-inherit eutils
+inherit eutils multilib
DESCRIPTION="Fast Library for Number Theory"
HOMEPAGE="http://www.flintlib.org/"
@@ -22,6 +22,11 @@ DEPEND="dev-libs/mpfr
"
RDEPEND="${DEPEND}"
+src_prepare() {
+ # Correct lib paths to be multilib-proper #470732
+ sed -i -e 's~/lib~/'$(get_libdir)'~' Makefile.in || die
+}
+
src_configure() {
# handwritten script, needs extra stabbing
./configure --with-mpir=/usr --with-mpfr=/usr --with-ntl=/usr --prefix="${D}/usr" || die