summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-07-14 23:03:39 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-07-14 23:03:39 +0000
commit0fbe854bfd849e3860c53e60d148fa38ecce6d34 (patch)
tree0c8d6f4679125acfa4da91deac242c01925a1ad1 /sci-mathematics/glpk/glpk-4.19.ebuild
parentwhitespace (diff)
downloadgentoo-2-0fbe854bfd849e3860c53e60d148fa38ecce6d34.tar.gz
gentoo-2-0fbe854bfd849e3860c53e60d148fa38ecce6d34.tar.bz2
gentoo-2-0fbe854bfd849e3860c53e60d148fa38ecce6d34.zip
Version bump all the way to 4.19, after reminder by bug #180147.
(Portage version: 2.1.3_rc5)
Diffstat (limited to 'sci-mathematics/glpk/glpk-4.19.ebuild')
-rw-r--r--sci-mathematics/glpk/glpk-4.19.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sci-mathematics/glpk/glpk-4.19.ebuild b/sci-mathematics/glpk/glpk-4.19.ebuild
new file mode 100644
index 000000000000..4e624b765c5f
--- /dev/null
+++ b/sci-mathematics/glpk/glpk-4.19.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/glpk/glpk-4.19.ebuild,v 1.1 2007/07/14 23:03:39 robbat2 Exp $
+
+DESCRIPTION="GNU Linear Programming Kit"
+LICENSE="GPL-2"
+HOMEPAGE="http://www.gnu.org/software/glpk/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+SLOT="0"
+IUSE="doc"
+KEYWORDS="~x86 ~amd64 ~ppc"
+
+DEPEND=">=sys-devel/gcc-3.2
+ virtual/libc
+ doc? ( virtual/ghostscript )"
+RDEPEND="virtual/libc"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # INSTALL include some usage docs
+ dodoc AUTHORS ChangeLog INSTALL NEWS README || \
+ die "failed to install docs"
+
+ # 385Kb
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.{c,mod,tsp} || \
+ die "failed to install examples"
+
+ # manual/ is 2.5Mb in size
+ if use doc; then
+ cd "${S}"/doc
+ dvipdf refman.dvi
+ dvipdf lang.dvi
+ insinto /usr/share/doc/${PF}/manual
+ doins *.pdf || die "failed to install manual files"
+ docinto manual
+ dodoc *.txt || die "failed to install manual txt"
+ fi
+}