summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-01-15 17:52:05 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-01-15 17:52:05 +0000
commite963f89a4314aff34a3d3244a7fb8a92f5f5eb43 (patch)
treea64824f5059ed25ae1f7698700be59c732c5e2e8 /sci-mathematics/glpk/glpk-4.35.ebuild
parentRemoved old version (diff)
downloadgentoo-2-e963f89a4314aff34a3d3244a7fb8a92f5f5eb43.tar.gz
gentoo-2-e963f89a4314aff34a3d3244a7fb8a92f5f5eb43.tar.bz2
gentoo-2-e963f89a4314aff34a3d3244a7fb8a92f5f5eb43.zip
Version bump
(Portage version: 2.2_rc22/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'sci-mathematics/glpk/glpk-4.35.ebuild')
-rw-r--r--sci-mathematics/glpk/glpk-4.35.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/sci-mathematics/glpk/glpk-4.35.ebuild b/sci-mathematics/glpk/glpk-4.35.ebuild
new file mode 100644
index 000000000000..e1568fe4b4a1
--- /dev/null
+++ b/sci-mathematics/glpk/glpk-4.35.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/glpk/glpk-4.35.ebuild,v 1.1 2009/01/15 17:52:05 bicatali Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="GNU Linear Programming Kit"
+LICENSE="GPL-3"
+HOMEPAGE="http://www.gnu.org/software/glpk/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+SLOT="0"
+IUSE="doc examples gmp odbc mysql"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="odbc? ( || ( dev-db/libiodbc dev-db/unixODBC ) )
+ gmp? ( dev-libs/gmp )
+ mysql? ( virtual/mysql )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ local myconf="--disable-dl"
+ if use mysql || use odbc; then
+ myconf="--enable-dl"
+ fi
+
+ [[ -z $(type -P odbc-config) ]] && \
+ append-cppflags $(pkg-config --cflags libiodbc)
+
+ econf \
+ --with-zlib \
+ $(use_with gmp) \
+ $(use_enable odbc) \
+ $(use_enable mysql) \
+ ${myconf}
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # INSTALL include some usage docs
+ dodoc AUTHORS ChangeLog NEWS README || \
+ die "failed to install docs"
+
+ insinto /usr/share/doc/${PF}
+ if use examples; then
+ emake distclean
+ doins -r examples || die "failed to install examples"
+ fi
+ if use doc; then
+ cd "${S}"/doc
+ doins *.pdf notes/gomory.djvu || die "failed to instal djvu and pdf"
+ dodoc *.txt || die "failed to install manual files"
+ fi
+}