summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-04-01 18:11:02 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-04-01 18:11:02 +0000
commit32d219c53b9db4a4a359c07e1d387aee2146ac96 (patch)
tree74cac9c35c8088e34eeb4c055743ad13de7a4053 /sci-mathematics/glpk
parentstable x86, bug 214615 (diff)
downloadgentoo-2-32d219c53b9db4a4a359c07e1d387aee2146ac96.tar.gz
gentoo-2-32d219c53b9db4a4a359c07e1d387aee2146ac96.tar.bz2
gentoo-2-32d219c53b9db4a4a359c07e1d387aee2146ac96.zip
Version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'sci-mathematics/glpk')
-rw-r--r--sci-mathematics/glpk/ChangeLog7
-rw-r--r--sci-mathematics/glpk/glpk-4.28.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/sci-mathematics/glpk/ChangeLog b/sci-mathematics/glpk/ChangeLog
index 7cbb902c2c87..cde989e81fcf 100644
--- a/sci-mathematics/glpk/ChangeLog
+++ b/sci-mathematics/glpk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/glpk
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/glpk/ChangeLog,v 1.18 2008/03/26 14:03:08 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/glpk/ChangeLog,v 1.19 2008/04/01 18:11:02 bicatali Exp $
+
+*glpk-4.28 (01 Apr 2008)
+
+ 01 Apr 2008; Sébastien Fabbro <bicatali@gentoo.org> +glpk-4.28.ebuild:
+ Version bump
26 Mar 2008; Sébastien Fabbro <bicatali@gentoo.org> glpk-4.27.ebuild:
Fixed syntax errors
diff --git a/sci-mathematics/glpk/glpk-4.28.ebuild b/sci-mathematics/glpk/glpk-4.28.ebuild
new file mode 100644
index 000000000000..45046e845de9
--- /dev/null
+++ b/sci-mathematics/glpk/glpk-4.28.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/glpk/glpk-4.28.ebuild,v 1.1 2008/04/01 18:11:02 bicatali Exp $
+
+DESCRIPTION="GNU Linear Programming Kit"
+LICENSE="GPL-3"
+HOMEPAGE="http://www.gnu.org/software/glpk/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+SLOT="0"
+IUSE="doc gmp iodbc mysql"
+KEYWORDS="~x86 ~amd64 ~ppc"
+
+DEPEND="iodbc? ( dev-db/libiodbc )
+ gmp? ( dev-libs/gmp )
+ mysql? ( virtual/mysql )"
+
+src_compile() {
+ econf \
+ $(use_enable gmp) \
+ $(use_enable iodbc) \
+ $(use_enable mysql) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # INSTALL include some usage docs
+ dodoc AUTHORS ChangeLog NEWS README || \
+ die "failed to install docs"
+
+ insinto /usr/share/doc/${PF}
+ # 388Kb
+ doins -r examples || die "failed to install examples"
+ if use doc; then
+ cd "${S}"/doc
+ doins memo/gomory.djvu || die "failed to instal memo"
+ dodoc *.ps *.txt || die "failed to install manual files"
+ fi
+}