summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-11-25 19:11:22 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-11-25 19:11:22 +0000
commit96500754546d05d2c8f0029815fdd35e8542c7ba (patch)
tree3b5f0ed8cc2614542cbdd089f4e2f828d9a78fb1 /sci-mathematics/glpk
parentppc/ppc64 stable wrt #389807 (diff)
downloadgentoo-2-96500754546d05d2c8f0029815fdd35e8542c7ba.tar.gz
gentoo-2-96500754546d05d2c8f0029815fdd35e8542c7ba.tar.bz2
gentoo-2-96500754546d05d2c8f0029815fdd35e8542c7ba.zip
Version bump
(Portage version: 2.1.10.37/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/glpk')
-rw-r--r--sci-mathematics/glpk/ChangeLog7
-rw-r--r--sci-mathematics/glpk/glpk-4.47.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/sci-mathematics/glpk/ChangeLog b/sci-mathematics/glpk/ChangeLog
index ac38a05885c0..a1c5b196b8d5 100644
--- a/sci-mathematics/glpk/ChangeLog
+++ b/sci-mathematics/glpk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/glpk
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/glpk/ChangeLog,v 1.48 2011/06/09 12:18:17 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/glpk/ChangeLog,v 1.49 2011/11/25 19:11:22 bicatali Exp $
+
+*glpk-4.47 (25 Nov 2011)
+
+ 25 Nov 2011; Sébastien Fabbro <bicatali@gentoo.org> +glpk-4.47.ebuild:
+ Version bump
09 Jun 2011; Alexey Shvetsov <alexxy@gentoo.org> glpk-4.45.ebuild:
Add ~amd64-linux keyword
diff --git a/sci-mathematics/glpk/glpk-4.47.ebuild b/sci-mathematics/glpk/glpk-4.47.ebuild
new file mode 100644
index 000000000000..d1079eb3c1f7
--- /dev/null
+++ b/sci-mathematics/glpk/glpk-4.47.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/glpk/glpk-4.47.ebuild,v 1.1 2011/11/25 19:11:22 bicatali Exp $
+
+EAPI=4
+inherit flag-o-matic
+
+DESCRIPTION="GNU Linear Programming Kit"
+LICENSE="GPL-3"
+HOMEPAGE="http://www.gnu.org/software/glpk/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+SLOT="0"
+IUSE="doc examples gmp odbc mysql static-libs"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux"
+
+RDEPEND="odbc? ( || ( dev-db/libiodbc dev-db/unixODBC ) )
+ gmp? ( dev-libs/gmp )
+ mysql? ( virtual/mysql )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ local myconf="--disable-dl"
+ if use mysql || use odbc; then
+ myconf="--enable-dl"
+ fi
+
+ [[ -z $(type -P odbc-config) ]] && \
+ append-cppflags $(pkg-config --cflags libiodbc)
+
+ econf \
+ $(use_enable mysql) \
+ $(use_enable odbc) \
+ $(use_enable static-libs static) \
+ $(use_with gmp) \
+ ${myconf}
+}
+
+src_install() {
+ default
+ if use examples; then
+ emake distclean
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+ use doc && cd "${S}"/doc && dodoc *.pdf notes/*.pdf *.txt
+}