summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-08-14 23:41:29 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-08-14 23:41:29 +0000
commitcc6dbb42a770c3d0cd15c61ce1c6acf8bfe33f05 (patch)
tree92a7d23d1890cd59bfedb706b2373aacfac9b1ee /sci-mathematics/gmm
parentstable sparc, bug 280636 (diff)
downloadgentoo-2-cc6dbb42a770c3d0cd15c61ce1c6acf8bfe33f05.tar.gz
gentoo-2-cc6dbb42a770c3d0cd15c61ce1c6acf8bfe33f05.tar.bz2
gentoo-2-cc6dbb42a770c3d0cd15c61ce1c6acf8bfe33f05.zip
Version bump
(Portage version: 2.2_rc38/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/gmm')
-rw-r--r--sci-mathematics/gmm/ChangeLog8
-rw-r--r--sci-mathematics/gmm/gmm-3.1.ebuild19
-rw-r--r--sci-mathematics/gmm/metadata.xml10
3 files changed, 36 insertions, 1 deletions
diff --git a/sci-mathematics/gmm/ChangeLog b/sci-mathematics/gmm/ChangeLog
index 1a6e02a65708..0e4074fa787a 100644
--- a/sci-mathematics/gmm/ChangeLog
+++ b/sci-mathematics/gmm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/gmm
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gmm/ChangeLog,v 1.5 2009/07/01 15:05:10 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gmm/ChangeLog,v 1.6 2009/08/14 23:41:29 bicatali Exp $
+
+*gmm-3.1 (14 Aug 2009)
+
+ 14 Aug 2009; Sébastien Fabbro <bicatali@gentoo.org> +gmm-3.1.ebuild,
+ metadata.xml:
+ Version bump
01 Jul 2009; Alexis Ballier <aballier@gentoo.org> gmm-3.0.ebuild:
keyword ~x86-fbsd
diff --git a/sci-mathematics/gmm/gmm-3.1.ebuild b/sci-mathematics/gmm/gmm-3.1.ebuild
new file mode 100644
index 000000000000..d2200283d555
--- /dev/null
+++ b/sci-mathematics/gmm/gmm-3.1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gmm/gmm-3.1.ebuild,v 1.1 2009/08/14 23:41:29 bicatali Exp $
+
+inherit eutils
+
+DESCRIPTION="Generic C++ template library for sparse, dense and skyline matrices"
+SRC_URI="http://download.gna.org/getfem/stable/${P}.tar.gz"
+HOMEPAGE="http://www-gmm.insa-toulouse.fr/getfem/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS
+}
diff --git a/sci-mathematics/gmm/metadata.xml b/sci-mathematics/gmm/metadata.xml
index 8d1e86a9cefb..de7664cf4884 100644
--- a/sci-mathematics/gmm/metadata.xml
+++ b/sci-mathematics/gmm/metadata.xml
@@ -2,4 +2,14 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>kde</herd>
+<longdescription lang='en'>
+ Gmm++ is a generic C++ template library for sparse, dense and
+ skyline matrices. It is built as a set of generic algorithms (mult,
+ add, copy, sub-matrices, dense and sparse solvers ...) for any
+ interfaced vector type or matrix type. It can be view as a glue
+ library allowing cooperation between several vector and matrix
+ types. However, basic sparse, dense and skyline matrix/vector types
+ are built in Gmm++, hence it can be used as a standalone linear
+ algebra library.
+</longdescription>
</pkgmetadata>