summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-02-07 14:48:27 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-02-07 14:48:27 +0000
commit6f5bd616e15652eb9c790b5e54267a16d9731da1 (patch)
treef633cd2a8f33f59d6111fd83326e945a28d74780 /sci-mathematics/mathomatic
parentDropped ppc-macos keyword, see you in prefix (diff)
downloadgentoo-2-6f5bd616e15652eb9c790b5e54267a16d9731da1.tar.gz
gentoo-2-6f5bd616e15652eb9c790b5e54267a16d9731da1.tar.bz2
gentoo-2-6f5bd616e15652eb9c790b5e54267a16d9731da1.zip
Version bump
(Portage version: 2.1.4.1)
Diffstat (limited to 'sci-mathematics/mathomatic')
-rw-r--r--sci-mathematics/mathomatic/ChangeLog8
-rw-r--r--sci-mathematics/mathomatic/mathomatic-12.7.9.ebuild34
-rw-r--r--sci-mathematics/mathomatic/mathomatic-12.8.6.ebuild47
3 files changed, 54 insertions, 35 deletions
diff --git a/sci-mathematics/mathomatic/ChangeLog b/sci-mathematics/mathomatic/ChangeLog
index b10812a5b81f..baf978d25523 100644
--- a/sci-mathematics/mathomatic/ChangeLog
+++ b/sci-mathematics/mathomatic/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/mathomatic
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/ChangeLog,v 1.22 2008/01/25 10:38:46 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/ChangeLog,v 1.23 2008/02/07 14:48:27 bicatali Exp $
+
+*mathomatic-12.8.6 (07 Feb 2008)
+
+ 07 Feb 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ -mathomatic-12.7.9.ebuild, +mathomatic-12.8.6.ebuild:
+ Version bump
*mathomatic-12.8.5 (25 Jan 2008)
diff --git a/sci-mathematics/mathomatic/mathomatic-12.7.9.ebuild b/sci-mathematics/mathomatic/mathomatic-12.7.9.ebuild
deleted file mode 100644
index 8ed9ed386c8c..000000000000
--- a/sci-mathematics/mathomatic/mathomatic-12.7.9.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/mathomatic-12.7.9.ebuild,v 1.2 2007/11/05 15:13:22 cryos Exp $
-
-inherit eutils
-
-DESCRIPTION="Automatic algebraic manipulator"
-HOMEPAGE="http://www.mathomatic.com/"
-SRC_URI="http://www.panix.com/~gesslein/${P}.tar.bz2"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="doc"
-
-DEPEND="sys-libs/readline
- sys-libs/ncurses"
-
-src_compile() {
- emake READLINE=1 || die "emake failed"
-}
-
-src_install() {
- # It was easier just to install the files manually
- dobin mathomatic
- dodoc changes.txt README.txt
- doman mathomatic.1
-
- if use doc; then
- dohtml doc/*
- insinto /usr/share/doc/${PF}/examples
- doins tests/*.in
- fi
-}
diff --git a/sci-mathematics/mathomatic/mathomatic-12.8.6.ebuild b/sci-mathematics/mathomatic/mathomatic-12.8.6.ebuild
new file mode 100644
index 000000000000..1992a5685a48
--- /dev/null
+++ b/sci-mathematics/mathomatic/mathomatic-12.8.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/mathomatic-12.8.6.ebuild,v 1.1 2008/02/07 14:48:27 bicatali Exp $
+
+inherit eutils
+
+DESCRIPTION="Automatic algebraic manipulator"
+HOMEPAGE="http://www.mathomatic.com/"
+SRC_URI="http://www.panix.com/~gesslein/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+DEPEND="sys-libs/readline
+ sys-libs/ncurses"
+
+src_compile() {
+ # respect user flags
+ sed -i \
+ -e '/^CFLAGS/ s/-O.//' \
+ -e '/^LDFLAGS/s/+= -lm/:= -lm $(LDFLAGS)/' \
+ makefile primes/makefile || die "sed failed"
+ emake READLINE=1 || die "emake failed"
+ emake -C primes || die "emake in primes failed"
+}
+
+src_test() {
+ emake test || die "emake test failed"
+ emake -C primes test || die "emake test in primes failed"
+}
+
+src_install() {
+ # It was easier just to install the files manually
+ dobin mathomatic primes/matho-{primes,pascal,sumsq} || die
+ dodoc changes.txt README.txt AUTHORS || die
+ doman mathomatic.1 primes/*.1 || die
+ doicon mathomatic.png || die
+ domenu mathomatic.desktop || die
+ newdoc primes/README.txt README-primes.txt || die
+ if use doc; then
+ dohtml doc/* || die
+ insinto /usr/share/doc/${PF}
+ doins tests factorial m4 || die
+ fi
+}