summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-05-03 16:29:31 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-05-03 16:29:31 +0000
commit9da6c24c99e2ca1238013663c83159485561a766 (patch)
treed550e85497fd78d831b69531f4e0033d46bafec9 /sci-mathematics/mathomatic
parentVersion bump (diff)
downloadgentoo-2-9da6c24c99e2ca1238013663c83159485561a766.tar.gz
gentoo-2-9da6c24c99e2ca1238013663c83159485561a766.tar.bz2
gentoo-2-9da6c24c99e2ca1238013663c83159485561a766.zip
Version bump
(Portage version: 2.1.9.46/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/mathomatic')
-rw-r--r--sci-mathematics/mathomatic/ChangeLog8
-rw-r--r--sci-mathematics/mathomatic/mathomatic-15.6.0.ebuild49
2 files changed, 56 insertions, 1 deletions
diff --git a/sci-mathematics/mathomatic/ChangeLog b/sci-mathematics/mathomatic/ChangeLog
index 1755fd4eb4f7..ae9549281b63 100644
--- a/sci-mathematics/mathomatic/ChangeLog
+++ b/sci-mathematics/mathomatic/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/mathomatic
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/ChangeLog,v 1.56 2011/04/11 04:57:25 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/ChangeLog,v 1.57 2011/05/03 16:29:31 bicatali Exp $
+
+*mathomatic-15.6.0 (03 May 2011)
+
+ 03 May 2011; Sébastien Fabbro <bicatali@gentoo.org>
+ +mathomatic-15.6.0.ebuild:
+ Version bump
11 Apr 2011; Sébastien Fabbro <bicatali@gentoo.org>
mathomatic-15.5.2.ebuild:
diff --git a/sci-mathematics/mathomatic/mathomatic-15.6.0.ebuild b/sci-mathematics/mathomatic/mathomatic-15.6.0.ebuild
new file mode 100644
index 000000000000..1e9c8af7c7b3
--- /dev/null
+++ b/sci-mathematics/mathomatic/mathomatic-15.6.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/mathomatic-15.6.0.ebuild,v 1.1 2011/05/03 16:29:31 bicatali Exp $
+
+EAPI=4
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Automatic algebraic manipulator"
+HOMEPAGE="http://www.mathomatic.org/"
+SRC_URI="${HOMEPAGE}/archive/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc gnuplot"
+
+DEPEND="sys-libs/readline
+ sys-libs/ncurses"
+RDEPEND="${DEPEND}
+ gnuplot? ( sci-visualization/gnuplot )"
+
+src_prepare() {
+ sed -i -e 's/time -p//g' makefile primes/makefile || die
+}
+
+src_compile() {
+ emake READLINE=1 CC=$(tc-getCC)
+ emake CC=$(tc-getCC) -C primes
+}
+
+src_test() {
+ emake test
+ emake -C primes test
+}
+
+src_install() {
+ dobin mathomatic
+ dobin primes/matho-{mult,primes,pascal,sumsq} primes/primorial
+ dodoc changes.txt README.txt AUTHORS
+ doman mathomatic.1 primes/*.1
+ doicon icons/mathomatic.png
+ domenu icons/mathomatic.desktop
+ newdoc primes/README.txt README-primes.txt
+ if use doc; then
+ dohtml doc/*
+ insinto /usr/share/doc/${PF}
+ doins -r tests examples m4
+ fi
+}