summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2013-04-20 14:50:53 +0000
committerAndrey Grozin <grozin@gentoo.org>2013-04-20 14:50:53 +0000
commitbd919d5bc4e891b822c36aed870957cfbc7870d4 (patch)
tree969f7c7130f619ad69957078da2f0e01bd5171e0 /sci-mathematics/maxima/files
parentDrop PYTHON_TARGETS we can only append, not remove (which is the only thing w... (diff)
downloadgentoo-2-bd919d5bc4e891b822c36aed870957cfbc7870d4.tar.gz
gentoo-2-bd919d5bc4e891b822c36aed870957cfbc7870d4.tar.bz2
gentoo-2-bd919d5bc4e891b822c36aed870957cfbc7870d4.zip
Version bump
(Portage version: 2.2.0_alpha173/cvs/Linux i686, signed Manifest commit with key 0x3AFFCE974D34BD8C!)
Diffstat (limited to 'sci-mathematics/maxima/files')
-rw-r--r--sci-mathematics/maxima/files/clisp-0.patch19
-rw-r--r--sci-mathematics/maxima/files/clozurecl-0.patch27
-rw-r--r--sci-mathematics/maxima/files/cmucl-0.patch27
-rw-r--r--sci-mathematics/maxima/files/ecls-0.patch27
-rw-r--r--sci-mathematics/maxima/files/imaxima-0.patch5
-rw-r--r--sci-mathematics/maxima/files/rmaxima-0.patch25
-rw-r--r--sci-mathematics/maxima/files/sbcl-0.patch26
-rw-r--r--sci-mathematics/maxima/files/wish-0.patch28
-rw-r--r--sci-mathematics/maxima/files/xdg-utils-0.patch35
9 files changed, 219 insertions, 0 deletions
diff --git a/sci-mathematics/maxima/files/clisp-0.patch b/sci-mathematics/maxima/files/clisp-0.patch
new file mode 100644
index 000000000000..7e65c40b58f7
--- /dev/null
+++ b/sci-mathematics/maxima/files/clisp-0.patch
@@ -0,0 +1,19 @@
+diff -r -U1 maxima-5.30.0.orig/src/maxima.in maxima-5.30.0/src/maxima.in
+--- maxima-5.30.0.orig/src/maxima.in 2012-12-04 12:54:50.000000000 +0700
++++ maxima-5.30.0/src/maxima.in 2013-04-13 13:07:03.094128196 +0700
+@@ -138,5 +138,5 @@
+ if [ -x "$MAXIMA_IMAGESDIR/binary-$MAXIMA_LISP/maxima" ]; then
+- exec "$MAXIMA_IMAGESDIR/binary-$MAXIMA_LISP/maxima" $MAXIMA_LISP_OPTIONS -q "" -- "$arg1" "$arg2" "$arg3" "$arg4" "$arg5" "$arg6" "$arg7" "$arg8" "$arg9"
++ exec "$MAXIMA_IMAGESDIR/binary-$MAXIMA_LISP/maxima" $MAXIMA_LISP_OPTIONS -q -norc "" -- "$arg1" "$arg2" "$arg3" "$arg4" "$arg5" "$arg6" "$arg7" "$arg8" "$arg9"
+ else
+- exec "$MAXIMA_IMAGESDIR/binary-$MAXIMA_LISP/@CLISP_RUNTIME@" $MAXIMA_LISP_OPTIONS -q -M "$maxima_image_base.mem" "" -- "$arg1" "$arg2" "$arg3" "$arg4" "$arg5" "$arg6" "$arg7" "$arg8" "$arg9"
++ exec "$MAXIMA_IMAGESDIR/binary-$MAXIMA_LISP/@CLISP_RUNTIME@" $MAXIMA_LISP_OPTIONS -q -norc -M "$maxima_image_base.mem" "" -- "$arg1" "$arg2" "$arg3" "$arg4" "$arg5" "$arg6" "$arg7" "$arg8" "$arg9"
+ fi
+@@ -144,5 +144,5 @@
+ if [ -x "$maxima_image_base" ]; then
+- exec "$maxima_image_base" $MAXIMA_LISP_OPTIONS -q "" -- "$arg1" "$arg2" "$arg3" "$arg4" "$arg5" "$arg6" "$arg7" "$arg8" "$arg9"
++ exec "$maxima_image_base" $MAXIMA_LISP_OPTIONS -q -norc "" -- "$arg1" "$arg2" "$arg3" "$arg4" "$arg5" "$arg6" "$arg7" "$arg8" "$arg9"
+ else
+- exec "@CLISP_NAME@" $MAXIMA_LISP_OPTIONS -q -M "$maxima_image_base.mem" "" -- "$arg1" "$arg2" "$arg3" "$arg4" "$arg5" "$arg6" "$arg7" "$arg8" "$arg9"
++ exec "@CLISP_NAME@" $MAXIMA_LISP_OPTIONS -q -norc -M "$maxima_image_base.mem" "" -- "$arg1" "$arg2" "$arg3" "$arg4" "$arg5" "$arg6" "$arg7" "$arg8" "$arg9"
+ fi
diff --git a/sci-mathematics/maxima/files/clozurecl-0.patch b/sci-mathematics/maxima/files/clozurecl-0.patch
new file mode 100644
index 000000000000..d5afe951eb53
--- /dev/null
+++ b/sci-mathematics/maxima/files/clozurecl-0.patch
@@ -0,0 +1,27 @@
+diff -r -U1 maxima-5.30.0.orig/configure.in maxima-5.30.0/configure.in
+--- maxima-5.30.0.orig/configure.in 2013-04-03 02:13:30.000000000 +0700
++++ maxima-5.30.0/configure.in 2013-04-13 12:42:16.645751903 +0700
+@@ -351,3 +351,3 @@
+ dnl n.b. openmcl_default_name is hardcoded in "with" message
+-openmcl_default_name=openmcl
++openmcl_default_name=ccl
+ AC_ARG_ENABLE(openmcl,
+diff -r -U1 maxima-5.30.0.orig/src/Makefile.am maxima-5.30.0/src/Makefile.am
+--- maxima-5.30.0.orig/src/Makefile.am 2013-03-23 08:32:07.000000000 +0700
++++ maxima-5.30.0/src/Makefile.am 2013-04-13 12:49:34.911159093 +0700
+@@ -304,3 +304,3 @@
+ if OPENMCL
+-EXECUTEOPENMCL = $(OPENMCL_NAME) -e
++EXECUTEOPENMCL = $(OPENMCL_NAME) --no-init -e
+ all-local: sharefiles.mk $(OPENMCL_MAXIMA)
+diff -r -U1 maxima-5.30.0.orig/src/maxima.in maxima-5.30.0/src/maxima.in
+--- maxima-5.30.0.orig/src/maxima.in 2012-12-04 12:54:50.000000000 +0700
++++ maxima-5.30.0/src/maxima.in 2013-04-13 12:46:59.247013957 +0700
+@@ -185,5 +185,5 @@
+ if [ -x "$MAXIMA_IMAGESDIR/binary-$MAXIMA_LISP/maxima" ]; then
+- exec "$MAXIMA_IMAGESDIR/binary-$MAXIMA_LISP/maxima" $MAXIMA_LISP_OPTIONS -e '(cl-user::run)' -- "$arg1" "$arg2" "$arg3" "$arg4" "$arg5" "$arg6" "$arg7" "$arg8" "$arg9"
++ exec "$MAXIMA_IMAGESDIR/binary-$MAXIMA_LISP/maxima" $MAXIMA_LISP_OPTIONS --no-init -e '(cl-user::run)' -- "$arg1" "$arg2" "$arg3" "$arg4" "$arg5" "$arg6" "$arg7" "$arg8" "$arg9"
+ else
+- exec "@OPENMCL_NAME@" -I "$maxima_image_base.image" $MAXIMA_LISP_OPTIONS -e '(cl-user::run)' -- "$arg1" "$arg2" "$arg3" "$arg4" "$arg5" "$arg6" "$arg7" "$arg8" "$arg9"
++ exec "@OPENMCL_NAME@" -I "$maxima_image_base.image" $MAXIMA_LISP_OPTIONS --no-init -e '(cl-user::run)' -- "$arg1" "$arg2" "$arg3" "$arg4" "$arg5" "$arg6" "$arg7" "$arg8" "$arg9"
+ fi
diff --git a/sci-mathematics/maxima/files/cmucl-0.patch b/sci-mathematics/maxima/files/cmucl-0.patch
new file mode 100644
index 000000000000..73ebd3445b48
--- /dev/null
+++ b/sci-mathematics/maxima/files/cmucl-0.patch
@@ -0,0 +1,27 @@
+diff -r -U1 maxima-5.30.0.orig/src/Makefile.am maxima-5.30.0/src/Makefile.am
+--- maxima-5.30.0.orig/src/Makefile.am 2013-03-23 08:32:07.000000000 +0700
++++ maxima-5.30.0/src/Makefile.am 2013-04-13 13:12:37.521437190 +0700
+@@ -77,3 +77,3 @@
+ if CMUCL
+-EXECUTECMUCL = $(CMUCL_NAME) -noinit -batch
++EXECUTECMUCL = $(CMUCL_NAME) -nositeinit -noinit -batch
+ # Newer versions of CMUCL have an INTL package that is compatible with
+diff -r -U1 maxima-5.30.0.orig/src/maxima.in maxima-5.30.0/src/maxima.in
+--- maxima-5.30.0.orig/src/maxima.in 2012-12-04 12:54:50.000000000 +0700
++++ maxima-5.30.0/src/maxima.in 2013-04-13 13:11:26.647371277 +0700
+@@ -155,5 +155,5 @@
+ if [ -x "$MAXIMA_IMAGESDIR/binary-$MAXIMA_LISP/maxima" ]; then
+- exec "$MAXIMA_IMAGESDIR/binary-$MAXIMA_LISP/maxima" $MAXIMA_LISP_OPTIONS -quiet -- "$arg1" "$arg2" "$arg3" "$arg4" "$arg5" "$arg6" "$arg7" "$arg8" "$arg9"
++ exec "$MAXIMA_IMAGESDIR/binary-$MAXIMA_LISP/maxima" $MAXIMA_LISP_OPTIONS -quiet -nositeinit -noinit -- "$arg1" "$arg2" "$arg3" "$arg4" "$arg5" "$arg6" "$arg7" "$arg8" "$arg9"
+ else
+- exec "$MAXIMA_IMAGESDIR/binary-$MAXIMA_LISP/@CMUCL_RUNTIME@" $MAXIMA_LISP_OPTIONS -quiet -core "$maxima_image_base.core" -eval '(cl-user::run)' -- "$arg1" "$arg2" "$arg3" "$arg4" "$arg5" "$arg6" "$arg7" "$arg8" "$arg9"
++ exec "$MAXIMA_IMAGESDIR/binary-$MAXIMA_LISP/@CMUCL_RUNTIME@" $MAXIMA_LISP_OPTIONS -quiet -nositeinit -noinit -core "$maxima_image_base.core" -eval '(cl-user::run)' -- "$arg1" "$arg2" "$arg3" "$arg4" "$arg5" "$arg6" "$arg7" "$arg8" "$arg9"
+ fi
+@@ -161,5 +161,5 @@
+ if [ -x "$maxima_image_base" ]; then
+- exec "$maxima_image_base" $MAXIMA_LISP_OPTIONS -quiet -- "$arg1" "$arg2" "$arg3" "$arg4" "$arg5" "$arg6" "$arg7" "$arg8" "$arg9"
++ exec "$maxima_image_base" $MAXIMA_LISP_OPTIONS -quiet -nositeinit -noinit -- "$arg1" "$arg2" "$arg3" "$arg4" "$arg5" "$arg6" "$arg7" "$arg8" "$arg9"
+ else
+- exec "@CMUCL_NAME@" $MAXIMA_LISP_OPTIONS -quiet -core "$maxima_image_base.core" -eval '(cl-user::run)' -- "$arg1" "$arg2" "$arg3" "$arg4" "$arg5" "$arg6" "$arg7" "$arg8" "$arg9"
++ exec "@CMUCL_NAME@" $MAXIMA_LISP_OPTIONS -quiet -nositeinit -noinit -core "$maxima_image_base.core" -eval '(cl-user::run)' -- "$arg1" "$arg2" "$arg3" "$arg4" "$arg5" "$arg6" "$arg7" "$arg8" "$arg9"
+ fi
diff --git a/sci-mathematics/maxima/files/ecls-0.patch b/sci-mathematics/maxima/files/ecls-0.patch
new file mode 100644
index 000000000000..df45dee0eb4a
--- /dev/null
+++ b/sci-mathematics/maxima/files/ecls-0.patch
@@ -0,0 +1,27 @@
+diff -r -U1 maxima-5.30.0.orig/src/maxima.in maxima-5.30.0/src/maxima.in
+--- maxima-5.30.0.orig/src/maxima.in 2012-12-04 12:54:50.000000000 +0700
++++ maxima-5.30.0/src/maxima.in 2013-04-13 12:57:12.037579805 +0700
+@@ -191,3 +191,3 @@
+ elif [ "$MAXIMA_LISP" = "ecl" ]; then
+- exec "$maxima_image_base" $MAXIMA_LISP_OPTIONS -- "$arg1" "$arg2" "$arg3" "$arg4" "$arg5" "$arg6" "$arg7" "$arg8" "$arg9"
++ exec "$maxima_image_base" $MAXIMA_LISP_OPTIONS -norc -- "$arg1" "$arg2" "$arg3" "$arg4" "$arg5" "$arg6" "$arg7" "$arg8" "$arg9"
+
+diff -r -U1 maxima-5.30.0.orig/src/maxima.system maxima-5.30.0/src/maxima.system
+--- maxima-5.30.0.orig/src/maxima.system 2013-03-23 08:32:08.000000000 +0700
++++ maxima-5.30.0/src/maxima.system 2013-04-13 12:59:54.086730845 +0700
+@@ -61,2 +61,10 @@
+ #+ecl
++(defun split-ld-flags-for-ecl (string &aux space)
++ (setf string (string-trim '(#\Space) string))
++ (if (setf space (position #\Space string))
++ (cons (subseq string 0 space)
++ (split-ld-flags-for-ecl (subseq string (1+ space))))
++ (cons string nil)))
++
++#+ecl
+ (defun build-maxima-lib ()
+@@ -81,3 +89,3 @@
+ (find-package "MAXIMA")))))
+- (if (and x (not (string= x ""))) (list x)))
++ (if (and x (not (string= x ""))) (split-ld-flags-for-ecl x)))
+ :epilogue-code '(progn (require :defsystem)
diff --git a/sci-mathematics/maxima/files/imaxima-0.patch b/sci-mathematics/maxima/files/imaxima-0.patch
new file mode 100644
index 000000000000..fe607b240d13
--- /dev/null
+++ b/sci-mathematics/maxima/files/imaxima-0.patch
@@ -0,0 +1,5 @@
+--- interfaces/emacs/Makefile.am.orig 2010-02-01 22:11:44.809941160 +1300
++++ interfaces/emacs/Makefile.am 2010-02-01 22:12:06.608062346 +1300
+@@ -1 +1 @@
+-SUBDIRS = emaxima misc imaxima
++SUBDIRS = emaxima misc
diff --git a/sci-mathematics/maxima/files/rmaxima-0.patch b/sci-mathematics/maxima/files/rmaxima-0.patch
new file mode 100644
index 000000000000..712cbda19d45
--- /dev/null
+++ b/sci-mathematics/maxima/files/rmaxima-0.patch
@@ -0,0 +1,25 @@
+diff -r -U2 maxima-5.28.0.orig/src/Makefile.am maxima-5.28.0/src/Makefile.am
+--- maxima-5.28.0.orig/src/Makefile.am 2012-06-15 12:21:34.000000000 +0700
++++ maxima-5.28.0/src/Makefile.am 2012-10-30 22:22:29.000000000 +0700
+@@ -4,5 +4,21 @@
+ bin_SCRIPTS = maxima maxima-command.ico maxima.bat set_lang.vbs
+ else
++if SBCL
+ bin_SCRIPTS = maxima rmaxima
++else
++if CMUCL
++bin_SCRIPTS = maxima rmaxima
++else
++if ECL
++bin_SCRIPTS = maxima rmaxima
++else
++if OPENMCL
++bin_SCRIPTS = maxima rmaxima
++else
++bin_SCRIPTS = maxima
++endif
++endif
++endif
++endif
+ endif
+
diff --git a/sci-mathematics/maxima/files/sbcl-0.patch b/sci-mathematics/maxima/files/sbcl-0.patch
new file mode 100644
index 000000000000..5c2bdf7b509e
--- /dev/null
+++ b/sci-mathematics/maxima/files/sbcl-0.patch
@@ -0,0 +1,26 @@
+diff -r -U1 maxima-5.30.0.orig/src/Makefile.am maxima-5.30.0/src/Makefile.am
+--- maxima-5.30.0.orig/src/Makefile.am 2013-03-23 08:32:07.000000000 +0700
++++ maxima-5.30.0/src/Makefile.am 2013-04-13 14:36:39.977014432 +0700
+@@ -199,3 +199,3 @@
+ if SBCL
+-EXECUTESBCL = "$(SBCL_NAME)" --noinform --noprint --eval
++EXECUTESBCL = "$(SBCL_NAME)" --noinform --noprint --no-sysinit --no-userinit --eval
+ all-local: sharefiles.mk $(SBCL_MAXIMA)
+diff -r -U1 maxima-5.30.0.orig/src/maxima.in maxima-5.30.0/src/maxima.in
+--- maxima-5.30.0.orig/src/maxima.in 2012-12-04 12:54:50.000000000 +0700
++++ maxima-5.30.0/src/maxima.in 2013-04-13 14:36:39.977014432 +0700
+@@ -196,5 +196,5 @@
+ if [ -x "$MAXIMA_IMAGESDIR/binary-$MAXIMA_LISP/maxima" ]; then
+- exec "$MAXIMA_IMAGESDIR/binary-$MAXIMA_LISP/maxima" --noinform $MAXIMA_LISP_OPTIONS --end-runtime-options --eval '(cl-user::run)' --end-toplevel-options "$arg1" "$arg2" "$arg3" "$arg4" "$arg5" "$arg6" "$arg7" "$arg8" "$arg9"
++ exec "$MAXIMA_IMAGESDIR/binary-$MAXIMA_LISP/maxima" --noinform $MAXIMA_LISP_OPTIONS --end-runtime-options --no-sysinit --no-userinit --eval '(cl-user::run)' --end-toplevel-options "$arg1" "$arg2" "$arg3" "$arg4" "$arg5" "$arg6" "$arg7" "$arg8" "$arg9"
+ else
+- exec "@SBCL_NAME@" --core "$maxima_image_base.core" --noinform $MAXIMA_LISP_OPTIONS --end-runtime-options --eval '(cl-user::run)' --end-toplevel-options "$arg1" "$arg2" "$arg3" "$arg4" "$arg5" "$arg6" "$arg7" "$arg8" "$arg9"
++ exec "@SBCL_NAME@" --core "$maxima_image_base.core" --noinform $MAXIMA_LISP_OPTIONS --end-runtime-options --no-sysinit --no-userinit --eval '(cl-user::run)' --end-toplevel-options "$arg1" "$arg2" "$arg3" "$arg4" "$arg5" "$arg6" "$arg7" "$arg8" "$arg9"
+ fi
+diff -r -U1 maxima-5.30.0.orig/src/server.lisp maxima-5.30.0/src/server.lisp
+--- maxima-5.30.0.orig/src/server.lisp 2012-11-19 04:40:51.000000000 +0700
++++ maxima-5.30.0/src/server.lisp 2013-04-13 14:37:19.937051659 +0700
+@@ -10,3 +10,2 @@
+ (eval-when (:compile-toplevel :load-toplevel :execute)
+- #+sbcl (require 'asdf) ;not needed here for a recent SBCL
+ #+sbcl (require 'sb-posix)
diff --git a/sci-mathematics/maxima/files/wish-0.patch b/sci-mathematics/maxima/files/wish-0.patch
new file mode 100644
index 000000000000..6fcb0d9ec8e9
--- /dev/null
+++ b/sci-mathematics/maxima/files/wish-0.patch
@@ -0,0 +1,28 @@
+diff -r -U1 maxima-5.23.1.orig//configure.in maxima-5.23.1//configure.in
+--- maxima-5.23.1.orig//configure.in 2011-01-15 21:54:46.000000000 +0600
++++ maxima-5.23.1//configure.in 2011-01-16 21:00:16.000000000 +0600
+@@ -777,6 +777,11 @@
+ [ --with-wish=<prog> Use <prog> for Tk wish shell (default wish)],
+- [WISH="${withval}"],
+- [WISH="wish"])
++ [],
++ [with_wish="wish"])
++case "${with_wish}" in
++ no) WISH="none" ;;
++ yes) WISH="wish" ;;
++ *) WISH="${with_wish}" ;;
++esac
+ AC_SUBST(WISH)
+-
++AM_CONDITIONAL(WANT_TK, test x"${with_wish}" != xno)
+
+diff -r -U1 maxima-5.23.1.orig//interfaces/Makefile.am maxima-5.23.1//interfaces/Makefile.am
+--- maxima-5.23.1.orig//interfaces/Makefile.am 2004-04-28 23:34:59.000000000 +0700
++++ maxima-5.23.1//interfaces/Makefile.am 2011-01-16 20:41:38.000000000 +0600
+@@ -1,2 +1,6 @@
++if WANT_TK
+ SUBDIRS = emacs xmaxima
++else
++SUBDIRS = emacs
++endif
+ EXTRA_DIST = bin/xmaxima.iss
diff --git a/sci-mathematics/maxima/files/xdg-utils-0.patch b/sci-mathematics/maxima/files/xdg-utils-0.patch
new file mode 100644
index 000000000000..876fe6fcd469
--- /dev/null
+++ b/sci-mathematics/maxima/files/xdg-utils-0.patch
@@ -0,0 +1,35 @@
+--- interfaces/emacs/misc/bookmode.el.orig 2008-02-07 12:42:18.008472937 +0000
++++ interfaces/emacs/misc/bookmode.el 2008-02-07 12:43:02.531010132 +0000
+@@ -680,7 +680,7 @@
+
+ (and tem
+ (list (concat "View "(nth 1 tem))
+- 'call-process "ghostview" nil nil nil
++ 'call-process "xdg-open" nil nil nil
+ (expand-file-name(nth 1 tem))
+ ))
+ (list "Cancel")
+@@ -705,7 +705,7 @@
+ (concat
+ (cond ((looking-at "%PS") "")
+ (t "gzip -dc | "))
+- "ghostview -")
++ "xdg-open -")
+
+ )))
+
+--- interfaces/xmaxima/Tkmaxima/Constants.tcl.orig 2008-02-07 12:42:47.294141832 +0000
++++ interfaces/xmaxima/Tkmaxima/Constants.tcl 2008-02-07 12:43:02.539010587 +0000
+@@ -143,9 +143,9 @@
+ image/gif netmath
+ image/png netmath
+ image/jpeg netmath
+- application/postscript "ghostview -safer %s"
+- application/pdf "acroread %s"
+- application/x-dvi "xdvi %s"
++ application/postscript "xdg-open -safer %s"
++ application/pdf "xdg-open %s"
++ application/x-dvi "xdg-open %s"
+ }
+ set maxima_priv(imagecounter) 0
+