summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2009-12-17 12:24:58 +0000
committerAndrey Grozin <grozin@gentoo.org>2009-12-17 12:24:58 +0000
commit5fbd3c742a662d2aaa65fe0b3719ec7d501ce050 (patch)
tree2a5985579f4060241713069e7301fdc1ec5a23ce /sci-mathematics/maxima
parentInitial import (from the lisp overlay) (diff)
downloadgentoo-2-5fbd3c742a662d2aaa65fe0b3719ec7d501ce050.tar.gz
gentoo-2-5fbd3c742a662d2aaa65fe0b3719ec7d501ce050.tar.bz2
gentoo-2-5fbd3c742a662d2aaa65fe0b3719ec7d501ce050.zip
Version bump, added clozurecl as a supported lisp
(Portage version: 2.2_rc60/cvs/Linux i686)
Diffstat (limited to 'sci-mathematics/maxima')
-rw-r--r--sci-mathematics/maxima/ChangeLog8
-rw-r--r--sci-mathematics/maxima/files/maxima-clozurecl.patch8
-rw-r--r--sci-mathematics/maxima/maxima-5.20.1.ebuild188
-rw-r--r--sci-mathematics/maxima/metadata.xml2
4 files changed, 205 insertions, 1 deletions
diff --git a/sci-mathematics/maxima/ChangeLog b/sci-mathematics/maxima/ChangeLog
index d328d99a3b56..06588263a2c9 100644
--- a/sci-mathematics/maxima/ChangeLog
+++ b/sci-mathematics/maxima/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/maxima
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/maxima/ChangeLog,v 1.71 2009/10/07 16:22:36 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/maxima/ChangeLog,v 1.72 2009/12/17 12:24:57 grozin Exp $
+
+*maxima-5.20.1 (17 Dec 2009)
+
+ 17 Dec 2009; Andrey Grozin <grozin@gentoo.org> +maxima-5.20.1.ebuild,
+ +files/maxima-clozurecl.patch, metadata.xml:
+ Version bump, added clozurecl as a supported lisp
07 Oct 2009; nixnut <nixnut@gentoo.org> maxima-5.18.1.ebuild:
ppc stable #264649
diff --git a/sci-mathematics/maxima/files/maxima-clozurecl.patch b/sci-mathematics/maxima/files/maxima-clozurecl.patch
new file mode 100644
index 000000000000..79cdb7a82d33
--- /dev/null
+++ b/sci-mathematics/maxima/files/maxima-clozurecl.patch
@@ -0,0 +1,8 @@
+diff -r -U1 maxima-5.20.1.orig/configure maxima-5.20.1/configure
+--- maxima-5.20.1.orig/configure 2009-12-14 09:20:43.000000000 +0600
++++ maxima-5.20.1/configure 2009-12-17 23:00:13.000000000 +0600
+@@ -2560,3 +2560,3 @@
+
+-openmcl_default_name=openmcl
++openmcl_default_name=ccl
+ # Check whether --enable-openmcl or --disable-openmcl was given.
diff --git a/sci-mathematics/maxima/maxima-5.20.1.ebuild b/sci-mathematics/maxima/maxima-5.20.1.ebuild
new file mode 100644
index 000000000000..df57e1078495
--- /dev/null
+++ b/sci-mathematics/maxima/maxima-5.20.1.ebuild
@@ -0,0 +1,188 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/maxima/maxima-5.20.1.ebuild,v 1.1 2009/12/17 12:24:57 grozin Exp $
+EAPI=2
+inherit eutils elisp-common
+
+DESCRIPTION="Free computer algebra environment based on Macsyma"
+HOMEPAGE="http://maxima.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 AECA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Supported lisps with readline
+SUPP_RL="gcl clisp"
+# Supported lisps without readline
+SUPP_NORL="cmucl sbcl ecl openmcl"
+SUPP_LISPS="${SUPP_RL} ${SUPP_NORL}"
+# Default lisp if none selected
+DEF_LISP="sbcl"
+
+IUSE="latex emacs tk nls unicode xemacs X ${SUPP_LISPS} ${IUSE}"
+
+# Languages
+LANGS="es pt pt_BR"
+for lang in ${LANGS}; do
+ IUSE="${IUSE} linguas_${lang}"
+done
+
+RDEPEND="X? ( x11-misc/xdg-utils
+ sci-visualization/gnuplot[gd]
+ tk? ( dev-lang/tk ) )
+ latex? ( virtual/latex-base )
+ emacs? ( virtual/emacs
+ latex? ( app-emacs/auctex ) )
+ xemacs? ( app-editors/xemacs
+ latex? ( app-emacs/auctex ) )"
+
+PDEPEND="emacs? ( app-emacs/imaxima )"
+
+# create lisp dependencies
+for LISP in ${SUPP_LISPS}; do
+ if [ "${LISP}" = "gcl" ]
+ then
+ RDEPEND="${RDEPEND} gcl? ( >=dev-lisp/gcl-2.6.8_pre[ansi] )"
+ else if [ "${LISP}" = "ecl" ]
+ then
+ RDEPEND="${RDEPEND} ecl? ( >=dev-lisp/ecls-9.8.3 )"
+ else if [ "${LISP}" = "openmcl" ]
+ then
+ RDEPEND="${RDEPEND} openmcl? ( dev-lisp/clozurecl )"
+ else
+ RDEPEND="${RDEPEND} ${LISP}? ( dev-lisp/${LISP} )"
+ fi
+ fi
+ fi
+ DEF_DEP="${DEF_DEP} !${LISP}? ( "
+done
+DEF_DEP="${DEF_DEP} dev-lisp/${DEF_LISP}"
+for LISP in ${SUPP_NORL}; do
+ RDEPEND="${RDEPEND} ${LISP}? ( app-misc/rlwrap )"
+ [[ ${LISP} = ${DEF_LISP} ]] && \
+ DEF_DEP="${DEF_DEP} app-misc/rlwrap"
+done
+for LISP in ${SUPP_LISPS}; do
+ DEF_DEP="${DEF_DEP} )"
+done
+
+RDEPEND="${RDEPEND}
+ ${DEF_DEP}"
+
+DEPEND="${RDEPEND}
+ sys-apps/texinfo"
+
+TEXMF=/usr/share/texmf-site
+NO_INIT_PATCH_PV="5.19.1"
+
+pkg_setup() {
+ LISPS=""
+
+ for LISP in ${SUPP_LISPS}; do
+ use ${LISP} && LISPS="${LISPS} ${LISP}"
+ done
+
+ RL=""
+
+ for LISP in ${SUPP_NORL}; do
+ use ${LISP} && RL="yes"
+ done
+
+ if [ -z "${LISPS}" ]; then
+ ewarn "No lisp specified in USE flags, choosing ${DEF_LISP} as default"
+ LISPS="${DEF_LISP}"
+ RL="yes"
+ fi
+}
+
+src_prepare() {
+ # use xdg-open to view ps, pdf
+ epatch "${FILESDIR}"/${PN}-xdg-utils.patch
+
+ epatch "${FILESDIR}"/${PN}-${NO_INIT_PATCH_PV}-no-init-files.patch
+
+ # ClozureCL executable name is now ccl
+ epatch "${FILESDIR}"/${PN}-clozurecl.patch
+
+ # remove rmaxima if not needed
+ if [ -z "${RL}" ]; then
+ sed -e '/^@WIN32_FALSE@bin_SCRIPTS/s/rmaxima//' \
+ -i "${S}"/src/Makefile.in \
+ || die "sed for rmaxima failed"
+ fi
+
+ # don't install imaxima, since we have a separate package for it
+ sed -i -e '/^SUBDIRS/s/imaxima//' interfaces/emacs/Makefile.in \
+ || die "sed for imaxima failed"
+}
+
+src_configure() {
+ local myconf=""
+ for LISP in ${LISPS}; do
+ myconf="${myconf} --enable-${LISP}"
+ done
+
+ # remove xmaxima if no tk
+ if use tk; then
+ myconf="${myconf} --with-wish=wish"
+ else
+ myconf="${myconf} --with-wish=none"
+ sed -i \
+ -e '/^SUBDIRS/s/xmaxima//' \
+ interfaces/Makefile.in || die "sed for tk failed"
+ fi
+
+ # enable existing translated doc
+ if use nls; then
+ for lang in ${LANGS}; do
+ if use "linguas_${lang}"; then
+ myconf="${myconf} --enable-lang-${lang}"
+ use unicode && myconf="${myconf} --enable-lang-${lang}-utf8"
+ fi
+ done
+ fi
+
+ econf ${myconf}
+}
+
+src_install() {
+ einstall emacsdir="${D}${SITELISP}/${PN}" || die "einstall failed"
+
+ use tk && make_desktop_entry xmaxima xmaxima \
+ /usr/share/${PN}/${PV}/xmaxima/maxima-new.png \
+ "Science;Math;Education"
+
+ if use latex; then
+ insinto ${TEXMF}/tex/latex/emaxima
+ doins interfaces/emacs/emaxima/emaxima.sty
+ fi
+
+ # do not use dodoc because interfaces can't read compressed files
+ # read COPYING before attempt to remove it from dodoc
+ insinto /usr/share/${PN}/${PV}/doc
+ doins AUTHORS COPYING README README.lisps || die
+ dodir /usr/share/doc
+ dosym ../${PN}/${PV}/doc /usr/share/doc/${PF} || die
+
+ if use emacs; then
+ elisp-site-file-install "${FILESDIR}"/50maxima-gentoo.el || die
+ fi
+}
+
+pkg_preinst() {
+ # some lisps do not read compress info files (bug #176411)
+ for infofile in "${D}"/usr/share/info/*.bz2 ; do
+ bunzip2 "${infofile}"
+ done
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ use latex && mktexlsr
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+ use latex && mktexlsr
+}
diff --git a/sci-mathematics/maxima/metadata.xml b/sci-mathematics/maxima/metadata.xml
index 2cde5ed3993c..3d6382d82cb7 100644
--- a/sci-mathematics/maxima/metadata.xml
+++ b/sci-mathematics/maxima/metadata.xml
@@ -23,5 +23,7 @@
(<pkg>dev-lisp/sbcl</pkg>)</flag>
<flag name='ecl'>Add support for Embeddable Common Lisp
(<pkg>dev-lisp/ecls</pkg>)</flag>
+ <flag name='openmcl'>Add support for Clozure Common Lisp
+ (former OpenMCL, <pkg>dev-lisp/closurecl</pkg>)</flag>
</use>
</pkgmetadata>