summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2007-09-20 11:13:42 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2007-09-20 11:13:42 +0000
commitd1dc23e25cc028fcde9e8e1a2dbc37e055ffbbef (patch)
tree03706c348042dc9f44243c0177f2f30915e489cc /sci-mathematics/maxima
parentAdd elibtoolize back for FreeBSD users as we NEED it. (diff)
downloadgentoo-2-d1dc23e25cc028fcde9e8e1a2dbc37e055ffbbef.tar.gz
gentoo-2-d1dc23e25cc028fcde9e8e1a2dbc37e055ffbbef.tar.bz2
gentoo-2-d1dc23e25cc028fcde9e8e1a2dbc37e055ffbbef.zip
Enabling only one lisp. Priority are: 1.sbcl, 2.clisp, 3.
(Portage version: 2.1.3.9)
Diffstat (limited to 'sci-mathematics/maxima')
-rw-r--r--sci-mathematics/maxima/ChangeLog8
-rw-r--r--sci-mathematics/maxima/maxima-5.13.0.ebuild55
2 files changed, 37 insertions, 26 deletions
diff --git a/sci-mathematics/maxima/ChangeLog b/sci-mathematics/maxima/ChangeLog
index 9c81a08af5ad..2fc79624d676 100644
--- a/sci-mathematics/maxima/ChangeLog
+++ b/sci-mathematics/maxima/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/maxima
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/maxima/ChangeLog,v 1.33 2007/09/14 08:39:04 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/maxima/ChangeLog,v 1.34 2007/09/20 11:13:42 bicatali Exp $
+
+ 20 Sep 2007; Sébastien Fabbro <bicatali@gentoo.org> maxima-5.13.0.ebuild:
+ Enabling only one lisp. Priority are: 1.sbcl, 2.clisp, 3.
+ cmucl, 4. gcl, since gcl-2.6.7 is fairly unstable for maxima. Hopefully
+ taking care of bug #192613. General cleaning and commenting, removed
+ useless eautoreconf.
14 Sep 2007; Sébastien Fabbro <bicatali@gentoo.org> maxima-5.9.1.ebuild:
fixed a doc link (bug #182643)
diff --git a/sci-mathematics/maxima/maxima-5.13.0.ebuild b/sci-mathematics/maxima/maxima-5.13.0.ebuild
index bccbcae90f30..79b07e815712 100644
--- a/sci-mathematics/maxima/maxima-5.13.0.ebuild
+++ b/sci-mathematics/maxima/maxima-5.13.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/maxima/maxima-5.13.0.ebuild,v 1.4 2007/09/15 19:30:36 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/maxima/maxima-5.13.0.ebuild,v 1.5 2007/09/20 11:13:42 bicatali Exp $
-inherit eutils elisp-common autotools
+inherit eutils elisp-common
DESCRIPTION="Free computer algebra environment based on Macsyma"
HOMEPAGE="http://maxima.sourceforge.net/"
@@ -34,6 +34,8 @@ for lang in ${LANGS}; do
IUSE="${IUSE} linguas_${lang}"
done
+RESTRICT="clisp? ( strip )"
+
pkg_setup() {
# Don't install in the main tree, as this may cause file collisions
if use tetex; then
@@ -68,20 +70,28 @@ pkg_setup() {
fi
fi
- if ! built_with_use -a sci-visualization/gnuplot gd; then
+ if ! built_with_use sci-visualization/gnuplot gd; then
elog "To benefit full plotting capability of maxima,"
elog "enable the gd USE flag enabled for sci-visualization/gnuplot"
elog "Then re-emerge maxima"
epause 5
fi
- # enable gcl if no other lisp selected
- if use sbcl || (! use cmucl && ! use clisp && ! use gcl ); then
- ENABLE_SBCL="--enable-sbcl"
+ # lisp priorities
+ MAXIMA_LISP="sbcl"
+ if use clisp && use gcl && ! use sbcl; then
+ MAXIMA_LISP=clisp
+ elif use clisp && use cmucl && ! use sbcl; then
+ MAXIMA_LISP=clisp
+ elif use cmucl && use gcl && ! use sbcl; then
+ MAXIMA_LISP=cmucl
+ elif use gcl && ! use sbcl; then
+ MAXIMA_LISP=gcl
fi
+ einfo "Selected lisp: ${MAXIMA_LISP}"
- if use gcl; then
- einfo "Using gcl: it might break, recompile with another lisp, or use default (sbcl)."
+ if [[ ${MAXIMA_LISP} == gcl ]]; then
+ ewarn "Using gcl: if it breaks, recompile with another lisp or use default (sbcl)."
if ! built_with_use dev-lisp/gcl ansi; then
eerror "GCL must be installed with ANSI."
eerror "Try USE=\"ansi\" emerge gcl"
@@ -94,20 +104,17 @@ src_unpack() {
unpack ${A}
# use xdg-open to view ps, pdf
epatch "${FILESDIR}"/${P}-xdg-utils.patch
-}
-
-src_compile() {
- eautoreconf
-
# remove rmaxima if neither cmucl nor sbcl
- if ! use sbcl && ! use cmucl && [[ -z ${ENABLE_SBCL} ]]; then
+ if [[ ${MAXIMA_LISP} != cmucl ]] || [[ ${MAXIMA_LISP} != sbcl ]]; then
sed -i \
-e '/^@WIN32_FALSE@bin_SCRIPTS/s/rmaxima//' \
- src/Makefile.in || die "sed for rmaxima failed"
+ "${S}"/src/Makefile.in \
+ || die "sed for rmaxima failed"
fi
+}
- local myconf=${ENABLE_SBCL}
-
+src_compile() {
+ local myconf="--enable-${MAXIMA_LISP}"
# remove xmaxima if no tk
if use tk; then
myconf="${myconf} --with-wish=wish"
@@ -128,12 +135,7 @@ src_compile() {
done
fi
- econf \
- $(use_enable cmucl) \
- $(use_enable clisp) \
- $(use_enable gcl) \
- ${myconf} \
- || die "econf failed"
+ econf ${myconf} || die "econf failed"
emake || die "emake failed"
}
@@ -160,10 +162,13 @@ src_install() {
}
pkg_preinst() {
- # all lisps do not bunzip2 info files on the fly
- for infofile in $(ls ${D}/usr/share/info/*.bz2); do
+ # some lisps do not read compress info files (bug #176411)
+ for infofile in "${D}"/usr/share/info/*.bz2 ; do
bunzip2 "${infofile}"
done
+ for infofile in "${D}"/usr/share/info/*.gz ; do
+ gunzip "${infofile}"
+ done
}
pkg_postinst() {