summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2012-05-11 16:11:40 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2012-05-11 16:11:40 +0000
commitc0a392a36002a69db4d0808a18e2ef54744bba64 (patch)
treec1985961ac5eddafd29ef21705bdee3a9ba265af /sci-mathematics/mlpy/mlpy-3.5.0.ebuild
parentVersion bump. (diff)
downloadgentoo-2-c0a392a36002a69db4d0808a18e2ef54744bba64.tar.gz
gentoo-2-c0a392a36002a69db4d0808a18e2ef54744bba64.tar.bz2
gentoo-2-c0a392a36002a69db4d0808a18e2ef54744bba64.zip
New package: Machine Learning PYthon (mlpy) is a high-performance Python library for predictive modeling.
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/mlpy/mlpy-3.5.0.ebuild')
-rw-r--r--sci-mathematics/mlpy/mlpy-3.5.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sci-mathematics/mlpy/mlpy-3.5.0.ebuild b/sci-mathematics/mlpy/mlpy-3.5.0.ebuild
new file mode 100644
index 000000000000..79837aa931d9
--- /dev/null
+++ b/sci-mathematics/mlpy/mlpy-3.5.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mlpy/mlpy-3.5.0.ebuild,v 1.1 2012/05/11 16:11:40 dberkholz Exp $
+
+EAPI=4
+
+inherit distutils
+
+DESCRIPTION="Machine Learning PYthon (mlpy) is a high-performance Python library for predictive modeling"
+HOMEPAGE="https://mlpy.fbk.eu/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+RDEPEND=">=sci-libs/gsl-1.11
+ >=dev-python/numpy-1.3
+ >=sci-libs/scipy-0.7
+ >=dev-lang/python-2.6"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx )"
+
+src_install() {
+ distutils_src_install
+ if use doc; then
+ pushd docs 2>/dev/null || die
+ emake html || die
+ dohtml -r build/html/*
+ popd 2>/dev/null || die
+ fi
+}