summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2012-11-12 03:15:19 +0000
committerThomas Kahle <tomka@gentoo.org>2012-11-12 03:15:19 +0000
commitfac6852b80d6cdc08e06bc2828e4381525bd1904 (patch)
treec8f4f3af58f5bb49afc250e77d6b9d24a8164e0f /sci-mathematics/normaliz
parentProper static libs removal (diff)
downloadgentoo-2-fac6852b80d6cdc08e06bc2828e4381525bd1904.tar.gz
gentoo-2-fac6852b80d6cdc08e06bc2828e4381525bd1904.tar.bz2
gentoo-2-fac6852b80d6cdc08e06bc2828e4381525bd1904.zip
Bump to 2.8
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x89DEB219565C32BC)
Diffstat (limited to 'sci-mathematics/normaliz')
-rw-r--r--sci-mathematics/normaliz/ChangeLog11
-rw-r--r--sci-mathematics/normaliz/files/normaliz-2.8-respect-flags.patch67
-rw-r--r--sci-mathematics/normaliz/normaliz-2.8.ebuild56
3 files changed, 131 insertions, 3 deletions
diff --git a/sci-mathematics/normaliz/ChangeLog b/sci-mathematics/normaliz/ChangeLog
index 0cc9988770f7..d1e7ed5322d4 100644
--- a/sci-mathematics/normaliz/ChangeLog
+++ b/sci-mathematics/normaliz/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/normaliz
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/normaliz/ChangeLog,v 1.8 2011/11/14 11:28:36 flameeyes Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/normaliz/ChangeLog,v 1.9 2012/11/12 03:15:19 tomka Exp $
+
+*normaliz-2.8 (12 Nov 2012)
+
+ 12 Nov 2012; Thomas Kahle <tomka@gentoo.org>
+ +files/normaliz-2.8-respect-flags.patch, +normaliz-2.8.ebuild:
+ Bump to 2.8
14 Nov 2011; Diego E. Pettenò <flameeyes@gentoo.org> normaliz-2.5-r1.ebuild,
normaliz-2.7.ebuild:
@@ -36,4 +42,3 @@
03 Nov 2010; Thomas Kahle <tomka@gentoo.org> +normaliz-2.5-r1.ebuild,
+files/normaliz-2.5-makefile.patch, +metadata.xml:
Initial import of normaliz from science overlay
-
diff --git a/sci-mathematics/normaliz/files/normaliz-2.8-respect-flags.patch b/sci-mathematics/normaliz/files/normaliz-2.8-respect-flags.patch
new file mode 100644
index 000000000000..ebde3a0a35ec
--- /dev/null
+++ b/sci-mathematics/normaliz/files/normaliz-2.8-respect-flags.patch
@@ -0,0 +1,67 @@
+diff -U 3 -dHrN Normaliz2.8.orig/source/libnormaliz/Makefile Normaliz2.8/source/libnormaliz/Makefile
+--- Normaliz2.8.orig/source/libnormaliz/Makefile 2012-11-11 19:05:18.610268519 -0800
++++ Normaliz2.8/source/libnormaliz/Makefile 2012-11-11 19:07:17.040437439 -0800
+@@ -11,16 +11,16 @@
+ all: default
+
+ libnormaliz.o: $(LIBHEADERS) $(LIBSOURCES) libnormaliz-impl.cpp
+- $(CXX) $(CXXFLAGS) $(NORMFLAGS) -c libnormaliz-impl.cpp -o libnormaliz.o
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) $(NORMFLAGS) -c libnormaliz-impl.cpp -o libnormaliz.o
+
+ cone_property.o: cone_property.h cone_property.cpp
+- $(CXX) $(CXXFLAGS) $(NORMFLAGS) -c cone_property.cpp -o $@
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) $(NORMFLAGS) -c cone_property.cpp -o $@
+
+ hilbert_series.o: $(LIBHEADERS) HilbertSeries.cpp
+- $(CXX) $(CXXFLAGS) $(NORMFLAGS) -c HilbertSeries.cpp -o $@
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) $(NORMFLAGS) -c HilbertSeries.cpp -o $@
+
+ libnormaliz-templated.o: $(LIBHEADERS) $(LIBSOURCES) libnormaliz-templated.cpp
+- $(CXX) $(CXXFLAGS) $(NORMFLAGS) -c libnormaliz-templated.cpp -o $@
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) $(NORMFLAGS) -c libnormaliz-templated.cpp -o $@
+
+ libnormaliz.a: cone_property.o hilbert_series.o libnormaliz-templated.o
+ ar -cr $@ $^
+diff -U 3 -dHrN Normaliz2.8.orig/source/Makefile Normaliz2.8/source/Makefile
+--- Normaliz2.8.orig/source/Makefile 2012-11-11 19:05:18.610268519 -0800
++++ Normaliz2.8/source/Makefile 2012-11-11 19:06:14.265817851 -0800
+@@ -17,13 +17,13 @@
+ $(MAKE) normaliz
+
+ normaliz: $(SOURCES) $(HEADERS) libnormaliz/libnormaliz.a
+- $(CXX) $(CXXFLAGS) $(NORMFLAGS) Normaliz.cpp libnormaliz/libnormaliz.a $(GMPFLAGS) -o normaliz
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) $(NORMFLAGS) Normaliz.cpp libnormaliz/libnormaliz.a $(GMPFLAGS) -o normaliz
+
+ normaliz1: $(SOURCES) $(HEADERS) $(LIBHEADERS) $(LIBSOURCES)
+- $(CXX) $(CXXFLAGS) $(NORMFLAGS) Normaliz-impl.cpp $(GMPFLAGS) -o normaliz1
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) $(NORMFLAGS) Normaliz-impl.cpp $(GMPFLAGS) -o normaliz1
+
+ normaliz-pg: $(SOURCES) $(HEADERS) $(LIBHEADERS) $(LIBSOURCES)
+- $(CXX) $(CXXFLAGS) $(NORMFLAGS) -pg Normaliz-impl.cpp $(GMPFLAGS) -o normaliz-pg
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) $(NORMFLAGS) -pg Normaliz-impl.cpp $(GMPFLAGS) -o normaliz-pg
+
+
+ #always go down the directory and let the make there check what has to be done
+diff -U 3 -dHrN Normaliz2.8.orig/source/Makefile.configuration Normaliz2.8/source/Makefile.configuration
+--- Normaliz2.8.orig/source/Makefile.configuration 2012-11-11 19:05:18.613268547 -0800
++++ Normaliz2.8/source/Makefile.configuration 2012-11-11 19:05:37.323453221 -0800
+@@ -1,11 +1,9 @@
+ ##
+ ## Makefile configuration for normaliz
+ ##
+-CXX = g++
+ #CXX = linux32 g++ -m32 -march=i686 #compile it for linux32
+ CXXFLAGS += -Wall
+ CXXFLAGS += -pedantic -Wno-long-long
+-CXXFLAGS += -O3 -funroll-loops
+ #CXXFLAGS += -I /usr/local/boost_1_45_0
+ #CXXFLAGS += -g
+ #CXXFLAGS += -pg
+@@ -19,7 +17,6 @@
+ endif
+
+ ##for mac link libgcc not static
+-NORMFLAGS = -static
+ #NORMFLAGS = -static-libgcc
+
+ GMPFLAGS = -lgmpxx -lgmp
diff --git a/sci-mathematics/normaliz/normaliz-2.8.ebuild b/sci-mathematics/normaliz/normaliz-2.8.ebuild
new file mode 100644
index 000000000000..0fd880cf5915
--- /dev/null
+++ b/sci-mathematics/normaliz/normaliz-2.8.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/normaliz/normaliz-2.8.ebuild,v 1.1 2012/11/12 03:15:19 tomka Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+MYP="Normaliz${PV}"
+
+DESCRIPTION="tool for computations in affine monoids and more"
+HOMEPAGE="http://www.mathematik.uni-osnabrueck.de/normaliz/"
+SRC_URI="http://www.mathematik.uni-osnabrueck.de/${PN}/${MYP}/${MYP}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="extras openmp"
+
+RDEPEND="dev-libs/gmp[cxx]"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-libs/boost"
+# Only a boost header is needed -> not RDEPEND
+
+S=${WORKDIR}/${MYP}
+
+src_prepare () {
+ epatch "${FILESDIR}/${P}-respect-flags.patch"
+
+ if use openmp && tc-has-openmp; then
+ export OPENMP=yes
+ else
+ export OPENMP=no
+ fi
+}
+
+src_compile(){
+ emake CXX="$(tc-getCXX)" OPENMP="${OPENMP}" -C source
+}
+
+src_install() {
+ dobin source/normaliz
+ dodoc doc/"${MYP}Documentation.pdf"
+ if use extras; then
+ elog "You have selected to install extras which consist of Macaulay2"
+ elog "and Singular packages. These have been installed into "
+ elog "/usr/share/${PN}, and cannot be used without additional setup. Please refer"
+ elog "to the homepages of the respective projects for additional information."
+ elog "Note however, Gentoo's versions of Singular and Macaulay2 bring their own"
+ elog "copies of these interface packages. Usually you don't need normaliz's versions."
+ insinto "/usr/share/${PN}"
+ doins Singular/normaliz.lib
+ doins Macaulay2/Normaliz.m2
+ fi
+}