summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-05-18 17:10:18 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-05-18 17:10:18 +0000
commita8e76b72e279f695e5d2ba5ca4f0847d589a3bc1 (patch)
tree52eb9a51e2679268cd3a338313da1d71d0c04204 /sci-mathematics/nusmv
parentamd64/x86 stable, bug #221063 (diff)
downloadgentoo-2-a8e76b72e279f695e5d2ba5ca4f0847d589a3bc1.tar.gz
gentoo-2-a8e76b72e279f695e5d2ba5ca4f0847d589a3bc1.tar.bz2
gentoo-2-a8e76b72e279f695e5d2ba5ca4f0847d589a3bc1.zip
Switched virtual/tetex -> virtual/latex-base (see bug #222501).
(Portage version: 2.1.5_rc10)
Diffstat (limited to 'sci-mathematics/nusmv')
-rw-r--r--sci-mathematics/nusmv/ChangeLog7
-rw-r--r--sci-mathematics/nusmv/nusmv-2.3.1.ebuild25
2 files changed, 19 insertions, 13 deletions
diff --git a/sci-mathematics/nusmv/ChangeLog b/sci-mathematics/nusmv/ChangeLog
index e7a8113388e8..e63e0a3ef5b3 100644
--- a/sci-mathematics/nusmv/ChangeLog
+++ b/sci-mathematics/nusmv/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-mathematics/nusmv
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/nusmv/ChangeLog,v 1.2 2007/02/22 01:29:59 jokey Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/nusmv/ChangeLog,v 1.3 2008/05/18 17:10:18 markusle Exp $
+
+ 18 May 2008; Markus Dittrich <markusle@gentoo.org> nusmv-2.3.1.ebuild:
+ Switched virtual/tetex -> virtual/latex-base (see bug #222501).
22 Feb 2007; Markus Ullmann <jokey@gentoo.org> ChangeLog:
Redigest for Manifest2
diff --git a/sci-mathematics/nusmv/nusmv-2.3.1.ebuild b/sci-mathematics/nusmv/nusmv-2.3.1.ebuild
index b0a8407c2977..0450ddd2eb83 100644
--- a/sci-mathematics/nusmv/nusmv-2.3.1.ebuild
+++ b/sci-mathematics/nusmv/nusmv-2.3.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/nusmv/nusmv-2.3.1.ebuild,v 1.1 2006/04/02 11:40:21 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/nusmv/nusmv-2.3.1.ebuild,v 1.2 2008/05/18 17:10:18 markusle Exp $
inherit eutils toolchain-funcs
@@ -33,12 +33,15 @@ SRC_URI="mirror://gentoo/${NUSMV_A}
minisat? ( mirror://gentoo/${MINISAT_A} )"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~x86 ~amd64"
IUSE="minisat examples"
RDEPEND="virtual/libc
dev-libs/expat"
DEPEND="${RDEPEND}
- virtual/tetex
+ virtual/latex-base
+ || ( ( dev-texlive/texlive-latexextra )
+ app-text/tetex
+ app-text/ptex )
virtual/ghostscript
www-client/lynx
dev-lang/perl"
@@ -50,10 +53,10 @@ S="${NUSMV_S}"
src_unpack() {
unpack ${NUSMV_A}
if use minisat; then
- cd ${WORKDIR}/${NUSMV_P}/MiniSat
+ cd "${WORKDIR}"/${NUSMV_P}/MiniSat
unpack ${MINISAT_A}
epatch ${MINISAT_P}_nusmv.patch
- epatch ${FILESDIR}/${MINISAT_P}-optimizedlib.patch
+ epatch "${FILESDIR}"/${MINISAT_P}-optimizedlib.patch
fi
for i in ${NUSMV_S}/doc/{user-man,tutorial}/Makefile.in ; do
sed -i.orig \
@@ -69,7 +72,7 @@ src_compile() {
# do NOT merge these targets
emake COPTIMIZE="${CFLAGS}" r || die "Failed to build minisat bin"
emake COPTIMIZE="${CFLAGS}" lr || die "Failed to build minisat lib"
- ln -sf ${MINISAT_S} ${WORKDIR}/${NUSMV_P}/${MINISAT_P}
+ ln -sf ${MINISAT_S} "${WORKDIR}"/${NUSMV_P}/${MINISAT_P}
fi
cd ${CUDD_S}
@@ -99,19 +102,19 @@ src_install() {
cd ${NUSMV_S}
emake DESTDIR="${D}" install || die "emake install failed"
# duplicate items
- rm -f ${D}/usr/share/nusmv/{LGPL-2.1,README*,NEWS}
+ rm -f "${D}"/usr/share/nusmv/{LGPL-2.1,README*,NEWS}
# real docs
dodoc README* NEWS AUTHORS
dodoc doc/tutorial/tutorial.pdf
dodoc doc/user-man/nusmv.pdf
# move package-installed docs
- mv ${D}/usr/share/nusmv/doc/* ${D}/usr/share/doc/${PF}/
- rmdir ${D}/usr/share/nusmv/doc
+ mv "${D}"/usr/share/nusmv/doc/* "${D}"/usr/share/doc/${PF}/
+ rmdir "${D}"/usr/share/nusmv/doc
# clean out examples if not needed
if use !examples ; then
- rm -rf ${D}/usr/share/nusmv/examples || die "Failed to remove examples"
+ rm -rf "${D}"/usr/share/nusmv/examples || die "Failed to remove examples"
fi
}