summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-06-09 21:58:24 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-06-09 21:58:24 +0000
commit7a1f3b2395c8bab6be775fcaf21af989ae17f444 (patch)
tree4ab327c528af2d979d28955b57b9a0ccc98c90db /sci-mathematics/octave/files
parentExplicitly inherit the eutils eclass. (diff)
downloadgentoo-2-7a1f3b2395c8bab6be775fcaf21af989ae17f444.tar.gz
gentoo-2-7a1f3b2395c8bab6be775fcaf21af989ae17f444.tar.bz2
gentoo-2-7a1f3b2395c8bab6be775fcaf21af989ae17f444.zip
Added some patches for compiling on gcc-4.6, fixing fltk, and building packages directory from fedora. Added a parallel compilation patch.
(Portage version: 2.1.10/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/octave/files')
-rw-r--r--sci-mathematics/octave/files/octave-3.4.0-fltk.patch24
-rw-r--r--sci-mathematics/octave/files/octave-3.4.0-gcc46.patch24
-rw-r--r--sci-mathematics/octave/files/octave-3.4.0-help.patch13
-rw-r--r--sci-mathematics/octave/files/octave-3.4.0-pkgbuilddir.patch41
4 files changed, 102 insertions, 0 deletions
diff --git a/sci-mathematics/octave/files/octave-3.4.0-fltk.patch b/sci-mathematics/octave/files/octave-3.4.0-fltk.patch
new file mode 100644
index 000000000000..eff3642542c6
--- /dev/null
+++ b/sci-mathematics/octave/files/octave-3.4.0-fltk.patch
@@ -0,0 +1,24 @@
+diff -up octave-3.4.0/src/DLD-FUNCTIONS/__fltk_uigetfile__.cc.fltk octave-3.4.0/src/DLD-FUNCTIONS/__fltk_uigetfile__.cc
+--- octave-3.4.0/src/DLD-FUNCTIONS/__fltk_uigetfile__.cc.fltk 2011-02-08 03:00:52.000000000 -0700
++++ octave-3.4.0/src/DLD-FUNCTIONS/__fltk_uigetfile__.cc 2011-05-26 14:09:51.277484258 -0600
+@@ -27,7 +27,7 @@ along with Octave; see the file COPYING.
+ #if defined (HAVE_FLTK)
+
+ #include <FL/Fl.H>
+-#include <Fl/Fl_File_Chooser.H>
++#include <FL/Fl_File_Chooser.H>
+
+ // FLTK headers may include X11/X.h which defines Complex, and that
+ // conflicts with Octave's Complex typedef. We don't need the X11
+diff -up octave-3.4.0/src/DLD-FUNCTIONS/__init_fltk__.cc.fltk octave-3.4.0/src/DLD-FUNCTIONS/__init_fltk__.cc
+--- octave-3.4.0/src/DLD-FUNCTIONS/__init_fltk__.cc.fltk 2011-05-26 14:10:40.447667595 -0600
++++ octave-3.4.0/src/DLD-FUNCTIONS/__init_fltk__.cc 2011-05-26 14:10:14.456627808 -0600
+@@ -44,7 +44,7 @@ To initialize:
+ #include <FL/Fl_Box.H>
+ #include <FL/Fl_Button.H>
+ #include <FL/Fl_Choice.H>
+-#include <Fl/Fl_File_Chooser.H>
++#include <FL/Fl_File_Chooser.H>
+ #include <FL/Fl_Gl_Window.H>
+ #include <FL/Fl_Menu_Bar.H>
+ #include <FL/Fl_Menu_Button.H>
diff --git a/sci-mathematics/octave/files/octave-3.4.0-gcc46.patch b/sci-mathematics/octave/files/octave-3.4.0-gcc46.patch
new file mode 100644
index 000000000000..c174204acedb
--- /dev/null
+++ b/sci-mathematics/octave/files/octave-3.4.0-gcc46.patch
@@ -0,0 +1,24 @@
+diff -up octave-3.4.0/liboctave/oct-alloc.h.gcc46 octave-3.4.0/liboctave/oct-alloc.h
+--- octave-3.4.0/liboctave/oct-alloc.h.gcc46 2011-02-08 03:00:51.000000000 -0700
++++ octave-3.4.0/liboctave/oct-alloc.h 2011-02-08 09:41:23.984081687 -0700
+@@ -23,6 +23,8 @@ along with Octave; see the file COPYING.
+ #if !defined (octave_oct_alloc_h)
+ #define octave_oct_alloc_h 1
+
++#include <cstddef>
++
+ class
+ OCTAVE_API
+ octave_allocator
+diff -up octave-3.4.0/src/pr-output.cc.gcc46 octave-3.4.0/src/pr-output.cc
+--- octave-3.4.0/src/pr-output.cc.gcc46 2011-02-08 03:00:52.000000000 -0700
++++ octave-3.4.0/src/pr-output.cc 2011-02-08 09:55:16.149662744 -0700
+@@ -3024,7 +3024,7 @@ abs (T x)
+ }
+
+ #define INSTANTIATE_ABS(T) \
+- template /* static */ inline T abs (T)
++ template /* static */ T abs (T)
+
+ INSTANTIATE_ABS(signed char);
+ INSTANTIATE_ABS(short);
diff --git a/sci-mathematics/octave/files/octave-3.4.0-help.patch b/sci-mathematics/octave/files/octave-3.4.0-help.patch
new file mode 100644
index 000000000000..de98300b6c40
--- /dev/null
+++ b/sci-mathematics/octave/files/octave-3.4.0-help.patch
@@ -0,0 +1,13 @@
+Help parallel compilation
+patch by Sebastien Fabbro
+--- octave-3.4.0/scripts/Makefile.am.orig 2011-06-09 22:27:22.688268651 +0100
++++ octave-3.4.0/scripts/Makefile.am 2011-02-08 10:00:51.000000000 +0000
+@@ -316,7 +316,7 @@
+
+ gethelp_SOURCES = gethelp.cc
+
+-.DOCSTRINGS: $(FCN_FILES) $(GEN_FCN_FILES) mkdoc $(gethelp_SOURCES) Makefile
++.DOCSTRINGS: $(FCN_FILES) $(GEN_FCN_FILES) mkdoc $(gethelp_SOURCES) Makefile gethelp
+ @$(MAKE) $(AM_MAKEFLAGS) gethelp$(BUILD_EXEEXT)
+ if [ "x$(srcdir)" != "x." ] && [ -f $(srcdir)/DOCSTRINGS ] && [ ! -f DOCSTRINGS ]; then \
+ cp $(srcdir)/DOCSTRINGS DOCSTRINGS; \
diff --git a/sci-mathematics/octave/files/octave-3.4.0-pkgbuilddir.patch b/sci-mathematics/octave/files/octave-3.4.0-pkgbuilddir.patch
new file mode 100644
index 000000000000..c6811dce284b
--- /dev/null
+++ b/sci-mathematics/octave/files/octave-3.4.0-pkgbuilddir.patch
@@ -0,0 +1,41 @@
+--- octave-3.4.0/scripts/pkg/pkg.m.pkgbuilddir 2011-02-08 03:00:51.000000000 -0700
++++ octave-3.4.0/scripts/pkg/pkg.m 2011-03-18 09:31:24.670165643 -0600
+@@ -644,7 +644,14 @@
+ for i = 1:length (files)
+ tgz = files{i};
+
+- if (exist (tgz, "file"))
++ ## The filename pointed to an uncompressed package to begin with.
++ if (exist (tgz, "dir"))
++ if (tgz(1) == '/')
++ packdir = tgz;
++ else
++ packdir = fullfile (pwd(), tgz);
++ endif
++ elseif (exist (tgz, "file"))
+ ## Create a temporary directory.
+ tmpdir = tmpnam ();
+ tmpdirs{end+1} = tmpdir;
+@@ -671,20 +678,12 @@
+ if (length (dirlist) > 3)
+ error ("bundles of packages are not allowed");
+ endif
+- endif
+
+- ## The filename pointed to an uncompressed package to begin with.
+- if (exist (tgz, "dir"))
+- dirlist = {".", "..", tgz};
++ ## The two first entries of dirlist are "." and "..".
++ packdir = fullfile (tmpdir, dirlist{3});
+ endif
+
+ if (exist (tgz, "file") || exist (tgz, "dir"))
+- ## The two first entries of dirlist are "." and "..".
+- if (exist (tgz, "file"))
+- packdir = fullfile (tmpdir, dirlist{3});
+- else
+- packdir = fullfile (pwd(), dirlist{3});
+- endif
+ packdirs{end+1} = packdir;
+
+ ## Make sure the package contains necessary files.