summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2011-07-12 20:52:00 +0000
committerRafael Martins <rafaelmartins@gentoo.org>2011-07-12 20:52:00 +0000
commit3a6a83c28ab69f8a02ed1e681fb1833312d2e4e0 (patch)
treeeac22475a1ffacd1c043d7b987b047fac29db184 /sci-mathematics/octave
parentUse the session files from kdm, bug 364861 (diff)
downloadgentoo-2-3a6a83c28ab69f8a02ed1e681fb1833312d2e4e0.tar.gz
gentoo-2-3a6a83c28ab69f8a02ed1e681fb1833312d2e4e0.tar.bz2
gentoo-2-3a6a83c28ab69f8a02ed1e681fb1833312d2e4e0.zip
Revision bump. Fixes bug #373985. Thanks to trubatch@hotmail.com for reporting.
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/octave')
-rw-r--r--sci-mathematics/octave/ChangeLog10
-rw-r--r--sci-mathematics/octave/files/octave-3.4.0-fftshift.patch19
-rw-r--r--sci-mathematics/octave/octave-3.4.0-r2.ebuild (renamed from sci-mathematics/octave/octave-3.4.0-r1.ebuild)4
3 files changed, 30 insertions, 3 deletions
diff --git a/sci-mathematics/octave/ChangeLog b/sci-mathematics/octave/ChangeLog
index f438c48b9af2..fd163c90b232 100644
--- a/sci-mathematics/octave/ChangeLog
+++ b/sci-mathematics/octave/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-mathematics/octave
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.104 2011/06/13 22:39:30 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.105 2011/07/12 20:52:00 rafaelmartins Exp $
+
+*octave-3.4.0-r2 (12 Jul 2011)
+
+ 12 Jul 2011; Rafael G. Martins <rafaelmartins@gentoo.org>
+ -octave-3.4.0-r1.ebuild, +octave-3.4.0-r2.ebuild,
+ +files/octave-3.4.0-fftshift.patch:
+ Revision bump. Fixes bug #373985. Thanks to trubatch@hotmail.com for
+ reporting.
13 Jun 2011; Sébastien Fabbro <bicatali@gentoo.org> octave-3.4.0-r1.ebuild:
Added missing autotools eclass
diff --git a/sci-mathematics/octave/files/octave-3.4.0-fftshift.patch b/sci-mathematics/octave/files/octave-3.4.0-fftshift.patch
new file mode 100644
index 000000000000..bf163dede1d2
--- /dev/null
+++ b/sci-mathematics/octave/files/octave-3.4.0-fftshift.patch
@@ -0,0 +1,19 @@
+Reference: http://hg.savannah.gnu.org/hgweb/octave/rev/189baf055143
+
+diff -r e4dbfe3019b1 -r 189baf055143 scripts/signal/fftshift.m
+--- a/scripts/signal/fftshift.m Sat Feb 19 18:21:58 2011 -0800
++++ b/scripts/signal/fftshift.m Sun Feb 20 17:53:41 2011 -0800
+@@ -65,9 +65,9 @@
+ retval = x(idx{:});
+ else
+ if (isvector (x))
+- x = length (x);
+- xx = ceil (x/2);
+- retval = x([xx+1:x, 1:xx]);
++ xl = length (x);
++ xx = ceil (xl/2);
++ retval = x([xx+1:xl, 1:xx]);
+ elseif (ismatrix (x))
+ nd = ndims (x);
+ sz = size (x);
+
diff --git a/sci-mathematics/octave/octave-3.4.0-r1.ebuild b/sci-mathematics/octave/octave-3.4.0-r2.ebuild
index c4ab3b100106..686a22da1240 100644
--- a/sci-mathematics/octave/octave-3.4.0-r1.ebuild
+++ b/sci-mathematics/octave/octave-3.4.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-3.4.0-r1.ebuild,v 1.2 2011/06/13 22:39:30 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-3.4.0-r2.ebuild,v 1.1 2011/07/12 20:52:00 rafaelmartins Exp $
EAPI=4
inherit eutils base autotools
@@ -47,7 +47,7 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig"
src_prepare() {
- epatch "${FILESDIR}"/${P}-{gcc46,pkgbuilddir,fltk,help}.patch
+ epatch "${FILESDIR}"/${P}-{gcc46,pkgbuilddir,fltk,help,fftshift}.patch
eautoreconf
}