summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-11-25 17:39:01 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-11-25 17:39:01 +0000
commit799036129895648ecf1fd9c494c44db869699b4e (patch)
treeabb954b5af534e4a6b8562194af36c864a93abc8 /sci-mathematics/octave
parentppc64 stable wrt #388431 (diff)
downloadgentoo-2-799036129895648ecf1fd9c494c44db869699b4e.tar.gz
gentoo-2-799036129895648ecf1fd9c494c44db869699b4e.tar.bz2
gentoo-2-799036129895648ecf1fd9c494c44db869699b4e.zip
Version bump. Removed some patches applied upstream
(Portage version: 2.1.10.37/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/octave')
-rw-r--r--sci-mathematics/octave/ChangeLog7
-rw-r--r--sci-mathematics/octave/octave-3.4.3.ebuild86
2 files changed, 92 insertions, 1 deletions
diff --git a/sci-mathematics/octave/ChangeLog b/sci-mathematics/octave/ChangeLog
index 6aac2376c9d4..932f1aba8da1 100644
--- a/sci-mathematics/octave/ChangeLog
+++ b/sci-mathematics/octave/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/octave
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.107 2011/10/05 18:44:23 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.108 2011/11/25 17:39:01 bicatali Exp $
+
+*octave-3.4.3 (25 Nov 2011)
+
+ 25 Nov 2011; Sébastien Fabbro <bicatali@gentoo.org> +octave-3.4.3.ebuild:
+ Version bump. Removed some patches applied upstream
05 Oct 2011; Alexis Ballier <aballier@gentoo.org> octave-3.2.4-r1.ebuild,
octave-3.2.4-r3.ebuild, octave-3.4.0-r2.ebuild:
diff --git a/sci-mathematics/octave/octave-3.4.3.ebuild b/sci-mathematics/octave/octave-3.4.3.ebuild
new file mode 100644
index 000000000000..4510d5820534
--- /dev/null
+++ b/sci-mathematics/octave/octave-3.4.3.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-3.4.3.ebuild,v 1.1 2011/11/25 17:39:01 bicatali Exp $
+
+EAPI=4
+inherit eutils base autotools
+
+DESCRIPTION="High-level interactive language for numerical computations"
+LICENSE="GPL-3"
+HOMEPAGE="http://www.octave.org/"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${P}.tar.bz2"
+
+SLOT="0"
+IUSE="curl doc fftw readline sparse test zlib"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="dev-libs/libpcre
+ media-gfx/graphicsmagick[cxx]
+ media-libs/ftgl
+ media-libs/qhull
+ sci-libs/qrupdate
+ sci-mathematics/glpk
+ sci-visualization/gnuplot
+ sys-libs/ncurses
+ virtual/lapack
+ virtual/opengl
+ x11-libs/libX11
+ >=x11-libs/fltk-1.3:1[opengl]
+ curl? ( net-misc/curl )
+ fftw? ( sci-libs/fftw:3.0 )
+ sparse? (
+ sci-libs/camd
+ sci-libs/ccolamd
+ sci-libs/cholmod
+ sci-libs/colamd
+ sci-libs/cxsparse
+ sci-libs/umfpack )
+ zlib? ( sys-libs/zlib )
+ !sci-mathematics/octave-forge"
+
+DEPEND="${RDEPEND}
+ virtual/latex-base
+ sys-apps/texinfo
+ dev-texlive/texlive-genericrecommended
+ dev-util/gperf
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.4.0-{pkgbuilddir,help}.patch
+ eautoreconf
+}
+
+src_configure() {
+ # hdf5 disabled because not really useful (bug #299876)
+ econf \
+ --localstatedir=/var/state/octave \
+ --enable-shared \
+ --without-hdf5 \
+ --with-glpk \
+ --with-opengl \
+ --with-qrupdate \
+ --with-blas="$(pkg-config --libs blas)" \
+ --with-lapack="$(pkg-config --libs lapack)" \
+ $(use_enable readline) \
+ $(use_with curl) \
+ $(use_with fftw fftw3) \
+ $(use_with fftw fftw3f) \
+ $(use_with sparse umfpack) \
+ $(use_with sparse colamd) \
+ $(use_with sparse ccolamd) \
+ $(use_with sparse cholmod) \
+ $(use_with sparse cxsparse) \
+ $(use_with zlib z)
+}
+
+src_install() {
+ default
+ if use doc; then
+ einfo "Installing documentation..."
+ insinto /usr/share/doc/${PF}
+ doins $(find doc -name \*.pdf)
+ fi
+ use test && dodoc test/fntests.log
+ echo "LDPATH=/usr/$(get_libdir)/octave-${PV}" > 99octave
+ doenvd 99octave || die
+}