summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-08-01 21:38:31 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-08-01 21:38:31 +0000
commit78f3d5de0e4a09fb79fecb54a5cae10d22d360fe (patch)
tree2124f0ac479f363187ef60f1c059dd7180e8cf26 /sci-mathematics/pari/files
parentVersion bump (diff)
downloadgentoo-2-78f3d5de0e4a09fb79fecb54a5cae10d22d360fe.tar.gz
gentoo-2-78f3d5de0e4a09fb79fecb54a5cae10d22d360fe.tar.bz2
gentoo-2-78f3d5de0e4a09fb79fecb54a5cae10d22d360fe.zip
Fixed automagic dependencies against fltk and qt as noted by Burcin Erocal, bug #428192, added some upstream patches from sage-on-gentoo
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/pari/files')
-rw-r--r--sci-mathematics/pari/files/pari-2.5.1-1302.patch33
-rw-r--r--sci-mathematics/pari/files/pari-2.5.1-1304.patch39
-rw-r--r--sci-mathematics/pari/files/pari-2.5.1-no-automagic.patch100
3 files changed, 172 insertions, 0 deletions
diff --git a/sci-mathematics/pari/files/pari-2.5.1-1302.patch b/sci-mathematics/pari/files/pari-2.5.1-1302.patch
new file mode 100644
index 000000000000..245e587d275c
--- /dev/null
+++ b/sci-mathematics/pari/files/pari-2.5.1-1302.patch
@@ -0,0 +1,33 @@
+commit 917b505c86a70dda2191d380861af05becc03858
+Author: Karim Belabas <Karim.Belabas@math.u-bordeaux1.fr>
+Date: Mon Mar 12 23:54:11 2012 +0100
+
+ ispower(x < 0,, &n): n could have the wrong sign [#1302]
+
+diff --git a/src/basemath/arith1.c b/src/basemath/arith1.c
+index ded946b..5502ba5 100644
+--- a/src/basemath/arith1.c
++++ b/src/basemath/arith1.c
+@@ -1109,6 +1109,7 @@ Z_isanypower(GEN x, GEN *pty)
+ *pty = gerepileuptoint(av, y);
+ return k;
+ }
++ if (pty) togglesign_safe(pty);
+ }
+ if (pty) *pty = gerepilecopy(av, *pty); else avma = av;
+ return k;
+diff --git a/src/test/32/ispower b/src/test/32/ispower
+index bf4b6f0..84d8de7 100644
+--- a/src/test/32/ispower
++++ b/src/test/32/ispower
+@@ -1118,7 +1118,7 @@
+ [2, 999]
+ [6, 10]
+ [3, -4]
+-[3, 2]
+-[3, 21218]
++[3, -2]
++[3, -21218]
+ [3, -1/4]
+-Total time spent: 3236
++Total time spent: 3012
diff --git a/sci-mathematics/pari/files/pari-2.5.1-1304.patch b/sci-mathematics/pari/files/pari-2.5.1-1304.patch
new file mode 100644
index 000000000000..3da2e8558dac
--- /dev/null
+++ b/sci-mathematics/pari/files/pari-2.5.1-1304.patch
@@ -0,0 +1,39 @@
+commit ff707a3f2ba2d5c555434ba50547453833a7570f
+Author: Karim Belabas <Karim.Belabas@math.u-bordeaux1.fr>
+Date: Sun Mar 18 23:54:02 2012 +0100
+
+ 71- issquarefree(0) => error [#1304]
+
+diff --git a/src/basemath/ifactor1.c b/src/basemath/ifactor1.c
+index 046491f..8f9fbaa 100644
+--- a/src/basemath/ifactor1.c
++++ b/src/basemath/ifactor1.c
+@@ -3493,7 +3493,11 @@ moebius(GEN n)
+ GEN
+ gissquarefree(GEN x) { return map_proto_lG(issquarefree,x); }
+ long
+-Z_issquarefree(GEN n) { return moebius(n)? 1: 0; }
++Z_issquarefree(GEN n)
++{
++ if (!signe(n)) return 0;
++ return moebius(n)? 1: 0;
++}
+ long
+ issquarefree(GEN x)
+ {
+diff --git a/src/test/32/arith b/src/test/32/arith
+new file mode 100644
+index 0000000..3c5981a
+--- /dev/null
++++ b/src/test/32/arith
+@@ -0,0 +1,2 @@
++0
++Total time spent: 8
+diff --git a/src/test/in/arith b/src/test/in/arith
+new file mode 100644
+index 0000000..fb92bed
+--- /dev/null
++++ b/src/test/in/arith
+@@ -0,0 +1,2 @@
++\\#1304
++issquarefree(0)
diff --git a/sci-mathematics/pari/files/pari-2.5.1-no-automagic.patch b/sci-mathematics/pari/files/pari-2.5.1-no-automagic.patch
new file mode 100644
index 000000000000..8fee1f7eaf70
--- /dev/null
+++ b/sci-mathematics/pari/files/pari-2.5.1-no-automagic.patch
@@ -0,0 +1,100 @@
+diff -Nur pari-2.5.1.orig/config/get_config_options pari-2.5.1/config/get_config_options
+--- pari-2.5.1.orig/config/get_config_options 2012-08-01 18:32:03.000000000 +0100
++++ pari-2.5.1/config/get_config_options 2012-08-01 20:57:09.000000000 +0100
+@@ -83,10 +83,12 @@
+ --with-ncurses-lib=*|--with-ncurses=*)
+ with_ncurses_lib=`echo "$1" | sed -e 's/[-a-z]*=//'` ;;
+
++ --without-qt|--with-qt=no) without_qt=yes ;;
+ --with-qt) with_qt=yes ;;
+ --with-qt=*)
+ with_qt=`echo "$1" | sed -e 's/[-a-z]*=//'` ;;
+
++ --without-fltk|--with-fltk=no) without_fltk=yes ;;
+ --with-fltk) with_fltk=yes ;;
+ --with-fltk=*)
+ with_fltk=`echo "$1" | sed -e 's/[-a-z]*=//'` ;;
+@@ -158,7 +160,9 @@
+ --with-gmp-lib=DIR specify location of gmp libs
+
+ --with-qt[=DIR] use the Qt graphical library [prefix for Qt dir.]
++ --without-qt do not try to use the Qt lib
+ --with-fltk[=DIR] use the FLTK graphical library [prefix for FLTK dir.]
++ --without-fltk do not try to use the FLTK lib
+
+ EOT
+ exit 1
+diff -Nur pari-2.5.1.orig/config/get_fltk pari-2.5.1/config/get_fltk
+--- pari-2.5.1.orig/config/get_fltk 2012-08-01 18:32:03.000000000 +0100
++++ pari-2.5.1/config/get_fltk 2012-08-01 22:28:23.000000000 +0100
+@@ -2,6 +2,9 @@
+ with_fltk=yes
+ fi
+ FLTKDIR=
++if test -z "$without_fltk; then
++ FLTKDIR="`fltk-config --prefix 2>/dev/null`"
++fi
+ case "$with_fltk" in
+ yes)
+ pth=$libpth; lib=fltk; . ./locatelib
+diff -Nur pari-2.5.1.orig/config/get_graphic_lib pari-2.5.1/config/get_graphic_lib
+--- pari-2.5.1.orig/config/get_graphic_lib 2012-08-01 18:32:03.000000000 +0100
++++ pari-2.5.1/config/get_graphic_lib 2012-08-01 22:16:57.000000000 +0100
+@@ -11,6 +11,7 @@
+ else
+ if test -n "$with_fltk"; then which_graphic_lib=fltk; fi
+ if test -n "$with_qt"; then which_graphic_lib=Qt; fi
++ if test -n "$without_fltk" -a -n "$without_qt"; then which_graphic_lib=none; fi
+ if test "$which_graphic_lib" != none; then
+ case $osname in
+ mingw) case $which_graphic_lib in
+@@ -41,7 +42,7 @@
+ case $which_graphic_lib in
+ auto|fltk)
+ . ./get_fltk # FLTKDIR, FLTK_LIBS
+- if test -z "$FLTKDIR"; then
++ if test -z "`fltk-config --ldflags 2> /dev/null`"; then
+ case $which_graphic_lib in fltk) which_graphic_lib=none;; esac
+ else
+ which_graphic_lib=fltk
+diff -Nur pari-2.5.1.orig/config/get_Qt pari-2.5.1/config/get_Qt
+--- pari-2.5.1.orig/config/get_Qt 2012-08-01 18:32:03.000000000 +0100
++++ pari-2.5.1/config/get_Qt 2012-08-01 20:39:28.000000000 +0100
+@@ -5,7 +5,7 @@
+ case "$with_qt" in
+ yes)
+ pth="/usr/local/lib /usr/local/share /usr/lib /usr/share"
+- QTDIR=`locatedir qt4/bin $pth`
++ QTDIR=`locatedir qt4 $pth`
+ QTLIB="-lQtCore -lQtGui"
+ which_graphic_lib=Qt4
+ if test -z "$QTDIR"; then
+diff -Nur pari-2.5.1.orig/config/Makefile.SH pari-2.5.1/config/Makefile.SH
+--- pari-2.5.1.orig/config/Makefile.SH 2012-08-01 18:32:03.000000000 +0100
++++ pari-2.5.1/config/Makefile.SH 2012-08-01 21:08:20.000000000 +0100
+@@ -65,12 +65,12 @@
+ PLOTLIBS="-L\$(QTDIR)/lib $QTLIB"
+ graph=plotQt;;
+ Qt4)
+- PLOTCFLAGS='-D__FANCY_WIN__ -I$(QTDIR)/include'
+- PLOTLIBS="-L\$(QTDIR)/lib $QTLIB"
++ PLOTCFLAGS='-D__FANCY_WIN__ `pkg-config --cflags QtGui`'
++ PLOTLIBS="`pkg-config --libs QtGui`"
+ graph=plotQt4;;
+ fltk)
+- PLOTCFLAGS="-I\$(FLTKDIR)/include $X11_INC"
+- PLOTLIBS="-L\$(FLTKDIR)/lib -lfltk $FLTK_LIBS"
++ PLOTCFLAGS="`fltk-config --cxxflags` $X11_INC"
++ PLOTLIBS="`fltk-config --ldflags`"
+ postconfig='-fltk-config --post '
+ graph=plotfltk;;
+ win32)
+@@ -254,7 +254,7 @@
+ GMPINCLUDE = $GMPINCLUDE
+ # Graphic library.
+ QTDIR = "$QTDIR"
+-MOC = \$(QTDIR)/bin/moc
++MOC = "`which moc`"
+ PLOTCFLAGS = $PLOTCFLAGS
+ PLOTLIBS = $PLOTLIBS
+ CPLUSPLUS = g++