summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2013-11-18 00:11:13 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2013-11-18 00:11:13 +0000
commit7aa7fd7e6c4d259822bf920e8ad43525ee444845 (patch)
treef17b2493af109e57f5e9c6fd1f499192d4be709c /sci-mathematics/spin
parentDepend on dev-util/intltool, bug #485676 by Nikoli. (diff)
downloadgentoo-2-7aa7fd7e6c4d259822bf920e8ad43525ee444845.tar.gz
gentoo-2-7aa7fd7e6c4d259822bf920e8ad43525ee444845.tar.bz2
gentoo-2-7aa7fd7e6c4d259822bf920e8ad43525ee444845.zip
Version bump.
(Portage version: 2.2.1/cvs/Linux i686, signed Manifest commit with key 30427902)
Diffstat (limited to 'sci-mathematics/spin')
-rw-r--r--sci-mathematics/spin/ChangeLog10
-rw-r--r--sci-mathematics/spin/files/spin-6.2.5-makefile.patch21
-rw-r--r--sci-mathematics/spin/spin-6.2.5.ebuild48
3 files changed, 77 insertions, 2 deletions
diff --git a/sci-mathematics/spin/ChangeLog b/sci-mathematics/spin/ChangeLog
index e6c1e6262797..5cddddc45b41 100644
--- a/sci-mathematics/spin/ChangeLog
+++ b/sci-mathematics/spin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/spin
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/spin/ChangeLog,v 1.9 2012/12/30 18:30:00 phajdan.jr Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/spin/ChangeLog,v 1.10 2013/11/18 00:11:13 phajdan.jr Exp $
+
+*spin-6.2.5 (18 Nov 2013)
+
+ 18 Nov 2013; Pawel Hajdan jr <phajdan.jr@gentoo.org> +spin-6.2.5.ebuild,
+ +files/spin-6.2.5-makefile.patch:
+ Version bump.
*spin-6.2.3 (30 Dec 2012)
diff --git a/sci-mathematics/spin/files/spin-6.2.5-makefile.patch b/sci-mathematics/spin/files/spin-6.2.5-makefile.patch
new file mode 100644
index 000000000000..585e78b6f550
--- /dev/null
+++ b/sci-mathematics/spin/files/spin-6.2.5-makefile.patch
@@ -0,0 +1,21 @@
+--- makefile.orig 2013-05-05 01:21:02.000000000 +0200
++++ makefile 2013-11-18 01:07:20.000000000 +0100
+@@ -13,9 +13,6 @@
+
+ # see also ./make_pc for a simpler script, not requiring make
+
+-CC=gcc
+-CFLAGS=-O2 -DNXT # on some systems add: -I/usr/include
+-
+ # CFLAGS=-g -O2 -DNXT
+
+ # CC=gcc -m32 # 32bit compilation on a 64bit system
+@@ -45,7 +42,7 @@
+ tl_mem.o tl_rewrt.o tl_cache.o
+
+ spin: $(SPIN_OS) $(TL_OS) spin.o
+- $(CC) $(CFLAGS) -o spin spin.o $(SPIN_OS) $(TL_OS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o spin spin.o $(SPIN_OS) $(TL_OS)
+
+ spin.o: spin.y
+ $(YACC) $(YFLAGS) spin.y
diff --git a/sci-mathematics/spin/spin-6.2.5.ebuild b/sci-mathematics/spin/spin-6.2.5.ebuild
new file mode 100644
index 000000000000..55be719d9498
--- /dev/null
+++ b/sci-mathematics/spin/spin-6.2.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/spin/spin-6.2.5.ebuild,v 1.1 2013/11/18 00:11:13 phajdan.jr Exp $
+
+EAPI="5"
+
+inherit eutils toolchain-funcs versionator
+
+MY_PV=$(replace_all_version_separators '')
+MY_P="${PN}${MY_PV}"
+
+DESCRIPTION="Tool for formal verification of distributed software systems."
+HOMEPAGE="http://spinroot.com/"
+SRC_URI="http://spinroot.com/spin/Src/${MY_P}.tar.gz"
+
+LICENSE="|| ( spin-commercial spin-educational )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="graphviz tk"
+
+DEPEND="sys-devel/bison"
+RDEPEND="sys-devel/gcc
+ sys-process/time
+ tk? (
+ dev-lang/tk
+ graphviz? ( media-gfx/graphviz )
+ )"
+
+S="${WORKDIR}/Spin/Src${PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-6.2.5-makefile.patch"
+}
+
+src_compile() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ dobin spin
+ doman ../Man/spin.1
+ dodoc ../Doc/*
+ if use tk; then
+ newbin "${WORKDIR}/Spin/iSpin/ispin.tcl" ispin
+ make_desktop_entry ispin
+ fi
+}