summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-03-21 20:51:37 +0000
committerJustin Lecher <jlec@gentoo.org>2015-03-21 20:51:37 +0000
commit0af093665c2aaa2126fd0d86f6e20edcf603448b (patch)
tree1327223e1726f7d5f6297378aa0518aa1e8398c0 /sci-mathematics
parentInstall shared lib on Solaris, fix SRC_URI repoman complaint (diff)
downloadgentoo-2-0af093665c2aaa2126fd0d86f6e20edcf603448b.tar.gz
gentoo-2-0af093665c2aaa2126fd0d86f6e20edcf603448b.tar.bz2
gentoo-2-0af093665c2aaa2126fd0d86f6e20edcf603448b.zip
use dobin instead of exeinto /usr/bin/ && doexe
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/reduce/ChangeLog9
-rw-r--r--sci-mathematics/reduce/metadata.xml12
-rw-r--r--sci-mathematics/reduce/reduce-20110414-r1.ebuild45
-rw-r--r--sci-mathematics/reduce/reduce-20110414.ebuild79
4 files changed, 37 insertions, 108 deletions
diff --git a/sci-mathematics/reduce/ChangeLog b/sci-mathematics/reduce/ChangeLog
index 47ee8074a82f..524f134b4683 100644
--- a/sci-mathematics/reduce/ChangeLog
+++ b/sci-mathematics/reduce/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/reduce
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/reduce/ChangeLog,v 1.4 2011/12/22 12:23:03 grozin Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/reduce/ChangeLog,v 1.5 2015/03/21 20:51:37 jlec Exp $
+
+ 21 Mar 2015; Justin Lecher <jlec@gentoo.org> -reduce-20110414.ebuild,
+ metadata.xml, reduce-20110414-r1.ebuild:
+ use dobin instead of exeinto /usr/bin/ && doexe
*reduce-20110414-r1 (22 Dec 2011)
@@ -25,4 +29,3 @@
05 Jan 2011; Andrey Grozin <grozin@gentoo.org> +files/64reduce-gentoo.el,
+reduce-20101007.ebuild, +files/reduce, +metadata.xml:
Initial import
-
diff --git a/sci-mathematics/reduce/metadata.xml b/sci-mathematics/reduce/metadata.xml
index 523cb94a8164..4c137a0f4067 100644
--- a/sci-mathematics/reduce/metadata.xml
+++ b/sci-mathematics/reduce/metadata.xml
@@ -1,12 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-mathematics</herd>
-<maintainer>
- <email>grozin@gentoo.org</email>
- <name>Andrey Grozin</name>
-</maintainer>
-<longdescription lang="en">
+ <herd>sci-mathematics</herd>
+ <maintainer>
+ <email>grozin@gentoo.org</email>
+ <name>Andrey Grozin</name>
+ </maintainer>
+ <longdescription lang="en">
A general-purpose computer algebra system.
Powerful, mature and efficient.
</longdescription>
diff --git a/sci-mathematics/reduce/reduce-20110414-r1.ebuild b/sci-mathematics/reduce/reduce-20110414-r1.ebuild
index 7d637a47789b..13b184cfaf1e 100644
--- a/sci-mathematics/reduce/reduce-20110414-r1.ebuild
+++ b/sci-mathematics/reduce/reduce-20110414-r1.ebuild
@@ -1,21 +1,28 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/reduce/reduce-20110414-r1.ebuild,v 1.1 2011/12/22 12:23:04 grozin Exp $
-EAPI=4
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/reduce/reduce-20110414-r1.ebuild,v 1.2 2015/03/21 20:51:37 jlec Exp $
+
+EAPI=5
+
inherit elisp-common multilib
DESCRIPTION="A general-purpose computer algebra system"
-HOMEPAGE="http://reduce-algebra.sourceforge.net/
+HOMEPAGE="
+ http://reduce-algebra.sourceforge.net/
http://reduce-algebra.com/"
-IUSE="doc emacs gnuplot X"
SRC_URI="mirror://sourceforge/${PN}-algebra/${PN}-src-${PV}.tar.bz2"
-LICENSE="BSD-2 X? ( LGPL-2.1 )"
+
SLOT="0"
+LICENSE="BSD-2 X? ( LGPL-2.1 )"
KEYWORDS="~amd64 ~x86"
+IUSE="doc emacs gnuplot X"
-RDEPEND="X? ( x11-libs/libXrandr
+RDEPEND="
+ X? (
+ x11-libs/libXrandr
x11-libs/libXcursor
- x11-libs/libXft )
+ x11-libs/libXft
+ )
gnuplot? ( sci-visualization/gnuplot )
emacs? ( virtual/emacs )"
DEPEND="${RDEPEND}"
@@ -27,7 +34,7 @@ src_configure() {
# Therefore, I cannot use econf here
# Also, make calls configure in maintainer mode in subdirs *by design*
# The trunk sucks less => WONTFIX until the next release
- ./configure --with-csl $(use_with X gui)
+ ./configure --with-csl $(use_with X gui) || die
# psl build requires Internet connection at build time
# we cannot support it
}
@@ -36,7 +43,7 @@ src_compile() {
emake -j1 STRIP=true
pushd cslbuild/*/csl/reduce.doc > /dev/null
- rm -f *.txt *.tex
+ rm -f *.txt *.tex || die
popd > /dev/null
if use emacs; then
@@ -46,18 +53,17 @@ src_compile() {
}
src_test() {
- emake -j1 testall || die "emake testall failed"
+ emake -j1 testall
}
src_install() {
local lib="$(get_libdir)"
dodoc README BUILDING DEPENDENCY_TRACKING
pushd bin > /dev/null
- cp "${FILESDIR}"/redcsl "${FILESDIR}"/csl .
- sed -e "s/lib/${lib}/" -i redcsl
- sed -e "s/lib/${lib}/" -i csl
- exeinto /usr/bin
- doexe redcsl csl
+ cp "${FILESDIR}"/redcsl "${FILESDIR}"/csl . || die
+ sed -e "s/lib/${lib}/" -i redcsl || die
+ sed -e "s/lib/${lib}/" -i csl || die
+ dobin redcsl csl
popd > /dev/null
pushd cslbuild/*/csl > /dev/null
@@ -67,18 +73,17 @@ src_install() {
doins reduce.img csl.img
insinto /usr/share/${PN}
doins -r ${PN}.doc
- mv "${D}"usr/share/${PN}/${PN}.doc "${D}"usr/share/${PN}/doc
+ mv "${D}"usr/share/${PN}/${PN}.doc "${D}"usr/share/${PN}/doc || die
dosym /usr/share/${PN}/doc /usr/${lib}/${PN}/${PN}.doc
if use X; then
doins -r ${PN}.fonts
- mv "${D}"usr/share/${PN}/${PN}.fonts "${D}"usr/share/${PN}/fonts
+ mv "${D}"usr/share/${PN}/${PN}.fonts "${D}"usr/share/${PN}/fonts || die
dosym /usr/share/${PN}/fonts /usr/${lib}/${PN}/${PN}.fonts
fi
popd > /dev/null
if use doc; then
- insinto /usr/share/doc/${PF}
- doins doc/util/r38.pdf
+ dodoc doc/util/r38.pdf
fi
if use emacs; then
diff --git a/sci-mathematics/reduce/reduce-20110414.ebuild b/sci-mathematics/reduce/reduce-20110414.ebuild
deleted file mode 100644
index 29fb420bdd80..000000000000
--- a/sci-mathematics/reduce/reduce-20110414.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/reduce/reduce-20110414.ebuild,v 1.1 2011/09/22 11:15:33 grozin Exp $
-EAPI=4
-inherit elisp-common
-
-DESCRIPTION="A general-purpose computer algebra system"
-HOMEPAGE="http://reduce-algebra.sourceforge.net/
- http://reduce-algebra.com/"
-IUSE="doc emacs gnuplot X"
-SRC_URI="mirror://sourceforge/${PN}-algebra/${PN}-src-${PV}.tar.bz2"
-LICENSE="BSD-2 X? ( LGPL-2.1 )"
-SLOT="0"
-KEYWORDS="~x86"
-
-RDEPEND="X? ( x11-libs/libXrandr
- x11-libs/libXcursor
- x11-libs/libXft )
- gnuplot? ( sci-visualization/gnuplot )
- emacs? ( virtual/emacs )"
-DEPEND="${RDEPEND}"
-
-src_configure() {
- # If you pass --prefix to this damn configure,
- # make (not make install!) will try to install stuff
- # into the live file system => sandbox violation
- # Therefore, I cannot use econf here
- # Also, make calls configure in maintainer mode in subdirs *by design*
- # The trunk sucks less => WONTFIX until the next release
- ./configure --with-csl $(use_with X gui)
- # psl build requires Internet connection at build time
- # we cannot support it
-}
-
-src_compile() {
- emake STRIP=true
-
- pushd cslbuild/*/csl/reduce.doc > /dev/null
- rm -f *.txt *.tex
- popd > /dev/null
-
- if use emacs; then
- einfo "Compiling emacs lisp files"
- elisp-compile generic/emacs/*.el || die "elisp-compile failed"
- fi
-}
-
-src_test() {
- emake testall || die "emake testall failed"
-}
-
-src_install() {
- pushd cslbuild/*/csl > /dev/null
- exeinto /usr/lib/${PN}
- doexe reduce csl
- insinto /usr/lib/${PN}
- doins reduce.img csl.img
- doins -r reduce.doc
- if use X; then
- doins -r reduce.fonts
- fi
- popd > /dev/null
- exeinto /usr/bin
- doexe "${FILESDIR}/redcsl" "${FILESDIR}/csl"
- dodoc README BUILDING DEPENDENCY_TRACKING
- dosym /usr/lib/${PN}/${PN}.doc /usr/share/doc/${PF}/html
-
- if use doc; then
- insinto /usr/share/doc/${PF}
- doins -r doc/util/r38.pdf
- fi
-
- if use emacs; then
- pushd generic/emacs > /dev/null
- elisp-install ${PN} *.el *.elc || die "elisp-install failed"
- elisp-site-file-install "${FILESDIR}/64${PN}-gentoo.el"
- popd > /dev/null
- fi
-}