summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-07-22 15:32:05 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-07-22 15:32:05 +0000
commit4598e07ed498d930b1e5d6f8c2d7c2ec7c41d1a0 (patch)
tree23f7d60eff8f27165d9097a72a57429c51813bbb /sci-mathematics
parentppc stable #423071 (diff)
downloadgentoo-2-4598e07ed498d930b1e5d6f8c2d7c2ec7c41d1a0.tar.gz
gentoo-2-4598e07ed498d930b1e5d6f8c2d7c2ec7c41d1a0.tar.bz2
gentoo-2-4598e07ed498d930b1e5d6f8c2d7c2ec7c41d1a0.zip
Version bump, keyword amd64-linux, x86-linux
(Portage version: 2.2.01.20757-prefix/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/mathomatic/ChangeLog7
-rw-r--r--sci-mathematics/mathomatic/mathomatic-16.0.1.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/sci-mathematics/mathomatic/ChangeLog b/sci-mathematics/mathomatic/ChangeLog
index 30d458097234..ab9410e185a8 100644
--- a/sci-mathematics/mathomatic/ChangeLog
+++ b/sci-mathematics/mathomatic/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/mathomatic
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/ChangeLog,v 1.68 2012/07/10 18:56:54 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/ChangeLog,v 1.69 2012/07/22 15:32:05 bicatali Exp $
+
+*mathomatic-16.0.1 (22 Jul 2012)
+
+ 22 Jul 2012; Sébastien Fabbro <bicatali@gentoo.org> +mathomatic-16.0.1.ebuild:
+ Version bump, keyword amd64-linux, x86-linux
10 Jul 2012; Justin Lecher <jlec@gentoo.org> -mathomatic-12.8.8.ebuild,
-mathomatic-12.9.1.ebuild, -mathomatic-15.8.2.ebuild, metadata.xml:
diff --git a/sci-mathematics/mathomatic/mathomatic-16.0.1.ebuild b/sci-mathematics/mathomatic/mathomatic-16.0.1.ebuild
new file mode 100644
index 000000000000..0fa53d3f2f8d
--- /dev/null
+++ b/sci-mathematics/mathomatic/mathomatic-16.0.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/mathomatic/mathomatic-16.0.1.ebuild,v 1.1 2012/07/22 15:32:03 bicatali Exp $
+
+EAPI=4
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="Automatic algebraic manipulator"
+HOMEPAGE="http://www.mathomatic.org/"
+SRC_URI="${HOMEPAGE}/archive/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc gnuplot"
+
+DEPEND="sys-libs/readline
+ sys-libs/ncurses"
+RDEPEND="${DEPEND}
+ gnuplot? ( sci-visualization/gnuplot )"
+
+src_compile() {
+ append-cflags -DBOLD_COLOR=1
+ emake READLINE=1 CC=$(tc-getCC)
+ emake CC=$(tc-getCC) -C primes
+}
+
+src_test() {
+ default
+ emake -C primes check
+}
+
+src_install() {
+ emake prefix="${EPREFIX}/usr" DESTDIR="${D}" bininstall
+ emake prefix="${EPREFIX}/usr" DESTDIR="${D}" -C primes install
+ dodoc changes.txt README.txt AUTHORS
+ newdoc primes/README.txt README-primes.txt
+ use doc && emake \
+ prefix="${EPREFIX}/usr" \
+ mathdocdir="${EPREFIX}/usr/share/doc/${PF}" \
+ DESTDIR="${D}" docinstall
+}