summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-06-18 07:53:32 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-06-18 07:53:32 +0000
commit5fedae605f3ee3c531be7b9ee055a0900418e5ee (patch)
tree70f79ae8623675a266bad1b652f2a9bc8a6f5b99 /sci-mathematics
parentold (diff)
downloadgentoo-2-5fedae605f3ee3c531be7b9ee055a0900418e5ee.tar.gz
gentoo-2-5fedae605f3ee3c531be7b9ee055a0900418e5ee.tar.bz2
gentoo-2-5fedae605f3ee3c531be7b9ee055a0900418e5ee.zip
Version bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/glpk/ChangeLog9
-rw-r--r--sci-mathematics/glpk/glpk-4.38.ebuild57
2 files changed, 64 insertions, 2 deletions
diff --git a/sci-mathematics/glpk/ChangeLog b/sci-mathematics/glpk/ChangeLog
index f1d5cc5b0ebb..43289209b19c 100644
--- a/sci-mathematics/glpk/ChangeLog
+++ b/sci-mathematics/glpk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/glpk
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/glpk/ChangeLog,v 1.36 2009/05/17 13:15:33 nixnut Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/glpk/ChangeLog,v 1.37 2009/06/18 07:53:32 bicatali Exp $
+
+*glpk-4.38 (18 Jun 2009)
+
+ 18 Jun 2009; Sébastien Fabbro <bicatali@gentoo.org> +glpk-4.38.ebuild:
+ Version bump
17 May 2009; nixnut <nixnut@gentoo.org> glpk-4.35.ebuild:
ppc stable #245707
diff --git a/sci-mathematics/glpk/glpk-4.38.ebuild b/sci-mathematics/glpk/glpk-4.38.ebuild
new file mode 100644
index 000000000000..4db4bb0b834f
--- /dev/null
+++ b/sci-mathematics/glpk/glpk-4.38.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/glpk/glpk-4.38.ebuild,v 1.1 2009/06/18 07:53:32 bicatali Exp $
+
+EAPI=2
+inherit flag-o-matic
+
+DESCRIPTION="GNU Linear Programming Kit"
+LICENSE="GPL-3"
+HOMEPAGE="http://www.gnu.org/software/glpk/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+SLOT="0"
+IUSE="doc examples gmp odbc mysql"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="odbc? ( || ( dev-db/libiodbc dev-db/unixODBC ) )
+ gmp? ( dev-libs/gmp )
+ mysql? ( virtual/mysql )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ local myconf="--disable-dl"
+ if use mysql || use odbc; then
+ myconf="--enable-dl"
+ fi
+
+ [[ -z $(type -P odbc-config) ]] && \
+ append-cppflags $(pkg-config --cflags libiodbc)
+
+ econf \
+ --with-zlib \
+ $(use_with gmp) \
+ $(use_enable odbc) \
+ $(use_enable mysql) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README || \
+ die "failed to install docs"
+
+ insinto /usr/share/doc/${PF}
+ if use examples; then
+ emake distclean
+ doins -r examples || die "failed to install examples"
+ fi
+ if use doc; then
+ cd "${S}"/doc
+ doins *.pdf notes/gomory.djvu || die "failed to instal djvu and pdf"
+ dodoc *.txt || die "failed to install manual files"
+ fi
+}