summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2010-01-13 02:29:56 +0000
committerMarkus Dittrich <markusle@gentoo.org>2010-01-13 02:29:56 +0000
commit73b4bd112895083f5931667f513e96e43c538242 (patch)
treee8a62c1a689019a653e6870b74868a4d1cf3efa9 /sci-mathematics
parentVersion bump. Fixes an issue that can be triggered by the recent ALSA output ... (diff)
downloadgentoo-2-73b4bd112895083f5931667f513e96e43c538242.tar.gz
gentoo-2-73b4bd112895083f5931667f513e96e43c538242.tar.bz2
gentoo-2-73b4bd112895083f5931667f513e96e43c538242.zip
Modernized ebuild and fixed parallel make issue (fixes bug #298208).
(Portage version: 2.1.7.16/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/otter/ChangeLog9
-rw-r--r--sci-mathematics/otter/files/otter-3.3-build.patch114
-rw-r--r--sci-mathematics/otter/otter-3.3-r2.ebuild40
3 files changed, 162 insertions, 1 deletions
diff --git a/sci-mathematics/otter/ChangeLog b/sci-mathematics/otter/ChangeLog
index 297f671acbf1..f5b97429901b 100644
--- a/sci-mathematics/otter/ChangeLog
+++ b/sci-mathematics/otter/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-mathematics/otter
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/otter/ChangeLog,v 1.12 2010/01/02 18:20:20 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/otter/ChangeLog,v 1.13 2010/01/13 02:29:46 markusle Exp $
+
+*otter-3.3-r2 (13 Jan 2010)
+
+ 13 Jan 2010; Markus Dittrich <markusle@gentoo.org> +otter-3.3-r2.ebuild,
+ +files/otter-3.3-build.patch:
+ Modernized ebuild and fixed parallel make issue (fixes bug #298208).
+ Thanks much to Kacper Kowalik for his patches.
02 Jan 2010; Christian Faulhammer <fauli@gentoo.org> otter-3.3-r1.ebuild:
Transfer Prefix keywords
diff --git a/sci-mathematics/otter/files/otter-3.3-build.patch b/sci-mathematics/otter/files/otter-3.3-build.patch
new file mode 100644
index 000000000000..b933d86252d6
--- /dev/null
+++ b/sci-mathematics/otter/files/otter-3.3-build.patch
@@ -0,0 +1,114 @@
+diff -Naur otter-3.3/mace2/Makefile otter-3.3.new/mace2/Makefile
+--- otter-3.3/mace2/Makefile 2003-08-06 10:18:09.000000000 -0400
++++ otter-3.3.new/mace2/Makefile 2010-01-12 19:41:44.000000000 -0500
+@@ -1,8 +1,8 @@
+ DFLAGS = -DTP_NAMES -DTP_SIGNAL -DTP_RUSAGE
+
+-CC = gcc
++#CC = gcc
+
+-CFLAGS = -O $(DFLAGS)
++CFLAGS += $(DFLAGS)
+
+ # CFLAGS = -g $(DFLAGS)
+
+@@ -12,20 +12,17 @@
+ OBJECTS = clock.o avail.o opts.o stats.o miscellany.o flatten.o\
+ dp.o generate.o print.o part.o
+
+-all: mace2 anldp install clean
++all: mace2 anldp
+
+ mace2: mace2.o $(OBJECTS)
+- $(CC) $(CFLAGS) mace2.o $(OBJECTS) ../source/libotter.a -o mace2
++ $(CC) $(CFLAGS) $(LDFLAGS) mace2.o $(OBJECTS) ../source/libotter.a -o ../bin/mace2
+
+ anldp: anldp.o $(OBJECTS)
+- $(CC) $(CFLAGS) anldp.o $(OBJECTS) ../source/libotter.a -o anldp
++ $(CC) $(CFLAGS) $(LDFLAGS) anldp.o $(OBJECTS) ../source/libotter.a -o ../bin/anldp
+
+ mace2.o anldp.o $(OBJECTS): Mace2.h Clock.h Avail.h Opts.h Stats.h\
+ Miscellany.h Dp.h Generate.h Flatten.h Part.h
+
+-install:
+- /bin/mv mace2 anldp ../bin
+-
+ clean:
+ /bin/rm -f *.o
+
+diff -Naur otter-3.3/source/Makefile otter-3.3.new/source/Makefile
+--- otter-3.3/source/Makefile 2003-08-06 21:48:29.000000000 -0400
++++ otter-3.3.new/source/Makefile 2010-01-12 19:58:16.000000000 -0500
+@@ -66,7 +66,7 @@
+ # Specify the C compiler. I recommend gcc (GNU C Compiler) if you have it.
+ # In many Linux environments, cc is just a symlink to gcc.
+
+-CC = gcc
++#CC = gcc
+
+ #############################################################################
+ #
+@@ -74,7 +74,7 @@
+ #
+ # optimized
+
+-CFLAGS = -O $(DFLAGS)
++CFLAGS += $(DFLAGS)
+
+ #
+ # check for strict ANSI conformance with Solaris cc:
+@@ -108,19 +108,20 @@
+
+ #############################################################################
+
+-all: otter install clean
++all: formed
++
++formed: otter
++ +make -C formed clean
++ +make -C formed
+
+ otter: main.o libotter.a
+- $(CC) $(CFLAGS) main.o libotter.a -o otter
++ $(CC) $(CFLAGS) $(LDFLAGS) main.o libotter.a -o ../bin/otter
+
+ libotter.a: $(OBJECTS)
+ $(AR) rs libotter.a $(OBJECTS)
+
+ main.o $(OBJECTS): header.h types.h macros.h cos.h proto.h foreign.h lisp.h
+
+-install:
+- /bin/mv otter ../bin
+-
+ clean:
+ /bin/rm -f *.o
+
+diff -Naur otter-3.3/source/formed/Makefile otter-3.3.new/source/formed/Makefile
+--- otter-3.3/source/formed/Makefile 2003-07-21 15:34:44.000000000 -0400
++++ otter-3.3.new/source/formed/Makefile 2010-01-12 19:37:46.000000000 -0500
+@@ -1,14 +1,14 @@
+
+ DFLAGS = -DTP_NAMES -DTP_SIGNAL -DTP_FORK -DTP_RUSAGE
+
+-CC = gcc
++#CC = gcc
+
+ #############################################################################
+ # Specify the compiler flags; include DFLAGS (above)
+ #
+ # optimized
+
+-CFLAGS = -O $(DFLAGS)
++CFLAGS += $(DFLAGS)
+
+ #
+ # save symbols for debuggers
+@@ -40,7 +40,7 @@
+ XLIBS = -L/usr/X11R6/lib -lXaw
+
+ formed: formed.o display.o callback.o
+- $(CC) $(CFLAGS) formed.o display.o callback.o \
++ $(CC) $(CFLAGS) $(LDFLAGS) formed.o display.o callback.o \
+ ../libotter.a $(XLIBS) -o formed
+
+ display.o callback.o formed.o: formed.h
diff --git a/sci-mathematics/otter/otter-3.3-r2.ebuild b/sci-mathematics/otter/otter-3.3-r2.ebuild
new file mode 100644
index 000000000000..bc683123880c
--- /dev/null
+++ b/sci-mathematics/otter/otter-3.3-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/otter/otter-3.3-r2.ebuild,v 1.1 2010/01/13 02:29:46 markusle Exp $
+
+EAPI="2"
+inherit eutils
+
+DESCRIPTION="An Automated Deduction System."
+SRC_URI="http://www-unix.mcs.anl.gov/AR/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www-unix.mcs.anl.gov/AR/otter/"
+
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+LICENSE="otter"
+SLOT="0"
+IUSE=""
+DEPEND="virtual/libc"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_compile() {
+ cd source
+ CC=$(tc-getCC) emake || die "emake failed"
+ cd "${S}"/mace2
+ CC=$(tc-getCC) emake || die "emake in mace2 failed"
+}
+
+src_install() {
+ dobin bin/* source/formed/formed \
+ || die "failed to install binaries"
+ dodoc README* Legal Changelog Contents \
+ || die "failed to install regular docs"
+ insinto /usr/share/doc/${PF}
+ doins documents/*.pdf \
+ || die "failed to install pdf docs"
+ insinto /usr/share/${PN}/
+ doins -r examples examples-mace2 \
+ || die "failed to install examples"
+}