summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-08-09 17:52:26 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-08-09 17:52:26 +0000
commit7ed1a33437cad7e8c42cb1b33a7fc297f33cdac8 (patch)
treece9668770f34eec5e1ef8231aaa53f92c7ea72df /sci-mathematics
parentMarking File-Find-Rule-0.330.0 ppc for bug 418811 (diff)
downloadgentoo-2-7ed1a33437cad7e8c42cb1b33a7fc297f33cdac8.tar.gz
gentoo-2-7ed1a33437cad7e8c42cb1b33a7fc297f33cdac8.tar.bz2
gentoo-2-7ed1a33437cad7e8c42cb1b33a7fc297f33cdac8.zip
Version bump. Fixed for prefix
(Portage version: 2.2.01.20796-prefix/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/calc/ChangeLog11
-rw-r--r--sci-mathematics/calc/calc-2.12.4.4.ebuild (renamed from sci-mathematics/calc/calc-2.12.4.0-r1.ebuild)30
2 files changed, 25 insertions, 16 deletions
diff --git a/sci-mathematics/calc/ChangeLog b/sci-mathematics/calc/ChangeLog
index ffbf825974b5..f17bab1e48d0 100644
--- a/sci-mathematics/calc/ChangeLog
+++ b/sci-mathematics/calc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/calc
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/calc/ChangeLog,v 1.22 2011/03/07 05:12:39 bicatali Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/calc/ChangeLog,v 1.23 2012/08/09 17:52:26 bicatali Exp $
+
+*calc-2.12.4.4 (09 Aug 2012)
+
+ 09 Aug 2012; Sébastien Fabbro <bicatali@gentoo.org> +calc-2.12.4.4.ebuild,
+ -calc-2.12.4.0-r1.ebuild:
+ Version bump. Fixed for prefix
*calc-2.12.4.3 (07 Mar 2011)
@@ -111,4 +117,3 @@
11 Mar 2004; Peter Bienstman <pbienst@gentoo.org> calc-2.11.9.3.ebuild:
New app, thanks to José Romildo Malaquias <romildo@uber.com.br> (#38736)
-
diff --git a/sci-mathematics/calc/calc-2.12.4.0-r1.ebuild b/sci-mathematics/calc/calc-2.12.4.4.ebuild
index 42161658423f..f984ef92f518 100644
--- a/sci-mathematics/calc/calc-2.12.4.0-r1.ebuild
+++ b/sci-mathematics/calc/calc-2.12.4.4.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/calc/calc-2.12.4.0-r1.ebuild,v 1.1 2010/06/15 15:43:48 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/calc/calc-2.12.4.4.ebuild,v 1.1 2012/08/09 17:52:26 bicatali Exp $
-EAPI="3"
+EAPI=4
inherit eutils multilib toolchain-funcs
-DESCRIPTION="An arbitrary precision C-like arithmetic system"
+DESCRIPTION="Arbitrary precision C-like arithmetic system"
HOMEPAGE="http://www.isthe.com/chongo/tech/comp/calc/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+SRC_URI="http://www.isthe.com/chongo/src/calc/${P}.tar.bz2"
SLOT="0"
LICENSE="LGPL-2"
@@ -17,37 +17,41 @@ KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
IUSE=""
DEPEND="
- >=sys-libs/ncurses-5.2
- >=sys-libs/readline-4.2"
+ sys-libs/ncurses
+ sys-libs/readline"
RDEPEND="${DEPEND}"
src_prepare() {
- epatch "${FILESDIR}"/${P}-prefix.patch
- epatch "${FILESDIR}"/${PV}-ldflags.patch
+ epatch "${FILESDIR}"/${PN}-2.12.4.0-prefix.patch
+ epatch "${FILESDIR}"/2.12.4.0-ldflags.patch
ln -sf libcustcalc.so.${PV} custom/libcustcalc.so
+ sed -i -e "/DIR/s:/usr:${EPREFIX}/usr:g" Makefile || die
}
src_compile() {
# parallel compilation hard to fix. better to leave upstream.
emake -j1 \
- CC=$(tc-getCC) \
+ CC="$(tc-getCC)" \
DEBUG="${CFLAGS}" \
LDFLAGS="${LDFLAGS}" \
CALCPAGER="${PAGER}" \
USE_READLINE="-DUSE_READLINE" \
READLINE_LIB="-lreadline -lhistory -lncurses -L${S}/custom -lcustcalc" \
- all || die "emake failed"
+ all
}
src_test() {
if echo "${LD_PRELOAD}" | grep -q "sandbox"; then
ewarn "Can't run check when running in sandbox - see bug #59676"
else
- make chk || die "Check failed"
+ emake chk || die "Check failed"
fi
}
src_install() {
- emake T="${D}" LIBDIR="${EPREFIX}/usr/$(get_libdir)" install || die "emake install failed"
+ emake \
+ T="${D}" \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
+ install
dodoc BUGS CHANGES LIBRARY README
}