summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2013-09-11 21:34:48 +0000
committerThomas Kahle <tomka@gentoo.org>2013-09-11 21:34:48 +0000
commit912037e160d3ebaa4e67b251313a25709839096a (patch)
tree3cb438eb10e457378057d0454428aa15ae65cbc0 /sci-mathematics
parentFix building with gcc-4.8 and -O3, bug #472058. Apply patches for ia64, bug #... (diff)
downloadgentoo-2-912037e160d3ebaa4e67b251313a25709839096a.tar.gz
gentoo-2-912037e160d3ebaa4e67b251313a25709839096a.tar.bz2
gentoo-2-912037e160d3ebaa4e67b251313a25709839096a.zip
bump to 1.6
(Portage version: 2.2.2/cvs/Linux x86_64, signed Manifest commit with key 0x89DEB219565C32BC!)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/4ti2/4ti2-1.6.ebuild36
-rw-r--r--sci-mathematics/4ti2/ChangeLog7
2 files changed, 42 insertions, 1 deletions
diff --git a/sci-mathematics/4ti2/4ti2-1.6.ebuild b/sci-mathematics/4ti2/4ti2-1.6.ebuild
new file mode 100644
index 000000000000..c530ff4b6116
--- /dev/null
+++ b/sci-mathematics/4ti2/4ti2-1.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/4ti2/4ti2-1.6.ebuild,v 1.1 2013/09/11 21:34:48 tomka Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils
+
+DESCRIPTION="Software package for algebraic, geometric and combinatorial problems"
+HOMEPAGE="http://www.4ti2.de/"
+SRC_URI="http://4ti2.de/version_${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-macos"
+IUSE="static-libs"
+
+DEPEND="
+ sci-mathematics/glpk:0[gmp]
+ dev-libs/gmp[cxx]"
+RDEPEND="${DEPEND}"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.2-gold.patch
+ )
+
+src_prepare() {
+ sed \
+ -e "s:^CXX.*$:CXX=$(tc-getCXX):g" \
+ -i m4/glpk-check.m4 || die
+ autotools-utils_src_prepare
+}
diff --git a/sci-mathematics/4ti2/ChangeLog b/sci-mathematics/4ti2/ChangeLog
index dce964275f21..d992989958d8 100644
--- a/sci-mathematics/4ti2/ChangeLog
+++ b/sci-mathematics/4ti2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/4ti2
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/4ti2/ChangeLog,v 1.13 2013/08/11 13:22:29 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/4ti2/ChangeLog,v 1.14 2013/09/11 21:34:48 tomka Exp $
+
+*4ti2-1.6 (11 Sep 2013)
+
+ 11 Sep 2013; Thomas Kahle <tomka@gentoo.org> +4ti2-1.6.ebuild:
+ bump to 1.6
11 Aug 2013; Justin Lecher <jlec@gentoo.org> -4ti2-1.3.2.ebuild,
metadata.xml: