summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2006-04-14 20:06:19 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2006-04-14 20:06:19 +0000
commit94047cd8f03882629a6dbd8befa5f1f8db5866d6 (patch)
tree1b3007d95dddf6108eb2eac173093f992bb3592a /sci-mathematics
parentVersion bump, thanks to Etienne Dube <etdube@globetrotter.net> for the bumped... (diff)
downloadgentoo-2-94047cd8f03882629a6dbd8befa5f1f8db5866d6.tar.gz
gentoo-2-94047cd8f03882629a6dbd8befa5f1f8db5866d6.tar.bz2
gentoo-2-94047cd8f03882629a6dbd8befa5f1f8db5866d6.zip
Applied GCC 4.1 patch, thanks to Mark Loeser <halcy0n@gentoo.org>, closes bug 125188.
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/gturing/ChangeLog9
-rw-r--r--sci-mathematics/gturing/files/gturing-0.1.1-gcc-41.patch13
-rw-r--r--sci-mathematics/gturing/gturing-0.1.1.ebuild7
3 files changed, 24 insertions, 5 deletions
diff --git a/sci-mathematics/gturing/ChangeLog b/sci-mathematics/gturing/ChangeLog
index 6c37b67fd0ec..a4a71f0ff6a2 100644
--- a/sci-mathematics/gturing/ChangeLog
+++ b/sci-mathematics/gturing/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/gturing
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gturing/ChangeLog,v 1.3 2005/08/23 02:47:35 ribosome Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gturing/ChangeLog,v 1.4 2006/04/14 20:06:19 cryos Exp $
+
+ 14 Apr 2006; Marcus D. Hanwell <cryos@gentoo.org>
+ +files/gturing-0.1.1-gcc-41.patch, gturing-0.1.1.ebuild:
+ Applied GCC 4.1 patch, thanks to Mark Loeser <halcy0n@gentoo.org>, closes
+ bug 125188.
23 Aug 2005; Olivier Fisette <ribosome@gentoo.org>
+files/gturing-0.1.1-gettext.patch, gturing-0.1.1.ebuild:
diff --git a/sci-mathematics/gturing/files/gturing-0.1.1-gcc-41.patch b/sci-mathematics/gturing/files/gturing-0.1.1-gcc-41.patch
new file mode 100644
index 000000000000..b9d24a2da12f
--- /dev/null
+++ b/sci-mathematics/gturing/files/gturing-0.1.1-gcc-41.patch
@@ -0,0 +1,13 @@
+diff -ur gturing-0.1.1-orig/src/turing.h gturing-0.1.1/src/turing.h
+--- gturing-0.1.1-orig/src/turing.h 2006-04-14 00:11:59.000000000 -0400
++++ gturing-0.1.1/src/turing.h 2006-04-14 00:13:35.000000000 -0400
+@@ -56,9 +56,6 @@
+ }
+ turing;
+
+-extern gchar states_fname[1024];
+-extern gchar tape_string[1024];
+-
+ extern turing *turing_new(void);
+ extern gchar *turing_states_to_string(turing_state *state);
+ extern gint turing_fread_states(turing *machine, gchar *filename);
diff --git a/sci-mathematics/gturing/gturing-0.1.1.ebuild b/sci-mathematics/gturing/gturing-0.1.1.ebuild
index f9afdbad83d7..06c1eb8e3f97 100644
--- a/sci-mathematics/gturing/gturing-0.1.1.ebuild
+++ b/sci-mathematics/gturing/gturing-0.1.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gturing/gturing-0.1.1.ebuild,v 1.2 2005/08/23 02:47:35 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/gturing/gturing-0.1.1.ebuild,v 1.3 2006/04/14 20:06:19 cryos Exp $
inherit eutils
@@ -18,7 +18,8 @@ DEPEND=">=gnome-base/libgnomeui-2.0.0"
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/${P}-gettext.patch
+ epatch ${FILESDIR}/${P}-gettext.patch
+ epatch ${FILESDIR}/${P}-gcc-41.patch
}
src_compile() {