summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-12-17 21:26:45 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-12-17 21:26:45 +0000
commit9689ec8779ca52a2ca18ee00fce6335339877179 (patch)
treeb598d2171eb0945a2ce27385f139d807841ebae5 /sci-mathematics
parentia64/x86 stable (diff)
downloadgentoo-2-9689ec8779ca52a2ca18ee00fce6335339877179.tar.gz
gentoo-2-9689ec8779ca52a2ca18ee00fce6335339877179.tar.bz2
gentoo-2-9689ec8779ca52a2ca18ee00fce6335339877179.zip
version bump
(Portage version: 2.1.4_rc10)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/coq/ChangeLog7
-rw-r--r--sci-mathematics/coq/coq-8.1_p3.ebuild66
-rw-r--r--sci-mathematics/coq/files/digest-coq-8.1_p33
3 files changed, 75 insertions, 1 deletions
diff --git a/sci-mathematics/coq/ChangeLog b/sci-mathematics/coq/ChangeLog
index 46464cdad179..6887aae5d3ec 100644
--- a/sci-mathematics/coq/ChangeLog
+++ b/sci-mathematics/coq/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/coq
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/ChangeLog,v 1.20 2007/10/20 15:55:05 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/ChangeLog,v 1.21 2007/12/17 21:26:44 aballier Exp $
+
+*coq-8.1_p3 (17 Dec 2007)
+
+ 17 Dec 2007; Alexis Ballier <aballier@gentoo.org> +coq-8.1_p3.ebuild:
+ version bump
20 Oct 2007; Alexis Ballier <aballier@gentoo.org> coq-8.0_p3.ebuild,
coq-8.1_p1.ebuild:
diff --git a/sci-mathematics/coq/coq-8.1_p3.ebuild b/sci-mathematics/coq/coq-8.1_p3.ebuild
new file mode 100644
index 000000000000..c5c0ffc0ffaa
--- /dev/null
+++ b/sci-mathematics/coq/coq-8.1_p3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/coq-8.1_p3.ebuild,v 1.1 2007/12/17 21:26:44 aballier Exp $
+
+inherit eutils multilib
+
+IUSE="norealanalysis ide debug"
+
+RESTRICT="strip"
+
+MY_PV="${PV/_p/pl}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Coq is a proof assistant written in O'Caml"
+HOMEPAGE="http://coq.inria.fr/"
+SRC_URI="ftp://ftp.inria.fr/INRIA/${PN}/V${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="|| ( >=dev-ml/camlp5-5.01 <dev-lang/ocaml-3.10 )
+>=dev-lang/ocaml-3.08
+ide? ( >=dev-ml/lablgtk-2.2.0 )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ local myconf="--prefix /usr \
+ --bindir /usr/bin \
+ --libdir /usr/$(get_libdir)/coq \
+ --mandir /usr/man \
+ --emacslib /usr/share/emacs/site-lisp \
+ --coqdocdir /usr/$(get_libdir)/coq/coqdoc"
+
+ use debug && myconf="--debug $myconf"
+ use norealanalysis && myconf="$myconf --reals no"
+ use norealanalysis || myconf="$myconf --reals all"
+
+ if use ide; then
+ myconf="$myconf --coqide opt"
+ else
+ myconf="$myconf --coqide no"
+ fi
+
+ ./configure $myconf || die "configure failed"
+
+ if use ide; then
+ labldir=/usr/$(get_libdir)/ocaml/lablgtk2
+ sed -i -e "s|BYTEFLAGS=|BYTEFLAGS=-I ${labldir} |" Makefile
+ sed -i -e "s|OPTFLAGS=|OPTFLAGS=-I ${labldir} |" Makefile
+ sed -i -e "s|COQIDEFLAGS=.*|COQIDEFLAGS=-thread -I ${labldir}|" Makefile
+ fi
+
+ emake -j1 alldepend || die "make failed"
+ emake worldnodep || die "make failed"
+}
+
+src_install() {
+ emake COQINSTALLPREFIX="${D}" install || die
+ dodoc README CREDITS CHANGES
+
+ if use ide; then
+ domenu "${FILESDIR}/coqide.desktop"
+ fi
+}
diff --git a/sci-mathematics/coq/files/digest-coq-8.1_p3 b/sci-mathematics/coq/files/digest-coq-8.1_p3
new file mode 100644
index 000000000000..eb63855d1e8b
--- /dev/null
+++ b/sci-mathematics/coq/files/digest-coq-8.1_p3
@@ -0,0 +1,3 @@
+MD5 84311faf7865b2eab964990cdb365dca coq-8.1pl3.tar.gz 3003593
+RMD160 f8f4749e1014cb47a83915550713cf9ce1992e34 coq-8.1pl3.tar.gz 3003593
+SHA256 7f8f45594adff2625312c5ecb144cb00d39c99201dac309c9286b34d01a36bb6 coq-8.1pl3.tar.gz 3003593