summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2014-05-09 13:36:16 +0000
committerThomas Kahle <tomka@gentoo.org>2014-05-09 13:36:16 +0000
commiteb3e1534b8ace5e8ff6b9e74bba9cf155821eb46 (patch)
tree243c147543d327edd09452670ba4b7a38be1de6b /sci-mathematics
parentamd64/x86 stable wrt #505952 (diff)
downloadgentoo-2-eb3e1534b8ace5e8ff6b9e74bba9cf155821eb46.tar.gz
gentoo-2-eb3e1534b8ace5e8ff6b9e74bba9cf155821eb46.tar.bz2
gentoo-2-eb3e1534b8ace5e8ff6b9e74bba9cf155821eb46.zip
Bump to 2.11
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 565C32BC)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/normaliz/ChangeLog10
-rw-r--r--sci-mathematics/normaliz/files/normaliz-2.11-respect-flags.patch35
-rw-r--r--sci-mathematics/normaliz/normaliz-2.11.ebuild61
3 files changed, 104 insertions, 2 deletions
diff --git a/sci-mathematics/normaliz/ChangeLog b/sci-mathematics/normaliz/ChangeLog
index 9532ccf1caab..05b698275857 100644
--- a/sci-mathematics/normaliz/ChangeLog
+++ b/sci-mathematics/normaliz/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/normaliz
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/normaliz/ChangeLog,v 1.15 2013/07/27 14:59:12 tomka Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/normaliz/ChangeLog,v 1.16 2014/05/09 13:36:16 tomka Exp $
+
+*normaliz-2.11 (09 May 2014)
+
+ 09 May 2014; Thomas Kahle <tomka@gentoo.org>
+ +files/normaliz-2.11-respect-flags.patch, +normaliz-2.11.ebuild:
+ Bump to 2.11
*normaliz-2.10.1 (27 Jul 2013)
diff --git a/sci-mathematics/normaliz/files/normaliz-2.11-respect-flags.patch b/sci-mathematics/normaliz/files/normaliz-2.11-respect-flags.patch
new file mode 100644
index 000000000000..6d5c15f18202
--- /dev/null
+++ b/sci-mathematics/normaliz/files/normaliz-2.11-respect-flags.patch
@@ -0,0 +1,35 @@
+diff -U 3 -dHrN Normaliz2.11/source/Makefile Normaliz2.11.new/source/Makefile
+--- Normaliz2.11/source/Makefile 2014-02-24 12:44:10.000000000 +0100
++++ Normaliz2.11.new/source/Makefile 2014-05-09 15:26:52.885085512 +0200
+@@ -20,7 +20,7 @@
+ $(CXX) $(CXXFLAGS) $(NORMFLAGS) -c Normaliz.cpp -o normaliz.o
+
+ normaliz: $(SOURCES) $(HEADERS) normaliz.o libnormaliz/libnormaliz.a
+- $(CXX) $(CXXFLAGS) $(NORMFLAGS) normaliz.o libnormaliz/libnormaliz.a $(GMPFLAGS) -o normaliz
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) normaliz.o libnormaliz/libnormaliz.a $(GMPFLAGS) -o normaliz
+
+ normaliz1: $(SOURCES) $(HEADERS) $(LIBHEADERS) $(LIBSOURCES)
+ $(CXX) $(CXXFLAGS) $(NORMFLAGS) Normaliz-impl.cpp $(GMPFLAGS) -o normaliz1
+diff -U 3 -dHrN Normaliz2.11/source/Makefile.configuration Normaliz2.11.new/source/Makefile.configuration
+--- Normaliz2.11/source/Makefile.configuration 2014-04-29 11:06:24.000000000 +0200
++++ Normaliz2.11.new/source/Makefile.configuration 2014-05-09 15:26:52.875085512 +0200
+@@ -1,11 +1,9 @@
+ ##
+ ## Makefile configuration for normaliz
+ ##
+-CXX = g++
+ #CXX = linux32 g++ -m32 -march=i686 #compile it for linux32
+ CXXFLAGS += -std=c++0x
+ CXXFLAGS += -Wall -pedantic
+-CXXFLAGS += -O3 -funroll-loops
+ #CXXFLAGS += -I /usr/local/boost_1_45_0
+ #CXXFLAGS += -g ## debugging
+ #CXXFLAGS += -pg ## profiling
+@@ -19,7 +17,6 @@
+ endif
+
+ ## for distributing the executables link static (does not work for mac)
+-CXXFLAGS += -static
+ ## for almost static compilation on Mac use
+ #CXXFLAGS += -static-libgcc
+ ## make it compatible with older Mac versions
diff --git a/sci-mathematics/normaliz/normaliz-2.11.ebuild b/sci-mathematics/normaliz/normaliz-2.11.ebuild
new file mode 100644
index 000000000000..19a34550c6b5
--- /dev/null
+++ b/sci-mathematics/normaliz/normaliz-2.11.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/normaliz/normaliz-2.11.ebuild,v 1.1 2014/05/09 13:36:16 tomka Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs versionator
+
+MYPV=$(get_version_component_range 1-2)
+MYP="Normaliz${MYPV}"
+
+DESCRIPTION="Tool for computations in affine monoids and more"
+HOMEPAGE="http://www.mathematik.uni-osnabrueck.de/normaliz/"
+SRC_URI="http://www.mathematik.uni-osnabrueck.de/${PN}/${MYP}/${MYP}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="extras openmp"
+
+RDEPEND="dev-libs/gmp[cxx]"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-libs/boost"
+# Only a boost header is needed -> not RDEPEND
+
+S=${WORKDIR}/${MYP}
+
+src_prepare () {
+ epatch "${FILESDIR}/${PN}-${MYPV}-respect-flags.patch"
+
+ # Respect users AR tool (Bug 474532)
+ sed -e "s:ar -cr:$(tc-getAR) -cr:" -i source/libnormaliz/Makefile
+
+ if use openmp && tc-has-openmp; then
+ export OPENMP=yes
+ else
+ export OPENMP=no
+ fi
+}
+
+src_compile(){
+ emake CXX="$(tc-getCXX)" OPENMP="${OPENMP}" -C source
+}
+
+src_install() {
+ dobin source/normaliz
+ dodoc doc/"Normaliz_${MYPV}.pdf"
+ dodoc doc/"NmzIntegrate_1.2.pdf"
+ if use extras; then
+ elog "You have selected to install extras which consist of Macaulay2"
+ elog "and Singular packages. These have been installed into "
+ elog "/usr/share/${PN}, and cannot be used without additional setup. Please refer"
+ elog "to the homepages of the respective projects for additional information."
+ elog "Note however, Gentoo's versions of Singular and Macaulay2 bring their own"
+ elog "copies of these interface packages. Usually you don't need normaliz's versions."
+ insinto "/usr/share/${PN}"
+ doins Singular/normaliz.lib
+ doins Macaulay2/Normaliz.m2
+ fi
+}