summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-02-01 23:06:44 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-02-01 23:06:44 +0000
commitfeeef3cec5c1e6cd23c9768bd989d74c59c1b830 (patch)
tree4bac3fe690dbc38d67de68d7648ef256ca83b064 /sci-misc/boinc
parentRestored ~ppc and ~ppc64 keywords to KDE-4.2.0 (diff)
downloadgentoo-2-feeef3cec5c1e6cd23c9768bd989d74c59c1b830.tar.gz
gentoo-2-feeef3cec5c1e6cd23c9768bd989d74c59c1b830.tar.bz2
gentoo-2-feeef3cec5c1e6cd23c9768bd989d74c59c1b830.zip
Fix initscript for baselayout-1. This time for real :]. Per bug #257113. Big thanks to Andrea Conti <alyf@alyf.net>
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sci-misc/boinc')
-rw-r--r--sci-misc/boinc/ChangeLog6
-rw-r--r--sci-misc/boinc/files/boinc.init8
2 files changed, 9 insertions, 5 deletions
diff --git a/sci-misc/boinc/ChangeLog b/sci-misc/boinc/ChangeLog
index 2ee7bac5201a..b089f21a3552 100644
--- a/sci-misc/boinc/ChangeLog
+++ b/sci-misc/boinc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-misc/boinc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.49 2009/02/01 15:55:16 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.50 2009/02/01 23:06:43 scarabeus Exp $
+
+ 01 Feb 2009; Tomas Chvatal <scarabeus@gentoo.org> files/boinc.init:
+ Fix initscript for baselayout-1. This time for real :]. Per bug #257113.
+ Big thanks to Andrea Conti <alyf@alyf.net>
01 Feb 2009; Tomas Chvatal <scarabeus@gentoo.org> boinc-6.4.5.ebuild:
Fix bug #249997. Wrong dependency on ca-certificates.
diff --git a/sci-misc/boinc/files/boinc.init b/sci-misc/boinc/files/boinc.init
index 5013516bb8ed..c52072e55fe4 100644
--- a/sci-misc/boinc/files/boinc.init
+++ b/sci-misc/boinc/files/boinc.init
@@ -66,15 +66,15 @@ start() {
# check for baselayout version
if [[ "`start-stop-daemon --version |awk -F' ' '{print $2}'`" = "(OpenRC)" ]]; then
- PARAMS="--stdout ${LOGFILE} --stderr ${LOGFILE} -- ${ARGS}"
+ PARAMS="--background --stdout ${LOGFILE} --stderr ${LOGFILE} -- ${ARGS}"
else
- PARAMS="-- ${ARGS} &> ${LOGFILE}"
+ PARAMS="-- ${ARGS} >> ${LOGFILE} 2>&1 &"
fi
- ${CHRT} start-stop-daemon \
+ eval ${CHRT} start-stop-daemon \
--quiet --start --chdir ${RUNTIMEDIR} \
--exec ${BOINCBIN} --chuid ${USER}:${GROUP} \
- --background --nicelevel ${NICELEVEL} \
+ --nicelevel ${NICELEVEL} \
${PARAMS}
RESULT=$?