summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-11-27 22:51:10 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-11-27 22:51:10 +0000
commitbfeb0cd6f1591b8ba7978ddf9bbc6178870fc2f1 (patch)
tree64d76b83d77a9fa01a4e7d1b4ff1e208c62b4435 /sci-misc/nco
parentMask app-admin/profiler for removal (bug #444332) (diff)
downloadgentoo-2-bfeb0cd6f1591b8ba7978ddf9bbc6178870fc2f1.tar.gz
gentoo-2-bfeb0cd6f1591b8ba7978ddf9bbc6178870fc2f1.tar.bz2
gentoo-2-bfeb0cd6f1591b8ba7978ddf9bbc6178870fc2f1.zip
Version bump
(Portage version: 2.2.01.21313-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-misc/nco')
-rw-r--r--sci-misc/nco/ChangeLog9
-rw-r--r--sci-misc/nco/nco-4.2.3.ebuild51
2 files changed, 58 insertions, 2 deletions
diff --git a/sci-misc/nco/ChangeLog b/sci-misc/nco/ChangeLog
index be6221ffd4ee..2422ce0d9956 100644
--- a/sci-misc/nco/ChangeLog
+++ b/sci-misc/nco/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-misc/nco
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/nco/ChangeLog,v 1.19 2011/12/30 04:10:40 bicatali Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/nco/ChangeLog,v 1.20 2012/11/27 22:51:10 bicatali Exp $
+
+*nco-4.2.3 (27 Nov 2012)
+
+ 27 Nov 2012; Sébastien Fabbro <bicatali@gentoo.org> +nco-4.2.3.ebuild:
+ Version bump
*nco-4.0.8 (30 Dec 2011)
diff --git a/sci-misc/nco/nco-4.2.3.ebuild b/sci-misc/nco/nco-4.2.3.ebuild
new file mode 100644
index 000000000000..85a7c2ba8c1a
--- /dev/null
+++ b/sci-misc/nco/nco-4.2.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/nco/nco-4.2.3.ebuild,v 1.1 2012/11/27 22:51:10 bicatali Exp $
+
+EAPI=4
+inherit eutils flag-o-matic
+
+DESCRIPTION="Command line utilities for operating on netCDF files"
+HOMEPAGE="http://nco.sourceforge.net/"
+SRC_URI="http://nco.sf.net/src/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="dap doc gsl ncap2 static-libs test udunits"
+
+RDEPEND="
+ >=sci-libs/netcdf-4[dap=]
+ gsl? ( sci-libs/gsl )
+ udunits? ( >=sci-libs/udunits-2 )"
+
+DEPEND="${RDEPEND}
+ ncap2? ( dev-java/antlr:0 )
+ test? ( >=sci-libs/netcdf-4[tools] )"
+
+src_configure() {
+ local myconf
+ if has_version '>=sci-libs/netcdf-4[hdf5]'; then
+ myconf="--enable-netcdf4"
+ append-cppflags -DHAVE_NETCDF4_H
+ else
+ myconf="--disable-netcdf4"
+ fi
+ econf \
+ --disable-udunits \
+ $(use_enable dap dap-netcdf) \
+ $(use_enable gsl) \
+ $(use_enable ncap2) \
+ $(use_enable static-libs static) \
+ $(use_enable udunits udunits2) \
+ ${myconf}
+}
+
+src_install() {
+ default
+ cd doc
+ dodoc ANNOUNCE ChangeLog MANIFEST NEWS README TAG TODO VERSION *.txt
+ doinfo *.info*
+ use doc && dohtml nco.html && dodoc nco.pdf
+}