summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2010-03-10 23:13:24 +0000
committerCédric Krier <cedk@gentoo.org>2010-03-10 23:13:24 +0000
commit3ec8459b89607152d2a9338cb5f67057bcbdb910 (patch)
tree95da1f0c9387c27ed2cd176bf7bbeb2d1c1e018a /sci-misc
parentVersion bump. (diff)
downloadgentoo-2-3ec8459b89607152d2a9338cb5f67057bcbdb910.tar.gz
gentoo-2-3ec8459b89607152d2a9338cb5f67057bcbdb910.tar.bz2
gentoo-2-3ec8459b89607152d2a9338cb5f67057bcbdb910.zip
Version bump
(Portage version: 2.1.7.16/cvs/Linux i686)
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/pythoncad/ChangeLog8
-rw-r--r--sci-misc/pythoncad/files/pythoncad-1.37-png.patch24
-rw-r--r--sci-misc/pythoncad/pythoncad-1.37.ebuild (renamed from sci-misc/pythoncad/pythoncad-1.36.ebuild)5
3 files changed, 34 insertions, 3 deletions
diff --git a/sci-misc/pythoncad/ChangeLog b/sci-misc/pythoncad/ChangeLog
index 64f06c712000..054c847fdbb9 100644
--- a/sci-misc/pythoncad/ChangeLog
+++ b/sci-misc/pythoncad/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-misc/pythoncad
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/pythoncad/ChangeLog,v 1.3 2010/02/07 20:18:09 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/pythoncad/ChangeLog,v 1.4 2010/03/10 23:13:23 cedk Exp $
+
+*pythoncad-1.37 (10 Mar 2010)
+
+ 10 Mar 2010; Cédric Krier <cedk@gentoo.org> -pythoncad-1.36.ebuild,
+ +pythoncad-1.37.ebuild, +files/pythoncad-1.37-png.patch:
+ Version bump
07 Feb 2010; Peter Volkov <pva@gentoo.org> pythoncad-1.36.ebuild:
Add inherit eutils: domenu is defined there.
diff --git a/sci-misc/pythoncad/files/pythoncad-1.37-png.patch b/sci-misc/pythoncad/files/pythoncad-1.37-png.patch
new file mode 100644
index 000000000000..7d36625e21a8
--- /dev/null
+++ b/sci-misc/pythoncad/files/pythoncad-1.37-png.patch
@@ -0,0 +1,24 @@
+diff -ru PythonCAD-DS1-R37~/PythonCAD/Interface/Gtk/gtkDialog.py PythonCAD-DS1-R37/PythonCAD/Interface/Gtk/gtkDialog.py
+--- PythonCAD-DS1-R37~/PythonCAD/Interface/Gtk/gtkDialog.py 2010-03-11 00:01:58.000000000 +0100
++++ PythonCAD-DS1-R37/PythonCAD/Interface/Gtk/gtkDialog.py 2010-03-11 00:03:48.000000000 +0100
+@@ -107,7 +107,7 @@
+ _abautDialog.set_program_name("PythonCad")
+ _abautDialog.set_version("DS1-R37")
+ _abautDialog.set_comments("CAD built from Python")
+- _iconPath=os.path.join(os.getcwd(),"gtkpycad.png")
++ _iconPath=os.path.join("/usr/share/pixmaps/pythoncad.png")
+ _pixBuf=gtk.gdk.pixbuf_new_from_file(_iconPath)
+ _abautDialog.set_logo(_pixBuf)
+ _abautDialog.set_website("http://sourceforge.net/projects/pythoncad")
+diff -ru PythonCAD-DS1-R37~/PythonCAD/Interface/Gtk/gtkimage.py PythonCAD-DS1-R37/PythonCAD/Interface/Gtk/gtkimage.py
+--- PythonCAD-DS1-R37~/PythonCAD/Interface/Gtk/gtkimage.py 2010-03-11 00:01:58.000000000 +0100
++++ PythonCAD-DS1-R37/PythonCAD/Interface/Gtk/gtkimage.py 2010-03-11 00:02:59.000000000 +0100
+@@ -154,7 +154,7 @@
+ self.__image = image
+ self.__window = gtk.Window()
+ self.__window.set_title(image.filename)
+- self.__window.set_icon_from_file("gtkpycad.png")
++ self.__window.set_icon_from_file("/usr/share/pixmaps/pythoncad.png")
+ self.__window.connect("destroy", self.__destroyEvent)
+ self.__window.connect("event", self.__windowEvent)
+ self.__window.connect("key_press_event", self.__keyPressEvent)
diff --git a/sci-misc/pythoncad/pythoncad-1.36.ebuild b/sci-misc/pythoncad/pythoncad-1.37.ebuild
index 05bfb6d80a01..8438fe5beb66 100644
--- a/sci-misc/pythoncad/pythoncad-1.36.ebuild
+++ b/sci-misc/pythoncad/pythoncad-1.37.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/pythoncad/pythoncad-1.36.ebuild,v 1.3 2010/02/07 20:18:09 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/pythoncad/pythoncad-1.37.ebuild,v 1.1 2010/03/10 23:13:23 cedk Exp $
NEED_PYTHON=2.3
@@ -13,7 +13,7 @@ MY_P=${MY_PN}-${MY_PV}
DESCRIPTION="CAD program written in PyGTK"
HOMEPAGE="http://www.pythoncad.org/"
LICENSE="GPL-2"
-SRC_URI="http://www.pythoncad.org/releases/${MY_P}.tar.bz2"
+SRC_URI="mirror://sourceforge/pythoncad/${MY_P}.tar.gz"
SLOT="0"
KEYWORDS="~amd64 ~x86"
@@ -29,6 +29,7 @@ S=${WORKDIR}/${MY_P}
src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}/${P}-png.patch"
sed -i \
-e "s/gtkpycad.png/pythoncad.png/" \