summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-05-21 19:34:02 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-05-21 19:34:02 +0000
commit78cee144ab24c150f85291791e57e4537ca38549 (patch)
treef0478dfd94dc64d736d361ed00acbafac50b5212 /sci-misc
parentStabilise 2.3.1 on amd64 and x86. Bump to latest. (diff)
downloadgentoo-2-78cee144ab24c150f85291791e57e4537ca38549.tar.gz
gentoo-2-78cee144ab24c150f85291791e57e4537ca38549.tar.bz2
gentoo-2-78cee144ab24c150f85291791e57e4537ca38549.zip
Drop not fully tested features from initscript. Should solve most issues.
(Portage version: 2.2.0_alpha34/cvs/Linux x86_64)
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/boinc/ChangeLog8
-rw-r--r--sci-misc/boinc/files/boinc.conf8
-rw-r--r--sci-misc/boinc/files/boinc.init22
3 files changed, 9 insertions, 29 deletions
diff --git a/sci-misc/boinc/ChangeLog b/sci-misc/boinc/ChangeLog
index 3819e899c77f..9618f743fb4d 100644
--- a/sci-misc/boinc/ChangeLog
+++ b/sci-misc/boinc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-misc/boinc
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.94 2010/11/08 17:52:35 xarthisius Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-misc/boinc/ChangeLog,v 1.95 2011/05/21 19:34:02 scarabeus Exp $
+
+ 21 May 2011; Tomáš Chvátal <scarabeus@gentoo.org> files/boinc.conf,
+ files/boinc.init:
+ Drop not fully tested features from initscript. Should solve most issues.
08 Nov 2010; Kacper Kowalik <xarthisius@gentoo.org>
boinc-6.10.58-r1.ebuild:
diff --git a/sci-misc/boinc/files/boinc.conf b/sci-misc/boinc/files/boinc.conf
index 223b160b4b4c..827025b7da20 100644
--- a/sci-misc/boinc/files/boinc.conf
+++ b/sci-misc/boinc/files/boinc.conf
@@ -18,11 +18,3 @@ ALLOW_REMOTE_RPC="no"
# nice level
NICELEVEL="19"
-
-# scheduling parameters, arguments to chrt(1)
-SCHED_PARAM="--batch 0"
-
-# Relative CPU allocation for boinc user, default is 1024,
-# requires CONFIG_FAIR_GROUP_SCHED and CONFIG_USER_SCHED,
-# see /usr/src/linux/Documentation/scheduler/sched-design-CFS.txt
-CPU_SHARE="128"
diff --git a/sci-misc/boinc/files/boinc.init b/sci-misc/boinc/files/boinc.init
index 975ee83d68a9..ee772209e130 100644
--- a/sci-misc/boinc/files/boinc.init
+++ b/sci-misc/boinc/files/boinc.init
@@ -24,7 +24,7 @@ create_work_directory() {
generate_logs() {
if [ ! -f "${LOGFILE}" ]; then
einfo "No ${LOGFILE} around. Creating new..."
- einfo "For good log rotation is great tool app-admin/logrotate"
+ einfo "You really should use app-admin/logrotate for the log rotation."
touch "${LOGFILE}"
chown "${USER}:${GROUP}" "${LOGFILE}"
fi
@@ -40,7 +40,7 @@ cuda_check() {
start() {
ebegin "Starting BOINC"
- create_work_directory
+ create_work_directory || return 1
cuda_check
cd "${RUNTIMEDIR}"
@@ -68,14 +68,7 @@ start() {
generate_logs
- # sys-apps/util-linux (setup scheduling policy if specified, otherwise blank out
- if [ "${SCHED_PARAM}" = "" ]; then
- CHRT=""
- else
- CHRT="eval /usr/bin/chrt ${SCHED_PARAM}"
- fi
-
- ${CHRT} start-stop-daemon \
+ start-stop-daemon \
--start --quiet --chdir "${RUNTIMEDIR}" \
--make-pidfile \
--pidfile "${PIDFILE}" \
@@ -85,15 +78,6 @@ start() {
RESULT=$?
- if [ "${CPU_SHARE}" ] && [ -d /sys/kernel/uids ]; then
- BUID="$(id -u "${USER}")"
- # It might take a moment for start-stop-daemon to chuid
- [ -d /sys/kernel/uids/"${BUID}" ] || sleep 5 # 5 was working always here
- if [ -w /sys/kernel/uids/"${BUID}"/cpu_share ]; then
- echo "${CPU_SHARE}" > /sys/kernel/uids/"${BUID}"/cpu_share
- fi
- fi
-
eend ${RESULT}
}