summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-03-23 02:37:22 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-03-23 02:37:22 +0000
commit22c82e184e1f05b1c89ce27d4d97feb8df28b6ea (patch)
treea91d0713a123d4756d48116f1668bf7a52f4b342 /sci-physics/lhapdf
parentVersion bump (diff)
downloadgentoo-2-22c82e184e1f05b1c89ce27d4d97feb8df28b6ea.tar.gz
gentoo-2-22c82e184e1f05b1c89ce27d4d97feb8df28b6ea.tar.bz2
gentoo-2-22c82e184e1f05b1c89ce27d4d97feb8df28b6ea.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics/lhapdf')
-rw-r--r--sci-physics/lhapdf/ChangeLog7
-rw-r--r--sci-physics/lhapdf/lhapdf-5.8.2.ebuild76
2 files changed, 82 insertions, 1 deletions
diff --git a/sci-physics/lhapdf/ChangeLog b/sci-physics/lhapdf/ChangeLog
index 0c8dc9999a7b..3792e13b4eac 100644
--- a/sci-physics/lhapdf/ChangeLog
+++ b/sci-physics/lhapdf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-physics/lhapdf
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/lhapdf/ChangeLog,v 1.8 2010/01/08 02:25:13 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/lhapdf/ChangeLog,v 1.9 2010/03/23 02:37:22 bicatali Exp $
+
+*lhapdf-5.8.2 (23 Mar 2010)
+
+ 23 Mar 2010; Sébastien Fabbro <bicatali@gentoo.org> +lhapdf-5.8.2.ebuild:
+ Version bump
*lhapdf-5.8.1 (08 Jan 2010)
diff --git a/sci-physics/lhapdf/lhapdf-5.8.2.ebuild b/sci-physics/lhapdf/lhapdf-5.8.2.ebuild
new file mode 100644
index 000000000000..140dd8b646aa
--- /dev/null
+++ b/sci-physics/lhapdf/lhapdf-5.8.2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/lhapdf/lhapdf-5.8.2.ebuild,v 1.1 2010/03/23 02:37:22 bicatali Exp $
+
+EAPI=2
+
+DESCRIPTION="Les Houches Parton Density Function unified library"
+HOMEPAGE="http://projects.hepforge.org/lhapdf/"
+SRC_URI="http://www.hepforge.org/archive/lhapdf/${P}.tar.gz
+ test? (
+ http://svn.hepforge.org/${PN}/pdfsets/tags/${PV}/cteq61.LHgrid
+ http://svn.hepforge.org/${PN}/pdfsets/tags/${PV}/MRST2004nlo.LHgrid
+ http://svn.hepforge.org/${PN}/pdfsets/tags/${PV}/cteq61.LHpdf
+ octave? ( http://svn.hepforge.org/${PN}/pdfsets/tags/${PV}/cteq5l.LHgrid ) )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cxx doc examples octave python test"
+
+RDEPEND="octave? ( sci-mathematics/octave )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[latex] )
+ python? ( dev-lang/swig )"
+
+src_prepare() {
+ # do not create extra latex docs
+ sed -i \
+ -e 's/GENERATE_LATEX.*=YES/GENERATE_LATEX = NO/g' \
+ ccwrap/Doxyfile || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable cxx ccwrap) \
+ $(use_enable cxx old-ccwrap ) \
+ $(use_enable python pyext) \
+ $(use_enable doc doxygen)
+}
+
+src_test() {
+ # need to make a bogus link for octave test
+ ln -s "${DISTDIR}" PDFsets
+ LHAPATH="${DISTDIR}" \
+ LD_LIBRARY_PATH="${PWD}/lib/.libs:${LD_LIBRARY_PATH}" \
+ emake check || die "emake check failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README TODO AUTHORS ChangeLog
+
+ # leftover
+ rm -rf "${D}"/usr/share/${PN}/doc || die
+ if use doc && use cxx; then
+ # default doc install buggy
+ insinto /usr/share/doc/${PF}
+ doins -r ccwrap/doxy/html || die
+ fi
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.{f,cc} || die
+ fi
+}
+
+pkg_postinst() {
+ elog "To install data files, you have to run as root:"
+ elog "${ROOT}usr/bin/lhapdf-getdata --dest=${ROOT}usr/share/lhapdf --all"
+}
+
+pkg_postrm() {
+ if [ -d "${ROOT}usr/share/lhapdf" ]; then
+ ewarn "The data directory has not been removed, probably because"
+ ewarn "you still have installed data files."
+ fi
+}