summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-10-18 16:35:29 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-10-18 16:35:29 +0000
commit901701a7d51f7ca3cc8b5ffd89449d2346c96579 (patch)
treeec712af28cedb37d9142ef103e5341c15062ed1b /sci-physics/root
parentAdd patch for security bug #387069. (diff)
downloadgentoo-2-901701a7d51f7ca3cc8b5ffd89449d2346c96579.tar.gz
gentoo-2-901701a7d51f7ca3cc8b5ffd89449d2346c96579.tar.bz2
gentoo-2-901701a7d51f7ca3cc8b5ffd89449d2346c96579.zip
Fix building with libpng15 wrt #387553 by Daniel Savard
(Portage version: 2.2.0_alpha67/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics/root')
-rw-r--r--sci-physics/root/ChangeLog6
-rw-r--r--sci-physics/root/files/root-5.26.00e-libpng15.patch33
-rw-r--r--sci-physics/root/root-5.26.00e-r1.ebuild5
3 files changed, 41 insertions, 3 deletions
diff --git a/sci-physics/root/ChangeLog b/sci-physics/root/ChangeLog
index 9d17ce0c83b3..0e05878c0985 100644
--- a/sci-physics/root/ChangeLog
+++ b/sci-physics/root/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-physics/root
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/ChangeLog,v 1.88 2011/06/21 14:31:50 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/ChangeLog,v 1.89 2011/10/18 16:35:29 ssuominen Exp $
+
+ 18 Oct 2011; Samuli Suominen <ssuominen@gentoo.org> root-5.26.00e-r1.ebuild,
+ +files/root-5.26.00e-libpng15.patch:
+ Fix building with libpng15 wrt #387553 by Daniel Savard
21 Jun 2011; Justin Lecher <jlec@gentoo.org> root-5.26.00-r2.ebuild,
root-5.26.00e-r1.ebuild, root-5.28.00d.ebuild:
diff --git a/sci-physics/root/files/root-5.26.00e-libpng15.patch b/sci-physics/root/files/root-5.26.00e-libpng15.patch
new file mode 100644
index 000000000000..91ed9c428ef1
--- /dev/null
+++ b/sci-physics/root/files/root-5.26.00e-libpng15.patch
@@ -0,0 +1,33 @@
+This patch is a copy from media-libs/libafterimage.
+
+--- graf2d/asimage/src/libAfterImage/export.c
++++ graf2d/asimage/src/libAfterImage/export.c
+@@ -496,7 +496,7 @@
+ png_ptr = png_create_write_struct( PNG_LIBPNG_VER_STRING, NULL, NULL, NULL );
+ if ( png_ptr != NULL )
+ if( (info_ptr = png_create_info_struct(png_ptr)) != NULL )
+- if( setjmp(png_ptr->jmpbuf) )
++ if( setjmp(png_jmpbuf(png_ptr)) )
+ {
+ png_destroy_info_struct(png_ptr, (png_infopp) &info_ptr);
+ info_ptr = NULL ;
+--- graf2d/asimage/src/libAfterImage/import.c
++++ graf2d/asimage/src/libAfterImage/import.c
+@@ -1251,7 +1251,7 @@
+ * the normal method of doing things with libpng). REQUIRED unless you
+ * set up your own error handlers in the png_create_read_struct() earlier.
+ */
+- if ( !setjmp (png_ptr->jmpbuf))
++ if ( !setjmp (png_jmpbuf(png_ptr)))
+ {
+ ASFlagType rgb_flags = ASStorage_RLEDiffCompress|ASStorage_32Bit ;
+
+@@ -1468,7 +1468,7 @@
+
+ static void asim_png_read_data(png_structp png_ptr, png_bytep data, png_size_t length)
+ {
+- ASImPNGReadBuffer *buf = (ASImPNGReadBuffer *)png_ptr->io_ptr;
++ ASImPNGReadBuffer *buf = (ASImPNGReadBuffer *)png_get_io_ptr(png_ptr);
+ memcpy(data, buf->buffer, length);
+ buf->buffer += length;
+ }
diff --git a/sci-physics/root/root-5.26.00e-r1.ebuild b/sci-physics/root/root-5.26.00e-r1.ebuild
index 3ce30e5d174a..c06df397abb7 100644
--- a/sci-physics/root/root-5.26.00e-r1.ebuild
+++ b/sci-physics/root/root-5.26.00e-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/root-5.26.00e-r1.ebuild,v 1.10 2011/06/21 14:31:50 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/root-5.26.00e-r1.ebuild,v 1.11 2011/10/18 16:35:29 ssuominen Exp $
EAPI=3
@@ -111,7 +111,8 @@ src_prepare() {
"${WORKDIR}"/${P}-configure-paths.patch \
"${WORKDIR}"/${P}-nobyte-compile.patch \
"${WORKDIR}"/${P}-glibc212.patch \
- "${WORKDIR}"/${P}-xrootd-prop-flags.patch
+ "${WORKDIR}"/${P}-xrootd-prop-flags.patch \
+ "${FILESDIR}"/${P}-libpng15.patch
# use system cfortran
rm montecarlo/eg/inc/cfortran.h README/cfortran.doc