summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-07-08 14:23:22 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-07-08 14:23:22 +0000
commit62b300beb557b4095e86eb7a15d69c7f55516325 (patch)
treea1c4c7093a1054679b57cddea7144c0cae8178fc /sci-physics
parentMarking amd64 stable, bug #231166 (diff)
downloadgentoo-2-62b300beb557b4095e86eb7a15d69c7f55516325.tar.gz
gentoo-2-62b300beb557b4095e86eb7a15d69c7f55516325.tar.bz2
gentoo-2-62b300beb557b4095e86eb7a15d69c7f55516325.zip
Version bump. Removed dev-util/jam now obsolete. Thanks Marek Miller for testing (bug #231168).
(Portage version: 2.1.4.4)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/bullet/ChangeLog9
-rw-r--r--sci-physics/bullet/bullet-2.67.ebuild4
-rw-r--r--sci-physics/bullet/bullet-2.69.ebuild47
3 files changed, 57 insertions, 3 deletions
diff --git a/sci-physics/bullet/ChangeLog b/sci-physics/bullet/ChangeLog
index 82b1ca90d5f5..47b4b9e5692e 100644
--- a/sci-physics/bullet/ChangeLog
+++ b/sci-physics/bullet/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-physics/bullet
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/bullet/ChangeLog,v 1.1 2008/03/11 19:10:20 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/bullet/ChangeLog,v 1.2 2008/07/08 14:23:22 bicatali Exp $
+
+*bullet-2.69 (08 Jul 2008)
+
+ 08 Jul 2008; Sébastien Fabbro <bicatali@gentoo.org> bullet-2.67.ebuild,
+ +bullet-2.69.ebuild:
+ Version bump. Removed dev-util/jam now obsolete. Thanks Marek Miller for
+ testing (bug #231168).
*bullet-2.67 (11 Mar 2008)
diff --git a/sci-physics/bullet/bullet-2.67.ebuild b/sci-physics/bullet/bullet-2.67.ebuild
index a197496dccbb..766be264e7c4 100644
--- a/sci-physics/bullet/bullet-2.67.ebuild
+++ b/sci-physics/bullet/bullet-2.67.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/bullet/bullet-2.67.ebuild,v 1.1 2008/03/11 19:10:20 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/bullet/bullet-2.67.ebuild,v 1.2 2008/07/08 14:23:22 bicatali Exp $
inherit eutils toolchain-funcs
@@ -15,7 +15,7 @@ IUSE="doc examples"
RDEPEND="examples? ( virtual/opengl virtual/glut )"
DEPEND="${DEPEND}
- || ( dev-util/jam dev-util/ftjam )"
+ dev-util/ftjam"
src_unpack() {
unpack ${A}
diff --git a/sci-physics/bullet/bullet-2.69.ebuild b/sci-physics/bullet/bullet-2.69.ebuild
new file mode 100644
index 000000000000..bdc00c0238d3
--- /dev/null
+++ b/sci-physics/bullet/bullet-2.69.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/bullet/bullet-2.69.ebuild,v 1.1 2008/07/08 14:23:22 bicatali Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Continuous Collision Detection and Physics Library"
+HOMEPAGE="http://www.continuousphysics.com/Bullet/"
+SRC_URI="http://bullet.googlecode.com/files/${P}.tgz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc examples"
+
+RDEPEND="examples? ( virtual/opengl virtual/glut )"
+DEPEND="${DEPEND}
+ dev-util/ftjam"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e 's:-O3 -fomit-frame-pointer -ffast-math::' \
+ Jamrules || die "sed Jamrules failed"
+}
+
+src_compile() {
+ econf \
+ $(use_with examples x) \
+ $(use_with examples mesa) \
+ || die "econf failed"
+ jam -qa || die "jam failed"
+}
+
+src_test() {
+ jam check || die "jam check failed"
+}
+
+src_install() {
+ jam -sDESTDIR="${D}" install || die "jam install failed"
+ dodoc README ChangeLog.txt AUTHORS || die
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins *.pdf || die
+ fi
+}