summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-04-07 18:37:15 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-04-07 18:37:15 +0000
commit8bda191377f6515059d4192e6072889637105d6f (patch)
treea43d9155beacc684e2e7435e010361fcecc2d1ab /sci-physics
parentUse Python 2 (bug #324387). (diff)
downloadgentoo-2-8bda191377f6515059d4192e6072889637105d6f.tar.gz
gentoo-2-8bda191377f6515059d4192e6072889637105d6f.tar.bz2
gentoo-2-8bda191377f6515059d4192e6072889637105d6f.zip
Fix for the GTK M4 macro checking gtk:1, thanks Alex Belykh, bug #353785
(Portage version: 2.1.9.45/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/lightspeed/ChangeLog6
-rw-r--r--sci-physics/lightspeed/files/lightspeed-1.2a-autoconf.patch16
-rw-r--r--sci-physics/lightspeed/lightspeed-1.2a-r1.ebuild3
3 files changed, 23 insertions, 2 deletions
diff --git a/sci-physics/lightspeed/ChangeLog b/sci-physics/lightspeed/ChangeLog
index 972946e9dcb4..e6bb8af7ce90 100644
--- a/sci-physics/lightspeed/ChangeLog
+++ b/sci-physics/lightspeed/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-physics/lightspeed
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/lightspeed/ChangeLog,v 1.16 2011/03/06 09:34:28 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/lightspeed/ChangeLog,v 1.17 2011/04/07 18:37:15 bicatali Exp $
+
+ 07 Apr 2011; Sébastien Fabbro <bicatali@gentoo.org>
+ lightspeed-1.2a-r1.ebuild, +files/lightspeed-1.2a-autoconf.patch:
+ Fix for the GTK M4 macro checking gtk:1, thanks Alex Belykh, bug #353785
06 Mar 2011; Justin Lecher <jlec@gentoo.org> lightspeed-1.2a-r1.ebuild:
Correct Slots for gtk 3 introduction to tree
diff --git a/sci-physics/lightspeed/files/lightspeed-1.2a-autoconf.patch b/sci-physics/lightspeed/files/lightspeed-1.2a-autoconf.patch
new file mode 100644
index 000000000000..c6b2f9fda711
--- /dev/null
+++ b/sci-physics/lightspeed/files/lightspeed-1.2a-autoconf.patch
@@ -0,0 +1,16 @@
+diff --git a/configure.in b/configure.in
+index 1cfbcba..5363c05 100644
+--- a/configure.in
++++ b/configure.in
+@@ -54,9 +54,8 @@ if test "x$with_gtk" != "x1" -a "$gtkmorph_gtk" = "" ; then
+ AC_MSG_NOTICE([ Testing for GTK 2 skipped])
+ fi
+ if test "x$with_gtk" != "x2" -a "$version_of_gtk" = "" ; then
+- AM_PATH_GTK(1.0.1, , [AC_MSG_ERROR([Cannot find proper GTK+ version])])
+- version_of_gtk=gtk1
+- AC_DEFINE(HAVE_GTK1,1,"compiled with GTK 1 and GtkGLArea ")
++ AC_MSG_ERROR([Cannot find proper GTK+ version])
++ exit 1
+ fi
+
+ AM_CONDITIONAL(COND_GTK1, test "$version_of_gtk" = "gtk1" )
diff --git a/sci-physics/lightspeed/lightspeed-1.2a-r1.ebuild b/sci-physics/lightspeed/lightspeed-1.2a-r1.ebuild
index e520c49cce48..4ea83e1f16ab 100644
--- a/sci-physics/lightspeed/lightspeed-1.2a-r1.ebuild
+++ b/sci-physics/lightspeed/lightspeed-1.2a-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/lightspeed/lightspeed-1.2a-r1.ebuild,v 1.11 2011/03/06 09:34:28 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/lightspeed/lightspeed-1.2a-r1.ebuild,v 1.12 2011/04/07 18:37:15 bicatali Exp $
EAPI=2
@@ -40,6 +40,7 @@ S2="${WORKDIR}/objects"
src_prepare() {
epatch "${WORKDIR}/${DEB_PATCH}.diff"
+ epatch "${FILESDIR}"/${P}-autoconf.patch
eautoreconf
}