summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-06-28 13:34:44 +0000
committerJustin Lecher <jlec@gentoo.org>2011-06-28 13:34:44 +0000
commit99452421b46d78cbf56abb7dc9e96a61f75fa423 (patch)
tree10875215688a7109af76656e5a28c3162f87dde0 /sci-physics
parentVersion bump for dev channel release. Remove old. (diff)
downloadgentoo-2-99452421b46d78cbf56abb7dc9e96a61f75fa423.tar.gz
gentoo-2-99452421b46d78cbf56abb7dc9e96a61f75fa423.tar.bz2
gentoo-2-99452421b46d78cbf56abb7dc9e96a61f75fa423.zip
Fix sed on *FLAGS from : to |, EAPI bump
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/geant/ChangeLog7
-rw-r--r--sci-physics/geant/geant-3.21.14-r2.ebuild22
-rw-r--r--sci-physics/geant/geant-4.9.2_p02.ebuild32
-rw-r--r--sci-physics/geant/geant-4.9.3_p02-r1.ebuild39
-rw-r--r--sci-physics/geant/geant-4.9.4_p01.ebuild16
-rw-r--r--sci-physics/geant/metadata.xml30
6 files changed, 75 insertions, 71 deletions
diff --git a/sci-physics/geant/ChangeLog b/sci-physics/geant/ChangeLog
index 8d1c2f26219b..323126ff83c9 100644
--- a/sci-physics/geant/ChangeLog
+++ b/sci-physics/geant/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-physics/geant
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/ChangeLog,v 1.51 2011/06/21 14:39:19 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/ChangeLog,v 1.52 2011/06/28 13:34:44 jlec Exp $
+
+ 28 Jun 2011; Justin Lecher <jlec@gentoo.org> geant-3.21.14-r2.ebuild,
+ geant-4.9.2_p02.ebuild, geant-4.9.3_p02-r1.ebuild, geant-4.9.4_p01.ebuild,
+ metadata.xml:
+ Fix sed on *FLAGS from : to |, EAPI bump
21 Jun 2011; Justin Lecher <jlec@gentoo.org> geant-3.21.14-r2.ebuild,
geant-4.9.2_p02.ebuild, geant-4.9.3_p02-r1.ebuild, geant-4.9.4_p01.ebuild:
diff --git a/sci-physics/geant/geant-3.21.14-r2.ebuild b/sci-physics/geant/geant-3.21.14-r2.ebuild
index cd0c60c6e217..eeca20d617f1 100644
--- a/sci-physics/geant/geant-3.21.14-r2.ebuild
+++ b/sci-physics/geant/geant-3.21.14-r2.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/geant-3.21.14-r2.ebuild,v 1.19 2011/06/21 14:39:19 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/geant-3.21.14-r2.ebuild,v 1.20 2011/06/28 13:34:44 jlec Exp $
EAPI=2
+
inherit eutils fortran-2
DEB_PN=geant321
@@ -12,22 +13,21 @@ DEB_P=${DEB_PN}_${DEB_PV}
DESCRIPTION="CERN's detector description and simulation Tool"
HOMEPAGE="http://wwwasd.web.cern.ch/wwwasd/geant/index.html"
-
-LICENSE="GPL-2 LGPL-2 BSD"
-SRC_URI="mirror://debian/pool/main/${DEB_PN:0:1}/${DEB_PN}/${DEB_P}.orig.tar.gz
+SRC_URI="
+ mirror://debian/pool/main/${DEB_PN:0:1}/${DEB_PN}/${DEB_P}.orig.tar.gz
mirror://debian/pool/main/${DEB_PN:0:1}/${DEB_PN}/${DEB_P}-${DEB_PR}.diff.gz"
-KEYWORDS="amd64 x86"
SLOT="3"
+LICENSE="GPL-2 LGPL-2 BSD"
+KEYWORDS="amd64 x86"
IUSE=""
RDEPEND="
- virtual/fortran
->=x11-libs/openmotif-2.3:0
dev-lang/cfortran
sci-physics/cernlib
- sci-physics/paw"
-
+ sci-physics/paw
+ virtual/fortran
+ x11-libs/openmotif:0"
DEPEND="${RDEPEND}
virtual/latex-base
x11-misc/imake
@@ -42,9 +42,9 @@ src_prepare() {
cd "${S}"
cp debian/add-ons/Makefile .
export DEB_BUILD_OPTIONS="$(tc-getFC) nostrip nocheck"
- sed -i \
+ sed \
-e 's:/usr/local:/usr:g' \
- Makefile || die "sed'ing the Makefile failed"
+ -i Makefile || die "sed'ing the Makefile failed"
einfo "Applying Debian patches"
emake -j1 patch || die "debian patch failed"
diff --git a/sci-physics/geant/geant-4.9.2_p02.ebuild b/sci-physics/geant/geant-4.9.2_p02.ebuild
index 55c9cb34baf4..df4b4ad5adb8 100644
--- a/sci-physics/geant/geant-4.9.2_p02.ebuild
+++ b/sci-physics/geant/geant-4.9.2_p02.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/geant-4.9.2_p02.ebuild,v 1.14 2011/06/21 14:39:19 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/geant-4.9.2_p02.ebuild,v 1.15 2011/06/28 13:34:44 jlec Exp $
EAPI=2
-inherit eutils fortran-2 versionator toolchain-funcs
+inherit eutils fortran-2 toolchain-funcs versionator
PV1=$(get_version_component_range 1 ${PV})
PV2=$(get_version_component_range 2 ${PV})
@@ -13,10 +13,10 @@ MY_P=${PN}$(replace_version_separator 3 .)
DESCRIPTION="Toolkit for simulation of passage of particles through matter"
HOMEPAGE="http://geant4.cern.ch/"
-
SRC_COM="http://geant4.web.cern.ch/geant4/support/source"
SRC_URI="${SRC_COM}/${MY_P}.tar.gz"
-GEANT4_DATA="G4NDL.3.13
+GEANT4_DATA="
+ G4NDL.3.13
G4EMLOW.6.2
G4RadioactiveDecay.3.2
PhotonEvaporation.2.0
@@ -33,20 +33,22 @@ IUSE="aida athena +data dawn debug examples gdml geant3 global minimal +motif
RDEPEND="
virtual/fortran
-<sci-physics/clhep-2.1
- motif? ( >=x11-libs/openmotif-2.3:0 )
+ <sci-physics/clhep-2.1
+ motif? ( x11-libs/openmotif:0 )
athena? ( x11-libs/libXaw )
qt4? ( x11-libs/qt-gui:4 )
openinventor? ( >=media-libs/openinventor-2.1.5.10-r3 )
- raytracerx? ( x11-libs/libX11 x11-libs/libXmu )
- opengl? ( virtual/opengl
- athena? ( x11-libs/Xaw3d )
- qt4? ( x11-libs/qt-opengl:4 ) )
+ raytracerx? (
+ x11-libs/libX11
+ x11-libs/libXmu )
+ opengl? (
+ virtual/opengl
+ athena? ( x11-libs/Xaw3d )
+ qt4? ( x11-libs/qt-opengl:4 ) )
gdml? ( dev-libs/xerces-c )
geant3? ( sci-physics/geant:3 )
dawn? ( media-gfx/dawn )
zlib? ( sys-libs/zlib )"
-
DEPEND="${RDEPEND}"
S="${WORKDIR}/${MY_P}"
@@ -67,10 +69,10 @@ src_prepare() {
-e '/FC.*:=.*gfortran/d' \
-e 's/\(CXXFLAGS.*:=\).*/\1 -ansi/' \
-e '/CXXFLAGS.*+=.*pipe/d' \
- -e "/CXXFLAGS.*=.*-O2/s:=.*:= ${CXXFLAGS}:" \
- -e "/FCFLAGS.*=.*-O2/s:=.*:= ${FCFLAGS}:" \
- -e "/CCFLAGS.*=.*-O2/s:=.*:= ${CFLAGS}:" \
- -e "s:-Wl,-soname:${LDFLAGS} -Wl,-soname:g" \
+ -e "/CXXFLAGS.*=.*-O2/s|=.*|= ${CXXFLAGS}|" \
+ -e "/FCFLAGS.*=.*-O2/s|=.*|= ${FCFLAGS}|" \
+ -e "/CCFLAGS.*=.*-O2/s|=.*|= ${CFLAGS}|" \
+ -e "s|-Wl,-soname|${LDFLAGS} -Wl,-soname|g" \
-e "s/libq\*/lib\[q,Q\]t*/g" \
config/sys/Linux*gmk || die "flag substitution failed"
sed -i \
diff --git a/sci-physics/geant/geant-4.9.3_p02-r1.ebuild b/sci-physics/geant/geant-4.9.3_p02-r1.ebuild
index 69637a062237..9795a146eb8d 100644
--- a/sci-physics/geant/geant-4.9.3_p02-r1.ebuild
+++ b/sci-physics/geant/geant-4.9.3_p02-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/geant-4.9.3_p02-r1.ebuild,v 1.6 2011/06/21 14:39:19 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/geant-4.9.3_p02-r1.ebuild,v 1.7 2011/06/28 13:34:44 jlec Exp $
-EAPI=3
+EAPI=4
-inherit eutils fortran-2 versionator toolchain-funcs
+inherit eutils fortran-2 toolchain-funcs versionator
PV1=$(get_version_component_range 1 ${PV})
PV2=$(get_version_component_range 2 ${PV})
@@ -13,10 +13,10 @@ MY_P=${PN}$(replace_version_separator 3 .)
DESCRIPTION="Toolkit for simulation of passage of particles through matter"
HOMEPAGE="http://geant4.cern.ch/"
-
SRC_COM="http://geant4.cern.ch/support/source"
SRC_URI="${SRC_COM}/${MY_P}.tar.gz"
-GEANT4_DATA="G4NDL.3.13
+GEANT4_DATA="
+ G4NDL.3.13
G4EMLOW.6.9
G4RadioactiveDecay.3.2
PhotonEvaporation.2.0
@@ -34,8 +34,8 @@ IUSE="athena +data dawn debug examples gdml geant3 global minimal +motif
RDEPEND="
virtual/fortran
-<sci-physics/clhep-2.1
- motif? ( >=x11-libs/openmotif-2.3:0 )
+ <sci-physics/clhep-2.1
+ motif? ( x11-libs/openmotif:0 )
athena? ( x11-libs/libXaw )
qt4? ( x11-libs/qt-gui:4 )
openinventor? ( >=media-libs/openinventor-2.1.5.10-r3 )
@@ -47,7 +47,6 @@ RDEPEND="
geant3? ( sci-physics/geant:3 )
dawn? ( media-gfx/dawn )
zlib? ( sys-libs/zlib )"
-
DEPEND="${RDEPEND}"
S="${WORKDIR}/${MY_P}"
@@ -151,20 +150,20 @@ src_configure() {
src_compile() {
cd "${S}/source/"
einfo "Building shared library"
- emake || die "Building shared geant failed"
+ emake
if use global; then
export G4LIB_USE_GRANULAR=y
einfo "Building granular libraries"
- emake global || die "Building global libraries failed"
- emake || die "Rebuilding shared geant failed"
+ emake global
+ emake
fi
if use static-libs; then
einfo "Building static libraries"
rm -rf tmp
export G4LIB_BUILD_STATIC=y ; unset G4LIB_BUILD_SHARED
- emake || die "Building static geant failed"
+ emake
fi
}
@@ -199,34 +198,34 @@ g4_create_env_script() {
printenv | uniq | \
sed -n -e '/^G4/s:BUILD\(.*\)_DRIVER:USE\1:gp' >> ${g4env}
sed -i -e '/G4WORKDIR/d' ${g4env}
- doenvd ${g4env} || die "Installing environment scripts failed "
+ doenvd ${g4env}
}
src_install() {
# install headers via make since we want them in a single directory
cd "${S}/source/"
einfo "Installing Geant4 headers"
- emake includes || die 'Installing headers failed'
+ emake includes
cd "${S}"
# but install libraries and Geant library tool manually
einfo "Installing Geant4 libraries"
insinto ${GEANT4_LIBDIR}
insopts -m0755
- doins tmp/*.so || die
- doins tmp/libname.map || die
+ doins tmp/*.so
+ doins tmp/libname.map
insopts -m0644
if use static-libs; then
- doins tmp/*.a || die
+ doins tmp/*.a
fi
exeinto ${GEANT4_LIBDIR}
- doexe tmp/liblist || die
+ doexe tmp/liblist
g4_create_env_script
# configs
insinto ${GEANT4_DIR}
- doins -r config || die
+ doins -r config
# install data
if use data; then
@@ -235,7 +234,7 @@ src_install() {
pushd "${WORKDIR}" > /dev/null
for d in ${GEANT4_DATA}; do
local p=${d/.}
- doins -r *${p/G4} || die "installing data ${d} failed"
+ doins -r *${p/G4}
done
popd > /dev/null
fi
diff --git a/sci-physics/geant/geant-4.9.4_p01.ebuild b/sci-physics/geant/geant-4.9.4_p01.ebuild
index a62b3291dc32..c0bb499bfb0a 100644
--- a/sci-physics/geant/geant-4.9.4_p01.ebuild
+++ b/sci-physics/geant/geant-4.9.4_p01.ebuild
@@ -1,23 +1,22 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/geant-4.9.4_p01.ebuild,v 1.5 2011/06/21 14:39:19 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/geant/geant-4.9.4_p01.ebuild,v 1.6 2011/06/28 13:34:44 jlec Exp $
-EAPI=3
+EAPI=4
-inherit cmake-utils fortran-2 versionator eutils fortran-2
+inherit cmake-utils eutils fortran-2 versionator
PV1=$(get_version_component_range 1 ${PV})
PV2=$(get_version_component_range 2 ${PV})
PV3=$(get_version_component_range 3 ${PV})
-
MYP=${PN}$(replace_version_separator 3 .)
DESCRIPTION="Toolkit for simulation of passage of particles through matter"
HOMEPAGE="http://geant4.cern.ch/"
-
SRC_COM="http://geant4.cern.ch/support/source"
SRC_URI="${SRC_COM}/${MYP}.tar.gz"
-GEANT4_DATA="G4NDL.3.14
+GEANT4_DATA="
+ G4NDL.3.14
G4EMLOW.6.19
G4RadioactiveDecay.3.3
G4NEUTRONXS.1.0
@@ -36,13 +35,12 @@ IUSE="+data dawn examples gdml geant3 granular qt4 static-libs vrml zlib"
RDEPEND="
virtual/fortran
->=sci-physics/clhep-2.1
+ >=sci-physics/clhep-2.1
qt4? ( x11-libs/qt-gui:4 x11-libs/qt-opengl:4 )
gdml? ( dev-libs/xerces-c )
geant3? ( sci-physics/geant:3 )
dawn? ( media-gfx/dawn )
zlib? ( sys-libs/zlib )"
-
DEPEND="${RDEPEND}"
S="${WORKDIR}/${MYP}"
@@ -71,7 +69,7 @@ src_install() {
pushd "${WORKDIR}" > /dev/null
for d in ${GEANT4_DATA}; do
local p=${d/.}
- doins -r *${p/G4} || die "installing data ${d} failed"
+ doins -r *${p/G4}
done
popd > /dev/null
fi
diff --git a/sci-physics/geant/metadata.xml b/sci-physics/geant/metadata.xml
index bd76f546c4b1..7d3677c6e528 100644
--- a/sci-physics/geant/metadata.xml
+++ b/sci-physics/geant/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-physics</herd>
-<longdescription lang="en">
+ <herd>sci-physics</herd>
+ <longdescription lang="en">
Geant simulates the passage of subatomic particles through matter, for
instance, particle detectors. Geant 3 simulations are performed by
linking Fortran code supplied by the user with the Geant libraries,
@@ -11,21 +11,21 @@
Geant 4 is a complete rewrite in C++ with addition of other modern
features and detectors.
</longdescription>
-<use>
- <flag name='athena'>Enable the MIT Athena (<pkg>x11-libs/libXaw</pkg>)
+ <use>
+ <flag name="athena">Enable the MIT Athena (<pkg>x11-libs/libXaw</pkg>)
widget set (default is Motif)</flag>
- <flag name='data'>Add a lot of standard physics data files for geant4</flag>
- <flag name='dawn'>Add support for <pkg>media-gfx/dawn</pkg> (3D postscript
+ <flag name="data">Add a lot of standard physics data files for geant4</flag>
+ <flag name="dawn">Add support for <pkg>media-gfx/dawn</pkg> (3D postscript
rendering)</flag>
- <flag name='gdml'>Enable geometry markup language for xml</flag>
- <flag name='geant3'>Add compatibility for geant321 to geant4</flag>
- <flag name='global'>Produce a huge global library instead of small
+ <flag name="gdml">Enable geometry markup language for xml</flag>
+ <flag name="geant3">Add compatibility for geant321 to geant4</flag>
+ <flag name="global">Produce a huge global library instead of small
ones</flag>
- <flag name='granular'>Produce many small libraries instead of global ones</flag>
- <flag name='aida'>Add support for Abstract Interfaces for Data Analysis </flag>
- <flag name='openinventor'>Add support for <pkg>media-libs/openinventor</pkg>
+ <flag name="granular">Produce many small libraries instead of global ones</flag>
+ <flag name="aida">Add support for Abstract Interfaces for Data Analysis </flag>
+ <flag name="openinventor">Add support for <pkg>media-libs/openinventor</pkg>
SGI toolkit</flag>
- <flag name='raytracerx'>Enable raytracing for physics events</flag>
- <flag name='vrml'>Enable output of geant4 in vrml formats</flag>
-</use>
+ <flag name="raytracerx">Enable raytracing for physics events</flag>
+ <flag name="vrml">Enable output of geant4 in vrml formats</flag>
+ </use>
</pkgmetadata>