summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-07-29 10:43:53 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-07-29 10:43:53 +0000
commitf3d16f14a78261b6487f9644f1777e3aa7253a0b (patch)
tree456132b5e67f7ee917782951238ba544fbedc49d /sci-physics
parentVersion bump (diff)
downloadgentoo-2-f3d16f14a78261b6487f9644f1777e3aa7253a0b.tar.gz
gentoo-2-f3d16f14a78261b6487f9644f1777e3aa7253a0b.tar.bz2
gentoo-2-f3d16f14a78261b6487f9644f1777e3aa7253a0b.zip
Added use flags in metadata.xml, removed pch use flag (buggy upstream), added libiodbc as a possible implementation for ODBC. Also fixed qt-xmlpatterns dependency.
(Portage version: 2.1.4.4)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/root/ChangeLog8
-rw-r--r--sci-physics/root/metadata.xml44
-rw-r--r--sci-physics/root/root-5.18.00d.ebuild4
-rw-r--r--sci-physics/root/root-5.20.00.ebuild12
4 files changed, 60 insertions, 8 deletions
diff --git a/sci-physics/root/ChangeLog b/sci-physics/root/ChangeLog
index d5f5260b15eb..73d63a5b7f1c 100644
--- a/sci-physics/root/ChangeLog
+++ b/sci-physics/root/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-physics/root
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/ChangeLog,v 1.32 2008/07/27 22:20:12 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/ChangeLog,v 1.33 2008/07/29 10:43:53 bicatali Exp $
+
+ 29 Jul 2008; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml,
+ root-5.18.00d.ebuild, root-5.20.00.ebuild:
+ Added use flags in metadata.xml, removed pch use flag (buggy upstream),
+ added libiodbc as a possible implementation for ODBC. Also fixed
+ qt-xmlpatterns dependency.
27 Jul 2008; Carsten Lohrke <carlo@gentoo.org> root-5.16.00.ebuild,
root-5.18.00d.ebuild:
diff --git a/sci-physics/root/metadata.xml b/sci-physics/root/metadata.xml
index d4425c08ae2e..856a1f21c636 100644
--- a/sci-physics/root/metadata.xml
+++ b/sci-physics/root/metadata.xml
@@ -10,4 +10,48 @@
statistics, serialization, optimization, linear algebra, graphics,
GUI toolkit, and a complete visualization framework.
</longdescription>
+<use>
+ <flag name="cern">
+ Build the HBOOK input/ouput functionality. HBOOK is a histogram
+ library. On ROOT versions previous to 5.20.00, it will depend
+ on <pkg>sci-physics/cernlib</pkg>. On versions above, it only need
+ a FORTRAN compiler.
+ </flag>
+ <flag name="cint7">
+ Build the experimental C++ INTerpreter version 7. Use with caution to
+ test this newer interpreter. If not sure, stick with version 6
+ included by default.
+ </flag>
+ <flag name="clarens">
+ Buld the Clarens and PEAC plug-ins, to use in a GRID enabled
+ analysis. The Clarens Grid-Enabled Web Services Framework is an
+ open source portal for ubiquitous access to data and computational
+ resources provided by computing grids. PEAC is an interactive
+ distributed analysis framework that uses Clarens as a glue
+ protocol to advertise and communicate amongst SAM, Global Manager
+ (GM), Local Manager (LM), DCache, and PROOF services.
+ It doesn't need Clarens to build, however if you want to use it,
+ you will require to build Clarens and PEAC on your own, it is not
+ yet in the Gentoo Portage tree.
+ See http://clarens.sourceforge.net/ for Clarens
+ and http://physics.ucsd.edu/~schsu/project/peac.html for
+ PEAC.
+ </flag>
+ <flag name="geant4">
+ Build the <pkg>sci-physics/geant</pkg> (GEANT4) navigator.
+ </flag>
+ <flag name="math">
+ Build all math libraries plugins. It includes
+ the <pkg>sci-libs/gsl</pkg> bindings in MathMore, the GenVector
+ physical vectors package, the Minuit2 minimization library (same as
+ standalone <pkg>sci-libs/minuit</pkg>), the RooFit toolkit for
+ distribution modeling, and the Universal Non-Uniform RANdom number
+ generators (UNURAN) library.
+ </flag>
+ <flag name="xrootd">
+ Build the xrootd low latency file server. For more on the eXtended Request
+ Daemon (xrd) and associated software, please see
+ http://xrootd.slac.stanford.edu.
+ </flag>
+</use>
</pkgmetadata>
diff --git a/sci-physics/root/root-5.18.00d.ebuild b/sci-physics/root/root-5.18.00d.ebuild
index 6403f0deea37..e6375a97e063 100644
--- a/sci-physics/root/root-5.18.00d.ebuild
+++ b/sci-physics/root/root-5.18.00d.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/root-5.18.00d.ebuild,v 1.6 2008/07/27 22:20:12 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/root-5.18.00d.ebuild,v 1.7 2008/07/29 10:43:53 bicatali Exp $
EAPI="1"
inherit versionator flag-o-matic eutils toolchain-funcs qt3 qt4 fortran
@@ -39,7 +39,7 @@ RDEPEND="sys-apps/shadow
qt4? ( || ( ( x11-libs/qt-gui:4
x11-libs/qt-opengl:4
x11-libs/qt-qt3support:4
- x11-libs/qt-xml:4 )
+ x11-libs/qt-xmlpatterns:4 )
=x11-libs/qt-4.3* ) )
fftw? ( >=sci-libs/fftw-3 )
python? ( dev-lang/python )
diff --git a/sci-physics/root/root-5.20.00.ebuild b/sci-physics/root/root-5.20.00.ebuild
index 5736e6e29d26..35b8a1c55864 100644
--- a/sci-physics/root/root-5.20.00.ebuild
+++ b/sci-physics/root/root-5.20.00.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/root-5.20.00.ebuild,v 1.3 2008/07/26 21:40:13 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/root-5.20.00.ebuild,v 1.4 2008/07/29 10:43:53 bicatali Exp $
EAPI=1
inherit versionator flag-o-matic eutils toolchain-funcs qt4 fortran
@@ -18,7 +18,7 @@ LICENSE="LGPL-2.1"
KEYWORDS="~amd64 ~hppa ~sparc ~x86"
IUSE="afs cern clarens doc fftw geant4 kerberos ldap +math mysql odbc
- oracle pch postgres python ruby qt4 ssl xml xrootd"
+ oracle postgres python ruby qt4 ssl xml xrootd"
# libafterimage ignored, may be re-install for >=5.20
# see https://savannah.cern.ch/bugs/?func=detailitem&item_id=30944
@@ -43,7 +43,7 @@ RDEPEND="sys-apps/shadow
qt4? ( || ( ( x11-libs/qt-gui:4
x11-libs/qt-opengl:4
x11-libs/qt-qt3support:4
- x11-libs/qt-xml:4 )
+ x11-libs/qt-xmlpatterns:4 )
=x11-libs/qt-4.3* ) )
fftw? ( sci-libs/fftw:3.0 )
python? ( dev-lang/python )
@@ -51,7 +51,7 @@ RDEPEND="sys-apps/shadow
ssl? ( dev-libs/openssl )
xml? ( dev-libs/libxml2 )
geant4? ( sci-physics/geant:4 )
- odbc? ( dev-db/unixODBC )
+ odbc? ( || ( dev-db/unixODBC dev-db/libiodbc ) )
oracle? ( dev-db/oracle-instantclient-basic )
clarens? ( dev-libs/xmlrpc-c )"
@@ -118,6 +118,9 @@ src_compile() {
myconf="${myconf} --with-clhep-incdir=/usr/include" && \
myconf="${myconf} --with-g4-libdir=${G4LIB}"
+ use odbc && [[ -z $(type -P odbc-config) ]] && \
+ myconf="${myconf} --with-odbc-incdir=/usr/include/iodbc"
+
# the configure script is not the standard autotools
./configure \
${target} \
@@ -163,7 +166,6 @@ src_compile() {
$(use_enable math unuran) \
$(use_enable mysql) \
$(use_enable odbc) \
- $(use_enable pch) \
$(use_enable postgres pgsql) \
$(use_enable python) \
$(use_enable qt4 qt) \