summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2006-01-29 19:35:32 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2006-01-29 19:35:32 +0000
commit3760f47b80b76980f21cbddaef7efc8aa4caf619 (patch)
tree428a39ddf27af0fcd111d0e1f014b5a3582be53f /sci-visualization/fig2sxd/fig2sxd-0.13.ebuild
parentreally fix selinux patch (diff)
downloadgentoo-2-3760f47b80b76980f21cbddaef7efc8aa4caf619.tar.gz
gentoo-2-3760f47b80b76980f21cbddaef7efc8aa4caf619.tar.bz2
gentoo-2-3760f47b80b76980f21cbddaef7efc8aa4caf619.zip
Moved from media-gfx/fig2sxd to sci-visualization/fig2sxd.
Diffstat (limited to 'sci-visualization/fig2sxd/fig2sxd-0.13.ebuild')
-rw-r--r--sci-visualization/fig2sxd/fig2sxd-0.13.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sci-visualization/fig2sxd/fig2sxd-0.13.ebuild b/sci-visualization/fig2sxd/fig2sxd-0.13.ebuild
new file mode 100644
index 000000000000..e5ee463b0e2c
--- /dev/null
+++ b/sci-visualization/fig2sxd/fig2sxd-0.13.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/fig2sxd/fig2sxd-0.13.ebuild,v 1.1 2006/01/29 19:35:32 cryos Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A utility to convert files in xfig format to OpenOffice.org Draw format"
+LICENSE="GPL-2"
+
+HOMEPAGE="http://sourceforge.net/projects/fig2sxd"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}.orig.tar.gz
+ mirror://sourceforge/${PN}/${PN}_${PV}-1.diff.gz"
+
+SLOT="0"
+
+KEYWORDS="~ppc-macos ~x86"
+
+IUSE=""
+
+# Our workdir is somewhat different due
+# to the tarball name
+S="${WORKDIR}/${P}.orig"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${WORKDIR}"/${PN}_${PV}-1.diff
+}
+
+src_compile() {
+ emake CXXF="${CXXFLAGS}" CXX="$(tc-getCXX)" || die "emake failed"
+}
+
+src_install() {
+ dobin ${PN} || die
+ doman ${PN}.1 || die
+ dodoc debian/changelog || die
+}