summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-11-26 10:48:58 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-11-26 10:48:58 +0000
commit67dde2753fb00aabe84c2308e7cb03e4b54d085d (patch)
treeed68f5b06704acf78898592bc0865d9bf4faa8b9 /sci-visualization/spectromatic
parentFix bug 248865. (diff)
downloadgentoo-2-67dde2753fb00aabe84c2308e7cb03e4b54d085d.tar.gz
gentoo-2-67dde2753fb00aabe84c2308e7cb03e4b54d085d.tar.bz2
gentoo-2-67dde2753fb00aabe84c2308e7cb03e4b54d085d.zip
Fix installation for man files, cleaned ebuild and propagate cflags
(Portage version: 2.2_rc15/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'sci-visualization/spectromatic')
-rw-r--r--sci-visualization/spectromatic/ChangeLog9
-rw-r--r--sci-visualization/spectromatic/files/spectromatic-1.0-makefile.patch43
-rw-r--r--sci-visualization/spectromatic/metadata.xml11
-rw-r--r--sci-visualization/spectromatic/spectromatic-1.0-r1.ebuild35
4 files changed, 97 insertions, 1 deletions
diff --git a/sci-visualization/spectromatic/ChangeLog b/sci-visualization/spectromatic/ChangeLog
index 4356b1ba23a3..2efa11bcb8b7 100644
--- a/sci-visualization/spectromatic/ChangeLog
+++ b/sci-visualization/spectromatic/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-visualization/spectromatic
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/spectromatic/ChangeLog,v 1.4 2008/02/13 15:01:21 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/spectromatic/ChangeLog,v 1.5 2008/11/26 10:48:57 bicatali Exp $
+
+*spectromatic-1.0-r1 (26 Nov 2008)
+
+ 26 Nov 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/spectromatic-1.0-makefile.patch, metadata.xml,
+ +spectromatic-1.0-r1.ebuild:
+ Fix installation for man files, cleaned ebuild and propagate cflags
13 Feb 2008; Markus Dittrich <markusle@gentoo.org>
spectromatic-1.0.ebuild:
diff --git a/sci-visualization/spectromatic/files/spectromatic-1.0-makefile.patch b/sci-visualization/spectromatic/files/spectromatic-1.0-makefile.patch
new file mode 100644
index 000000000000..941cb3bd39da
--- /dev/null
+++ b/sci-visualization/spectromatic/files/spectromatic-1.0-makefile.patch
@@ -0,0 +1,43 @@
+--- spectromatic-1.0/Makefile 2002-03-30 05:17:34.000000000 +0000
++++ spectromatic-1.0.new/Makefile 2008-11-26 10:43:15.910065276 +0000
+@@ -1,33 +1,29 @@
+ # Makefile for spectromatic
+
+-CFLAGS = -O2 -Wall
+ LIBS = -lgsl -lgslcblas -lpng -lm
+ DESTDIR =
+ TOPLEVEL_HOME = /usr
+
+-CC = gcc -I.
+-
+ SRC = spectromatic.c wave.c
+
+ OBJ = $(SRC:.c=.o)
+
+ TARGET = spectromatic
+
+-install: all
+- mkdir -p $(DESTDIR)$(TOPLEVEL_HOME)/bin
+- mkdir -p $(DESTDIR)$(TOPLEVEL_HOME)/man/man1
+- install -o root -g root -m 0755 spectromatic $(DESTDIR)$(TOPLEVEL_HOME)/bin
+- install -o root -g root -m 0644 man/spectromatic.1 $(DESTDIR)$(TOPLEVEL_HOME)/man/man1
+-
+ all: $(OBJ)
+ $(CC) -o $(TARGET) $(OBJ) $(LIBS)
+- strip $(TARGET)
++
++install: all
++ mkdir -p $(DESTDIR)$(TOPLEVEL_HOME)/bin
++ mkdir -p $(DESTDIR)$(TOPLEVEL_HOME)/share/man/man1
++ install -m 0755 spectromatic $(DESTDIR)$(TOPLEVEL_HOME)/bin
++ install -m 0644 man/spectromatic.1 $(DESTDIR)$(TOPLEVEL_HOME)/share/man/man1
+
+ clean:
+ $(RM) $(TARGET) $(OBJ)
+
+ .c.o:
+- $(CC) $(CFLAGS) -c $<
++ $(CC) $(CFLAGS) -I. -c $<
+
+ .o:
+ $(CC) $< $(LIBS) -o $@
diff --git a/sci-visualization/spectromatic/metadata.xml b/sci-visualization/spectromatic/metadata.xml
index b229aec85b8f..cbca6963eeed 100644
--- a/sci-visualization/spectromatic/metadata.xml
+++ b/sci-visualization/spectromatic/metadata.xml
@@ -2,4 +2,15 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>sci</herd>
+<longdescription lang="en">
+ Spectromatic is a program for generating spectrograms from audio
+ files. Spectrograms are a form of simple time-frequency analysis which
+ lets you see how the distribution of energy at different frequencies
+ in an audio stream change over time. For example, if you play a scale
+ on a musical instrument, you will see a climbing and/or descending
+ pattern of blobs as you move from left to right.
+ Spectromatic reads its input as mono or stereo 16-bit wave files, and
+ writes the output image to an elongated PNG image (colour for stereo,
+ grayscale for mono audio).
+</longdescription>
</pkgmetadata>
diff --git a/sci-visualization/spectromatic/spectromatic-1.0-r1.ebuild b/sci-visualization/spectromatic/spectromatic-1.0-r1.ebuild
new file mode 100644
index 000000000000..53d42ab5cc17
--- /dev/null
+++ b/sci-visualization/spectromatic/spectromatic-1.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/spectromatic/spectromatic-1.0-r1.ebuild,v 1.1 2008/11/26 10:48:57 bicatali Exp $
+
+inherit eutils
+
+MY_P="spectromatic_1.0-1"
+
+DESCRIPTION="Generates time-frequency analysis images from wav files"
+HOMEPAGE="http://ieee.uow.edu.au/~daniel/software/spectromatic/"
+SRC_URI="http://ieee.uow.edu.au/~daniel/software/spectromatic/dist/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="bindist"
+
+DEPEND="media-libs/libpng
+ !bindist? ( sci-libs/gsl )
+ bindist? ( <sci-libs/gsl-1.10 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ epatch "${FILESDIR}"/${P}-stringliteral.patch
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README
+}