summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-03-05 18:41:13 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-03-05 18:41:13 +0000
commit897f94e0c98cee65abb6aff364b2a65f9c8c824f (patch)
treec62c271718d90d58dcf8a8398b8b5def95673f6d /sci-visualization/spyview
parentVersion bump. (diff)
downloadgentoo-2-897f94e0c98cee65abb6aff364b2a65f9c8c824f.tar.gz
gentoo-2-897f94e0c98cee65abb6aff364b2a65f9c8c824f.tar.bz2
gentoo-2-897f94e0c98cee65abb6aff364b2a65f9c8c824f.zip
Moved from sunrise overlay. Fixes bug #283449
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'sci-visualization/spyview')
-rw-r--r--sci-visualization/spyview/ChangeLog11
-rw-r--r--sci-visualization/spyview/files/spyview-includes.patch31
-rw-r--r--sci-visualization/spyview/metadata.xml12
-rw-r--r--sci-visualization/spyview/spyview-20100203.ebuild45
4 files changed, 99 insertions, 0 deletions
diff --git a/sci-visualization/spyview/ChangeLog b/sci-visualization/spyview/ChangeLog
new file mode 100644
index 000000000000..921154591b78
--- /dev/null
+++ b/sci-visualization/spyview/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-visualization/spyview
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/spyview/ChangeLog,v 1.1 2010/03/05 18:41:11 hwoarang Exp $
+
+*spyview-20100203 (05 Mar 2010)
+
+ 05 Mar 2010; Markos Chandras <hwoarang@gentoo.org>
+ +spyview-20100203.ebuild, +files/spyview-includes.patch, +metadata.xml:
+ Moved from sunrise overlay. Thanks to Andreas K. Huettel (dilfridge)
+ <mail@akhuettel.de> for the ebuild. Fixes bug #283449
+
diff --git a/sci-visualization/spyview/files/spyview-includes.patch b/sci-visualization/spyview/files/spyview-includes.patch
new file mode 100644
index 000000000000..fa76d1b8562e
--- /dev/null
+++ b/sci-visualization/spyview/files/spyview-includes.patch
@@ -0,0 +1,31 @@
+diff -r -u spyview-2009-12-14-09_17.orig/spyview/Fl_Listbox.C spyview-2009-12-14-09_17/spyview/Fl_Listbox.C
+--- spyview-2009-12-14-09_17.orig/spyview/Fl_Listbox.C 2008-09-05 16:23:20.000000000 +0200
++++ spyview-2009-12-14-09_17/spyview/Fl_Listbox.C 2010-01-05 15:54:46.000000000 +0100
+@@ -1,4 +1,5 @@
+ #include "Fl_Listbox.H"
++#include <stdio.h>
+
+ Fl_Listbox::Fl_Listbox(int x, int y, int w, int h, const char *l) : Fl_Table(x,y,w,h,l)
+ {
+diff -r -u spyview-2009-12-14-09_17.orig/spyview/ImageData.H spyview-2009-12-14-09_17/spyview/ImageData.H
+--- spyview-2009-12-14-09_17.orig/spyview/ImageData.H 2009-12-14 09:15:33.000000000 +0100
++++ spyview-2009-12-14-09_17/spyview/ImageData.H 2010-01-04 22:59:38.000000000 +0100
+@@ -5,6 +5,7 @@
+ #include <FL/Fl_Output.H>
+
+ #include <string>
++#include <stdio.h>
+ #include <string.h>
+ #include <stdlib.h>
+ #include <vector>
+diff -r -u spyview-2009-12-14-09_17.orig/spyview/gp_to_mat.C spyview-2009-12-14-09_17/spyview/gp_to_mat.C
+--- spyview-2009-12-14-09_17.orig/spyview/gp_to_mat.C 2009-08-28 23:46:45.000000000 +0200
++++ spyview-2009-12-14-09_17/spyview/gp_to_mat.C 2010-01-05 16:47:03.000000000 +0100
+@@ -5,6 +5,7 @@
+ #include <map>
+ #include <math.h>
+ #include <string.h>
++#include <stdio.h>
+ #include "../config.h"
+
+ using namespace std;
diff --git a/sci-visualization/spyview/metadata.xml b/sci-visualization/spyview/metadata.xml
new file mode 100644
index 000000000000..87afd6e36004
--- /dev/null
+++ b/sci-visualization/spyview/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+<email>hwoarang@gentoo.org</email>
+<name>Markos Chandras</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/sci-visualization/spyview/spyview-20100203.ebuild b/sci-visualization/spyview/spyview-20100203.ebuild
new file mode 100644
index 000000000000..49f9fd58d22e
--- /dev/null
+++ b/sci-visualization/spyview/spyview-20100203.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header $
+
+EAPI=2
+
+inherit base flag-o-matic eutils multilib
+
+DESCRIPTION="Interactive plotting program"
+HOMEPAGE="http://kavli.nano.tudelft.nl/~gsteele/spyview/"
+SRC_URI="http://kavli.nano.tudelft.nl/~gsteele/${PN}/versions/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND=">=dev-libs/boost-1.39
+ media-libs/netpbm
+ >=x11-libs/fltk-1.1.9:1.1
+ app-text/ghostscript-gpl"
+
+DEPEND="${COMMON_DEPEND}
+ sys-apps/groff"
+
+RDEPEND="${COMMON_DEPEND}
+ sci-visualization/gnuplot"
+
+S=${WORKDIR}/spyview-2010-02-03-11_57
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-includes.patch
+
+ append-cflags $(fltk-config --cflags)
+ append-cxxflags $(fltk-config --cxxflags) -I/usr/include/netpbm
+
+ # append-ldflags $(fltk-config --ldflags)
+ # this one leads to an insane amount of warnings
+
+ append-ldflags -L/usr/$(get_libdir)/fltk-1.1
+}
+
+src_configure() {
+ econf --datadir=/usr/share/spyview
+}