summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-06-21 14:50:03 +0000
committerJustin Lecher <jlec@gentoo.org>2012-06-21 14:50:03 +0000
commitd4ac4a1e49dc87417daa3068055798742877d82f (patch)
treec687bf3e7f3ef244b2904c4dd6fa738bb6a4da34 /sci-visualization/xd3d/xd3d-8.3.1.ebuild
parentStable for HPPA (bug #418751). (diff)
downloadgentoo-2-d4ac4a1e49dc87417daa3068055798742877d82f.tar.gz
gentoo-2-d4ac4a1e49dc87417daa3068055798742877d82f.tar.bz2
gentoo-2-d4ac4a1e49dc87417daa3068055798742877d82f.zip
sci-visualization/xd3d: Respect CC, handle examples through USE=examples, use zlib.h instead of bundled zutil.h, #422765
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'sci-visualization/xd3d/xd3d-8.3.1.ebuild')
-rw-r--r--sci-visualization/xd3d/xd3d-8.3.1.ebuild37
1 files changed, 23 insertions, 14 deletions
diff --git a/sci-visualization/xd3d/xd3d-8.3.1.ebuild b/sci-visualization/xd3d/xd3d-8.3.1.ebuild
index e2a26ee825da..f2d163435db8 100644
--- a/sci-visualization/xd3d/xd3d-8.3.1.ebuild
+++ b/sci-visualization/xd3d/xd3d-8.3.1.ebuild
@@ -1,33 +1,40 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/xd3d/xd3d-8.3.1.ebuild,v 1.9 2011/06/21 14:30:51 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/xd3d/xd3d-8.3.1.ebuild,v 1.10 2012/06/21 14:50:03 jlec Exp $
+
+EAPI=4
-EAPI=2
inherit eutils fortran-2 toolchain-funcs
DESCRIPTION="scientific visualization tool"
HOMEPAGE="http://www.cmap.polytechnique.fr/~jouve/xd3d/"
SRC_URI="mirror://gentoo/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc ppc64 x86"
-IUSE=""
+IUSE="examples"
RDEPEND="
virtual/fortran
-x11-libs/libXpm"
+ x11-libs/libXpm"
DEPEND="${RDEPEND}
app-shells/tcsh"
src_prepare() {
- epatch "${FILESDIR}"/${P}-gentoo.diff
- epatch "${FILESDIR}"/${P}-parallel.patch
- epatch "${FILESDIR}"/${P}-rotated.patch
+ epatch \
+ "${FILESDIR}"/${P}-gentoo.diff \
+ "${FILESDIR}"/${P}-parallel.patch \
+ "${FILESDIR}"/${P}-rotated.patch
+ sed \
+ -e 's:"zutil.h":<zlib.h>:g' \
+ -i src/qlib/timestuff.c || die
}
src_configure() {
- export FC=$(tc-getFC)
- sed -e "s:##D##:${D}:" \
+ tc-export FC CC
+ sed \
+ -e "s:##D##:${D}:" \
-e "s:##lib##:$(get_libdir):" \
-i RULES.gentoo \
|| die "failed to set up RULES.gentoo"
@@ -36,12 +43,14 @@ src_configure() {
src_install() {
dodir /usr/bin
- emake install || die "emake install failed"
+ emake install
dodoc BUGS CHANGELOG FAQ FORMATS README
insinto /usr/share/doc/${PF}
- doins Manuals/* || die
+ doins Manuals/*
- insinto /usr/share/doc/${PF}/examples
- doins -r Examples/* || die
+ if use examples; then
+ insinto /usr/share/doc/${PF}/
+ doins -r Examples
+ fi
}