summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-09-03 15:57:09 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-09-03 15:57:09 +0000
commit3964ef6e6d40b6a6ace7e3bafc4afa889ff4c094 (patch)
tree36ff54bfbd11dc3aa407f1b36ed69db1ddce33bd /sci-visualization
parentskip installing xv thumbnails (diff)
downloadgentoo-2-3964ef6e6d40b6a6ace7e3bafc4afa889ff4c094.tar.gz
gentoo-2-3964ef6e6d40b6a6ace7e3bafc4afa889ff4c094.tar.bz2
gentoo-2-3964ef6e6d40b6a6ace7e3bafc4afa889ff4c094.zip
Added a patch for qt4, hopefully fixing bug #236435
(Portage version: 2.2_rc8/cvs/Linux 2.6.23-gentoo-r9 x86_64)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/hippodraw/ChangeLog6
-rw-r--r--sci-visualization/hippodraw/files/hippodraw-1.21.3-qt4.patch34
-rw-r--r--sci-visualization/hippodraw/hippodraw-1.21.3-r1.ebuild3
3 files changed, 41 insertions, 2 deletions
diff --git a/sci-visualization/hippodraw/ChangeLog b/sci-visualization/hippodraw/ChangeLog
index e1d0248cec35..5a8ebe95d89d 100644
--- a/sci-visualization/hippodraw/ChangeLog
+++ b/sci-visualization/hippodraw/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-visualization/hippodraw
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/hippodraw/ChangeLog,v 1.9 2008/08/29 09:44:30 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/hippodraw/ChangeLog,v 1.10 2008/09/03 15:57:08 bicatali Exp $
+
+ 03 Sep 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/hippodraw-1.21.3-qt4.patch, hippodraw-1.21.3-r1.ebuild:
+ Added a patch for qt4, hopefully fixing bug #236435
29 Aug 2008; Sébastien Fabbro <bicatali@gentoo.org>
-hippodraw-1.19.1.ebuild, -hippodraw-1.21.3.ebuild:
diff --git a/sci-visualization/hippodraw/files/hippodraw-1.21.3-qt4.patch b/sci-visualization/hippodraw/files/hippodraw-1.21.3-qt4.patch
new file mode 100644
index 000000000000..0225968b1bf0
--- /dev/null
+++ b/sci-visualization/hippodraw/files/hippodraw-1.21.3-qt4.patch
@@ -0,0 +1,34 @@
+--- qt/QtApp.cxx.orig 2008-09-03 16:49:04.000000000 +0100
++++ qt/QtApp.cxx 2008-09-03 16:50:32.000000000 +0100
+@@ -34,13 +34,13 @@
+
+ QtApp * QtApp::s_instance = 0;
+
+-QtApp::QtApp ( int argc, char** argv)
++QtApp::QtApp ( int & argc, char** argv)
+ : QApplication ( argc, argv )
+ {
+ init ();
+ }
+
+-QtApp::QtApp ( int argc, char** argv, bool gui )
++QtApp::QtApp ( int & argc, char** argv, bool gui )
+ : QApplication ( argc, argv, gui )
+ {
+ init ();
+--- qt/QtApp.h.orig 2008-09-03 16:49:50.000000000 +0100
++++ qt/QtApp.h 2008-09-03 16:50:17.000000000 +0100
+@@ -79,11 +79,11 @@
+
+ /** A Constructor that always enables the GUI.
+ */
+- QtApp ( int argc, char ** argv );
++ QtApp ( int & argc, char ** argv );
+
+ /** A Constructor that enables the GUI optionally.
+ */
+- QtApp ( int argc, char ** argv, bool gui );
++ QtApp ( int & argc, char ** argv, bool gui );
+
+ /** The destructor. */
+ ~QtApp();
diff --git a/sci-visualization/hippodraw/hippodraw-1.21.3-r1.ebuild b/sci-visualization/hippodraw/hippodraw-1.21.3-r1.ebuild
index afbab5de6f87..b8fbc81f8d7c 100644
--- a/sci-visualization/hippodraw/hippodraw-1.21.3-r1.ebuild
+++ b/sci-visualization/hippodraw/hippodraw-1.21.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/hippodraw/hippodraw-1.21.3-r1.ebuild,v 1.4 2008/07/27 22:25:40 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/hippodraw/hippodraw-1.21.3-r1.ebuild,v 1.5 2008/09/03 15:57:08 bicatali Exp $
EAPI=1
@@ -55,6 +55,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-test-fix.patch
epatch "${FILESDIR}"/${P}-minuit2.patch
epatch "${FILESDIR}"/${P}-wcslib.patch
+ epatch "${FILESDIR}"/${P}-qt4.patch
# fix the install doc directory to gentoo's one
local docdir=/usr/share/doc/${PF}