summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2009-07-28 15:16:45 +0000
committerMarkus Dittrich <markusle@gentoo.org>2009-07-28 15:16:45 +0000
commit4d2b80e3f718d11f881b4e5a067e4e78cbe307ce (patch)
tree3adbdbc1439c652d27a07f94420933adb182f79b /sci-visualization
parentx11-drivers -> x11. (diff)
downloadgentoo-2-4d2b80e3f718d11f881b4e5a067e4e78cbe307ce.tar.gz
gentoo-2-4d2b80e3f718d11f881b4e5a067e4e78cbe307ce.tar.bz2
gentoo-2-4d2b80e3f718d11f881b4e5a067e4e78cbe307ce.zip
Added patch and fixes to ebuild to remove several install location snafus.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/paraview/ChangeLog7
-rw-r--r--sci-visualization/paraview/files/paraview-3.6.1-no-doc-finder.patch18
-rw-r--r--sci-visualization/paraview/paraview-3.6.1.ebuild16
3 files changed, 39 insertions, 2 deletions
diff --git a/sci-visualization/paraview/ChangeLog b/sci-visualization/paraview/ChangeLog
index b6d445ecc2c9..04afc6ad5dec 100644
--- a/sci-visualization/paraview/ChangeLog
+++ b/sci-visualization/paraview/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-visualization/paraview
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/paraview/ChangeLog,v 1.38 2009/07/27 09:32:19 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/paraview/ChangeLog,v 1.39 2009/07/28 15:16:45 markusle Exp $
+
+ 28 Jul 2009; Markus Dittrich <markusle@gentoo.org> paraview-3.6.1.ebuild,
+ +files/paraview-3.6.1-no-doc-finder.patch:
+ Added patch and fixes to ebuild to remove several install location
+ snafus.
27 Jul 2009; Markus Dittrich <markusle@gentoo.org> paraview-3.6.1.ebuild:
Have paraview block vtk until a better solution is found (#279264).
diff --git a/sci-visualization/paraview/files/paraview-3.6.1-no-doc-finder.patch b/sci-visualization/paraview/files/paraview-3.6.1-no-doc-finder.patch
new file mode 100644
index 000000000000..a98d004197d0
--- /dev/null
+++ b/sci-visualization/paraview/files/paraview-3.6.1-no-doc-finder.patch
@@ -0,0 +1,18 @@
+diff -Naur ParaView3.old/Applications/Client/CMakeLists.txt ParaView3/Applications/Client/CMakeLists.txt
+--- ParaView3.old/Applications/Client/CMakeLists.txt 2009-07-20 15:36:01.000000000 -0400
++++ ParaView3/Applications/Client/CMakeLists.txt 2009-07-28 09:28:12.000000000 -0400
+@@ -128,10 +128,10 @@
+ "${CMAKE_CURRENT_BINARY_DIR}/CMake/tmp/pqClientDocFinder.txt"
+ @ONLY
+ IMMEDIATE)
+- INSTALL(
+- FILES "${CMAKE_CURRENT_BINARY_DIR}/CMake/tmp/pqClientDocFinder.txt"
+- DESTINATION ${PV_INSTALL_BIN_DIR}
+- COMPONENT Runtime)
++ # INSTALL(
++ # FILES "${CMAKE_CURRENT_BINARY_DIR}/CMake/tmp/pqClientDocFinder.txt"
++ # DESTINATION ${PV_INSTALL_BIN_DIR}
++ # COMPONENT Runtime)
+ ENDIF(NOT PV_INSTALL_NO_RUNTIME)
+
+ IF(BUILD_TESTING)
diff --git a/sci-visualization/paraview/paraview-3.6.1.ebuild b/sci-visualization/paraview/paraview-3.6.1.ebuild
index badc7b7e965a..b3c52b96f66e 100644
--- a/sci-visualization/paraview/paraview-3.6.1.ebuild
+++ b/sci-visualization/paraview/paraview-3.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/paraview/paraview-3.6.1.ebuild,v 1.6 2009/07/27 09:32:19 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/paraview/paraview-3.6.1.ebuild,v 1.7 2009/07/28 15:16:45 markusle Exp $
EAPI="2"
@@ -59,6 +59,7 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-assistant.patch
epatch "${DISTDIR}"/${P}-openfoam-r120.patch.bz2
epatch "${DISTDIR}"/${P}-openfoam-gpl-r120.patch.bz2
+ epatch "${FILESDIR}"/${P}-no-doc-finder.patch
if use hdf5 && has_version '>=sci-libs/hdf5-1.8.0'; then
epatch "${FILESDIR}"/${P}-hdf-1.8.3.patch
@@ -69,6 +70,10 @@ src_prepare() {
-i VTK/Rendering/vtkOpenGLRenderWindow.cxx \
|| die "Failed to fix GL issues."
+ # fix plugin install directory
+ sed -e "s:\${PV_INSTALL_BIN_DIR}/plugins:/usr/${PVLIBDIR}/plugins:" \
+ -i CMake/ParaViewPlugins.cmake \
+ || die "Failed to fix plugin install directories"
}
src_compile() {
@@ -199,6 +204,15 @@ src_install() {
# set up the environment
echo "LDPATH=/usr/${PVLIBDIR}" >> "${T}"/40${PN}
doenvd "${T}"/40${PN}
+
+ # move and remove some of the files that should not be
+ # in /usr/bin
+ dohtml "${D}/usr/bin/about.html" && rm -f "${D}/usr/bin/about.html" \
+ || die "Failed to move about.html into doc dir"
+
+ # this binary does not work and probably should not be installed
+ rm -f "${D}/usr/bin/vtkSMExtractDocumentation" \
+ || die "Failed to remove vtkSMExtractDocumentation"
}
pkg_postinst() {